Strange/Lock Out From SharePoint

Copper Contributor

I have been making databases a while and been helping my cousin on the other side of the country out via an Access front end linked to a SharePoint backend.  Its been working fine for about a year or so.


Last week I was asked to add some additional tables and then merge the data into the original SharePoint.  I thought I would download the existing data/Tables from SharePoint work locally to test and create the work then upload the new tables when complete and transfer the front end to her.


Good plan...Until...I realised I hadnt needed to log in so long I forgot my password to her SharePoint. No problem I had that reset and thought I go.


Oh no.  Now I am getting a very handy pop up  that asks for my email address for accessing the SharePoint site, and then on inputting it, it tells me I cant go in as LockOut.png

No idea what to do from here.  Any suggestions please?


13 Replies


This problem seems to have more to do with SharePoint than Access. And, since the focus of this forum is MS Access, not SharePoint, you're more likely to get attention from specialists in SharePoint by re-posting in a SharePoint focused forum. Folks here tend to know Access pretty well, but not so much about SharePoint.


Accounts and passwords and different email addresses for SharePoint is something of a dark art, IMO, but to a SharePoint expert, it may be less obscure.

@George_Hepworth I think it is narrowed down to the Linked Table Manager.  From what I can see the Linked Table Manager is keeping a connection that I cant remove.  Anyone know how to completely remove the link from Linked Table Manager?



That may be the problem, but from the original description, I am not sure it follows.


However, to be sure, you could try these steps.

  • Create a new accdb.
  • Import all objects from this one EXCEPT for the tables.
  • Open the new accdb, holding down the shift key to  by-pass any start up code.
  • Relink the new accdb to the existing SharePoint Lists.

Does that resolve the problem?

@George_Hepworth Lockout1.png

This is the issue I am meaning.


If I try and open the Sharepoint Linked Manager loads the existing link.  No matter what I do. I am assuming this is some existing link perhaps in registry and this is preventing the link being reestablished?


If I click through it will then ask for user name and we go dancing down a rabbit hole to the existing connection blah blah.


Thank you for clarifying the specific circumstances.

What happens if you go through this option:



Same ring a rosy
I forgot; did you create a new accdb and try to link to the SP lists from it?
Yes I tried that, and had the same result. As I said it seems to me I need to be able to delete the old connection completely from the Linked Table manager and start again. However, I cannot, so far, discover how this can be done.
best response confirmed by GoodLookingFella (Copper Contributor)

@George_Hepworth Thanks. I won't have time to look at this possibility till this time tomorrow, unfortunately.



Well, if this works, it is truly embarrassing. I had COMPLETELY forgotten about this little code snippet and, more importantly, why I have it. My apologies.


This code was written back around 2010 when MS was trying to develop Access Web Databases, which used SP tables as the back end. That approach was deprecated. However, I wonder if this can help you here. 


Public Function RemoveSPPublish() As Boolean


    Dim db AS DAO.Database


    Set db = CurrentDB


    RemoveSPPublish = False
    db.Properties.Delete ("PublishURL")
    RemoveSPPublish = True


End Function


It is something of a long shot because I think you actually have a different problem, but it's worth trying.


This worked on the second try. For some reason, Access had a secondary account signed in. I am unclear why. My main account was mine, however, when I signed out there were my cousins name as an account, although it was yellow flagged !. I am unclear what happened...what I do know is after clearing the secondary connection it allowed me to relog in and the data is now visible.

Thanks for the patience, and I sincerely appreciate the help.
I'm happy to hear you solved the problem, but embarrassed it took me so long to finally recall that little trick.
1 best response

Accepted Solutions
best response confirmed by GoodLookingFella (Copper Contributor)