Home

axis number formatting on mac

%3CLINGO-SUB%20id%3D%22lingo-sub-307979%22%20slang%3D%22en-US%22%3Eaxis%20number%20formatting%20on%20mac%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-307979%22%20slang%3D%22en-US%22%3E%3CP%3Ehi%20community!%20i'm%20having%20trouble%20with%20the%20number%20formatting%20of%20the%20axis%20in%20charts%20(excel).%20but%20let%20me%20get%20the%20basics%20out%20first%3A%3C%2FP%3E%3CP%3Ei'm%20working%20on%20a%20microsoft%20office%20356%20pro%20plus%20licence%20on%20a%20mac.%20the%20number%20formatting%20on%20the%20os-level%20is%20british%2C%20with%20the%20advanced%20settings%20set%20to%20point%20as%20decimal%20separator.%20the%20number%20format%20in%20excel%20is%20the%20same%3A%20point%20as%20separator.%20this%20works%20perfectly%20in%20all%20charts.%20i%20can%20use%20functions%20and%20everything%2C%20so%20he%20gets%20my%20number%20formatting.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Enow%20here%20is%20the%20problem%3A%20if%20i%20plot%20anything%20in%20a%20chart%2C%20the%20axis%20will%20have%20a%20number%20formatting%20with%20a%20comma%20separator.%20even%20though%20the%20numbers%20on%20which%20the%20chart%20is%20based%20have%20the%20british%20format%20(point%20separator)%2C%20the%20chart%20treats%20them%20like%20german%20format%20(comma%20separator).%20this%20is%20also%20visible%20when%20hovering%20over%20the%20plot%3A%20the%20value%20preview%20will%20be%20depicted%20in%20german%20format.%3C%2FP%3E%3CP%3Eformatting%20the%20axis%26nbsp%3Bmanually%26nbsp%3Bdoesn't%20produce%20the%20expected%20results%20either.%20it%20offers%20formats%20like%20%23.%23%230%2C0%20but%20if%20i%20try%20to%20set%20%23%2C%23%230.0%20it%20doesn't%20accept%20my%20input.%20upon%20hitting%20enter%2C%20my%20input%20is%20automatically%20changed%20to%20%23%2C%23%2300%20and%20the%20result%20is%20accordingly.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ethe%20microsoft%20office%20support%2C%20though%20very%20friendly%2C%20felt%20he%20didn't%20know%20a%20solution%20and%20pointed%20me%20towards%20this%20forum.%20do%20you%20have%20a%20suggestion%3F%20thanks%20in%20advance%20anyway%20%3CLI-EMOJI%20id%3D%22lia_slightly-smiling-face%22%20title%3D%22%3Aslightly_smiling_face%3A%22%3E%3C%2FLI-EMOJI%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-307979%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ECharting%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EExcel%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EExcel%20on%20Mac%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOffice%20365%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-308434%22%20slang%3D%22en-US%22%3ERe%3A%20axis%20number%20formatting%20on%20mac%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-308434%22%20slang%3D%22en-US%22%3E%3CP%3Elol%20ok%20i%20fixed%20the%20problem.%3C%2FP%3E%3CP%3Efun%20fact%3A%20if%20you%20install%20office%2C%20it%20seems%20to%20permanently%20remember%20the%20language%2Fnumber%20format%20of%20your%20os.%20another%20fun%20fact%3A%20this%20also%20applies%20to%20the%20new%20fancy%20mac%20os%20mojave%20dark%20mode.%20i%20didn't%20notice%20that%20before%2C%20but%20all%20other%20apps%20complied%20with%20dark%20mode%2C%20except%20office%20apps.%3C%2FP%3E%3CP%3Ethis%20means%20office%20won't%20switch%26nbsp%3Bsome%20setting%2C%20even%20if%20you%20change%20them%26nbsp%3Bon%20all%20levels.%20in%20my%20eyes%2C%20that's%20a%20bug%2C%20but%20hey%2C%20if%20you%20want%20to%20convince%20me%20it's%20actually%20a%20feature%2C%20i'm%20all%20ears%20%3CLI-EMOJI%20id%3D%22lia_winking-face%22%20title%3D%22%3Awinking_face%3A%22%3E%3C%2FLI-EMOJI%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Eso%20my%20fix%3A%20uninstall%20and%20reinstall%20office%20AFTER%20you%20set%20all%20os-settings%20as%20desired.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Enote%20to%20the%20microsoft%20it-gods%3A%20create%20a%20ticket%20%3CLI-EMOJI%20id%3D%22lia_winking-face%22%20title%3D%22%3Awinking_face%3A%22%3E%3C%2FLI-EMOJI%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
janedoe19
New Contributor

hi community! i'm having trouble with the number formatting of the axis in charts (excel). but let me get the basics out first:

i'm working on a microsoft office 356 pro plus licence on a mac. the number formatting on the os-level is british, with the advanced settings set to point as decimal separator. the number format in excel is the same: point as separator. this works perfectly in all charts. i can use functions and everything, so he gets my number formatting.

 

now here is the problem: if i plot anything in a chart, the axis will have a number formatting with a comma separator. even though the numbers on which the chart is based have the british format (point separator), the chart treats them like german format (comma separator). this is also visible when hovering over the plot: the value preview will be depicted in german format.

formatting the axis manually doesn't produce the expected results either. it offers formats like #.##0,0 but if i try to set #,##0.0 it doesn't accept my input. upon hitting enter, my input is automatically changed to #,##00 and the result is accordingly.

 

the microsoft office support, though very friendly, felt he didn't know a solution and pointed me towards this forum. do you have a suggestion? thanks in advance anyway :)

1 Reply

lol ok i fixed the problem.

fun fact: if you install office, it seems to permanently remember the language/number format of your os. another fun fact: this also applies to the new fancy mac os mojave dark mode. i didn't notice that before, but all other apps complied with dark mode, except office apps.

this means office won't switch some setting, even if you change them on all levels. in my eyes, that's a bug, but hey, if you want to convince me it's actually a feature, i'm all ears ;)

 

so my fix: uninstall and reinstall office AFTER you set all os-settings as desired.

 

note to the microsoft it-gods: create a ticket ;)

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
46 Replies
Extentions Synchronization
Deleted in Discussions on
3 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
30 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
13 Replies