SSL wildcard Certificate

Copper Contributor

I think i have tried everything with i have found to create a  wildcard certificate for horizon for the past several days. and nothing has worked.  i get errors like


"This site can’t provide a secure connection localhost uses an unsupported protocol."  or



all which do not allow the interface to come up.   


i have even tried  the following link, all which have not been fruitful


Creating a wildcard webserver certificate with your internal Microsoft CA | Robbie Roberts Blog OCS,...


now i am creating the certificate Poweshell with the script below which works on Windows 10 but not Windows server 2012 R2 


$date_now = Get-Date

$extended_date = $date_now.AddYears(99)

$cert = New-SelfSignedCertificate  `

    -Type Custom `

    -certstorelocation cert:\localmachine\my `

    -dnsname *.domain.local `

    -KeyUsage DigitalSignature, KeyEncipherment `

    -KeySpec KeyExchange -Subject "C=US, ST=IO, L=IOCity, CN=*.domain.local" `

    -NotAfter $extended_date `

    -KeyLength 4096 `

    -FriendlyName vdm



$pwd = ConvertTo-SecureString -String '$password' -Force -AsPlainText

$path = 'cert:\localMachine\my\' + $cert.thumbprint

Export-PfxCertificate -cert $path -FilePath c:\temp\ssl\teltrium-local.pfx -Password $pwd


the certificate is created  and i added to the trusted site. the only difference between this an the one applied at setup is the Key Usage has  a yellow exclamation point.



Does anyone know what I am doing incorrectly. is there an "IDIOTS Guide" somewhere?    Any assistance is greatly appreciated. thank you in advance.

0 Replies