Issues with Remote Desktop Web Client (HTML5)

Copper Contributor

Hey all,


I'm having a strange issue after implementing the Remote Desktop HTML 5 Client for one of our RDS instances. Everything is working up until the actual act of opening an application which we then receive the following error:




We have performed all of the verification steps to ensure that the set up is configured correctly and haven't had any issues out of other RDS instances with the same set up. Below is a list of everything that we have verified:


  • The RDS server (singular server, running all RDS roles) is Server 2019 and is entirely up to date with Windows Updates.
  • The public trusted certificates are configured correctly.
  • Licensing is set to per-user client access, not device level.
  • Verified that the RDS server's NPS is registered with Active Directory.
  • Reviewed all appropriate connection and authorization access policies, verified that these are looking great.

We receive this error when attempting to access locally using the FQDN as well as externally over the internet as well. When performing a log capture we can see the following error:


2022-12-22T20:01:12.622Z WebSocketTransport(ERR): WebSocket error received for url=wss://removed.for.confidentiality:443/remoteDesktopGateway?CorId=%7B9ca382bc-96b8-444e-b22c-3e5cbc370000%7D&ConId=%7B299f9980-d47f-44e9-86e7-479750c95ab4%7D&ClGen=HTML%3D1&ClBld=Type%3DRdClient%3B%20Build%3Dprivate&AuthS=SSPI_NTLM
websockettransport.cpp(304): OnErrorFromJS()


Does anyone have any ideas or have ran into this issue before? The results online are very scarce and every recommendation that has worked for other doesn't appear to work in our case.


Assistance would be greatly appreciated!

5 Replies
We are facing the same problem. Did you manage to find the solution?
Hi, you wrote: "singular server, running all RDS roles"
Does that mean you have also installed the RD Gateway on the server?

If not you have to make some additional configuration on the webclient to make it work.
step: Connecting to RD Broker without RD Gateway in Windows Server 2019

I have the same problem. I also have a single server running all RDS roles. The error is not encountered when the rdp file is used to access though, so the issue is isolated to the webclient.

Does anyone have a solution for this?



In my case the issue was caused by using an untrusted web certificate on IIS-side. After installing RootCA client-side, the issue went away. Temporarily omitting security warning in the browser was insufficient. I hope this will help someone having a similar issue.

@baginenny Thanks for replying.


I've tried re-adding the SSL certificate on IIS and have added it on the Remote Desktop Gateway but the issue persists.