Neverending "The term ..... is not recognized as the name of a cmdlet"

Copper Contributor

Hello, I'm sure this is probably Powershell 101 to most but my google skills are letting me down.  I spend WAY too much time battling the "The term ..... is not recognized as the name of a cmdlet" error and I just haven't been able to learn how to find why, or which module I need to do what looks like a simple thing in Microsoft articles.


For just ONE example, while working on a Teams/Skype issue leads me to an article that indicates I should run:

Get-CsTenantFederationConfiguration (or: Get-CsTenant, etc)


Microsoft indicates that the "MicrosoftTeams" module now incorporates all things Skype , so I install/load/connect the MicrosoftTeams module and get the dreaded "The term ..... is not recognized as the name of a cmdlet". 


Please note that though I give this most recent Teams example, I run into this error elsewhere (Azure, INtune, Endpoint protection, Exchange, etc., etc., etc) as I try to figure out "what module", or version of which/what module a specific command is included in.  I'm sure there is some web page or something that answers this but darned if I've figured out how to approach solving this issue when it arises.


Any help in understanding what I'm sure are otherwise basic powershell steps needed to troubleshoot this process would be greatly appreciated!





1 Reply


Just to confirm one thing, for example, the exchangeonline PS module,
if you first run Get-Module exchangeonlinemanagement -ListAvailable what the output will be

if you see the Exchange module and tried to run the command 

Get-Module exchangeonlinemanagement | Import-Module

are you able to run a related command such as Connect-ExchangeOnline