WAC will not connect to Windows 10 computer(s)

Occasional Contributor

I get THIS connection error:


Connecting to remote server xxx-203.domain.local failed with the following error message : WinRM cannot complete the operation. Verify that the specified computer name is valid, that the computer is accessible over the network, and that a firewall exception for the WinRM service is enabled and allows access from this computer. By default, the WinRM firewall exception for public profiles limits access to remote computers within the same local subnet. For more information, see the about_Remote_Troubleshooting Help topic.


Problem is: the name IS valid, the computer IS accessible over the network, the firewall exception IS enabled via Group Policy, then WinRM service is started via Group Policy, WinRM PS-remoting IS installed, I did winrm quickconfig on this device. I know this particular device has been rebooted.


What am I missing?? that should be done for WAC to touch this computer??


Thank you, Tom


7 Replies
Try running the following on the client machine

winrm enum winrm/config/listener

Look for the line "ListeningOn = ", does it have a valid IP or does it say NULL?

I went through this this morning and it turns out it was an old GPO that was set to filter out IP's under

Computer Configuration - Administrative Templates - Windows Components - Windows Remote Management (WinRM) - WinRM Service

IPV4 filter was filled in with IP's that were thought to filter what IP's to listen TO when they actually filter what IP's to listen ON.

If there are IP's listed, remove them and then just put * in the filter field. Update your GPO on the client and run the winrm enum command again. It should list the IP's available on the client machine.

@MrDecepticon Well I did have this configured to the local subnet range. I've changed it to *. I have to wait for group policy to update since I don't have direct access to the client machine. By this evening or tomorrow I should know if this works or not. Thank you!! :) tom

This didn't work either, still same error message. Can anyone suggest any other ways I can test winrm?? I don't have remote access to the particular Win10 computer unfortunately.

See the I can connect to some servers, but not others section of WAC troubleshooting.


The first diagnosis step is to try remote PowerShell from the console.

On the same machine where you have installed WAC, try:

Enter-PSSession xxx-203.domain.local



I get the same error, only in PowerShell red. Maybe I can do rsop to see if the relevant policy items are applying to this computer...??

If you get the same error in the console then it's a Remote PowerShell/WSMAN/WinRM configuration issue, unrelated to Windows Admin Center.

best response confirmed by tlyczko2 (Occasional Contributor)
I finally got it sussed with this link:
It helped me figure out that I needed to do some things in Group Policy then wait. I did all this last night and today I could touch the desired Win10 box. Now only to figure out various other things...Thank you, everyone!! :)