The version '2.8.1610.0' of the module 'SharePointPnPPowerShellOnline' is not catalogue signed

%3CLINGO-SUB%20id%3D%22lingo-sub-21444%22%20slang%3D%22en-US%22%3EThe%20version%20'2.8.1610.0'%20of%20the%20module%20'SharePointPnPPowerShellOnline'%20is%20not%20catalogue%20signed%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-21444%22%20slang%3D%22en-US%22%3E%3CP%3EHi%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENot%20sure%20if%20this%20related%20to%20the%20build%20of%20of%20this%20module%20or%20somthing%20I%20am%20doing%20-%20skipping%20the%20PublsherCheck%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EPS%20D%3A%5CPS%5CWSLOffice365%5CWSLOffice365AdminTasks%26gt%3B%20Install-Module%20SharePointPnPPowerShellOnline%20-Force%3CBR%20%2F%3EPackageManagement%5CInstall-Package%20%3A%20The%20version%20'2.8.1610.0'%20of%20the%20module%20'SharePointPnPPowerShellOnline'%20being%3CBR%20%2F%3Einstalled%20is%20not%20catalog%20signed.%20Ensure%20that%20the%20version%20'2.8.1610.0'%20of%20the%20module%3CBR%20%2F%3E'SharePointPnPPowerShellOnline'%20has%20the%20catalog%20file%20'SharePointPnPPowerShellOnline.cat'%20and%20signed%20with%20the%20same%3CBR%20%2F%3Epublisher%20'CN%3Dthawte%20Primary%20Root%20CA%2C%20OU%3D%22(c)%202006%20thawte%2C%20Inc.%20-%20For%20authorized%20use%20only%22%2C%20OU%3DCertification%3CBR%20%2F%3EServices%20Division%2C%20O%3D%22thawte%2C%20Inc.%22%2C%20C%3DUS'%20as%20the%20previously-installed%20module%20'2.8.1610.0'%20with%20version%3CBR%20%2F%3E'2.6.1608.0'%20under%20the%20directory%20'C%3A%5CProgram%3CBR%20%2F%3EFiles%5CWindowsPowerShell%5CModules%5CSharePointPnPPowerShellOnline%5C2.6.1608.0'.%20If%20you%20still%20want%20to%20install%20or%3CBR%20%2F%3Eupdate%2C%20use%20-SkipPublisherCheck%20parameter.%3CBR%20%2F%3EAt%20C%3A%5CProgram%20Files%5CWindowsPowerShell%5CModules%5CPowerShellGet%5C1.0.0.1%5CPSModule.psm1%3A1661%20char%3A21%3CBR%20%2F%3E%2B%20...%20%24null%20%3D%20PackageManagement%5CInstall-Package%20%40PSBoundParameters%3CBR%20%2F%3E%2B%20~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~%3CBR%20%2F%3E%2B%20CategoryInfo%20%3A%20InvalidOperation%3A%20(Microsoft.Power....InstallPackage%3AInstallPackage)%20%5BInstall-Packa%3CBR%20%2F%3Ege%5D%2C%20Exception%3CBR%20%2F%3E%2B%20FullyQualifiedErrorId%20%3A%20ModuleIsNotCatalogSigned%2CValidate-ModuleAuthenticodeSignature%2CMicrosoft.PowerShell.%3CBR%20%2F%3EPackageManagement.Cmdlets.InstallPackage%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-21458%22%20slang%3D%22en-US%22%3ERe%3A%20The%20version%20'2.8.1610.0'%20of%20the%20module%20'SharePointPnPPowerShellOnline'%20is%20not%20catalogue%20signed%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-21458%22%20slang%3D%22en-US%22%3E%3CBLOCKQUOTE%3E%3CHR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1096%22%20target%3D%22_blank%22%3E%40Dean%20Gross%3C%2FA%3E%20wrote%3A%3CBR%20%2F%3E%3CP%3EI%20reported%20the%20same%20issue%20yesterday%20in%20the%20GitHub%20repo.%20I%20think%20that%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F122%22%20target%3D%22_blank%22%3E%40Erwin%20van%20Hunen%3C%2FA%3E%26nbsp%3Bmay%20already%20be%20investigating.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20did%20some%20digging%20on%20my%20machine%20and%20found%20some%20old%20modules%20that%20I%20removed%20and%20then%20this%20one%20updated%20without%20any%20issues.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%2C%20I%20should%20have%20really%20reported%20it%20on%20GItHub%20..%20%26nbsp%3BI%20am%20just%20creating%20a%20few%20Site%20columnst%20to%20be%20referenced%20in%20a%20Nintex%20Worflow%26nbsp%3Bso%20the%20older%20module%20works%20fine.%26nbsp%3B%3C%2FP%3E%3C%2FBLOCKQUOTE%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-21454%22%20slang%3D%22en-US%22%3ERe%3A%20The%20version%20'2.8.1610.0'%20of%20the%20module%20'SharePointPnPPowerShellOnline'%20is%20not%20catalogue%20signed%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-21454%22%20slang%3D%22en-US%22%3E%3CP%3EI%20reported%20the%20same%20issue%20yesterday%20in%20the%20GitHub%20repo.%20I%20think%20that%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F122%22%20target%3D%22_blank%22%3E%40Erwin%20van%20Hunen%3C%2FA%3E%26nbsp%3Bmay%20already%20be%20investigating.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20did%20some%20digging%20on%20my%20machine%20and%20found%20some%20old%20modules%20that%20I%20removed%20and%20then%20this%20one%20updated%20without%20any%20issues.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Regular Contributor

Hi

 

 

Not sure if this related to the build of of this module or somthing I am doing - skipping the PublsherCheck 

 

 

PS D:\PS\WSLOffice365\WSLOffice365AdminTasks> Install-Module SharePointPnPPowerShellOnline -Force
PackageManagement\Install-Package : The version '2.8.1610.0' of the module 'SharePointPnPPowerShellOnline' being
installed is not catalog signed. Ensure that the version '2.8.1610.0' of the module
'SharePointPnPPowerShellOnline' has the catalog file 'SharePointPnPPowerShellOnline.cat' and signed with the same
publisher 'CN=thawte Primary Root CA, OU="(c) 2006 thawte, Inc. - For authorized use only", OU=Certification
Services Division, O="thawte, Inc.", C=US' as the previously-installed module '2.8.1610.0' with version
'2.6.1608.0' under the directory 'C:\Program
Files\WindowsPowerShell\Modules\SharePointPnPPowerShellOnline\2.6.1608.0'. If you still want to install or
update, use -SkipPublisherCheck parameter.
At C:\Program Files\WindowsPowerShell\Modules\PowerShellGet\1.0.0.1\PSModule.psm1:1661 char:21
+ ... $null = PackageManagement\Install-Package @PSBoundParameters
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : InvalidOperation: (Microsoft.Power....InstallPackage:InstallPackage) [Install-Packa
ge], Exception
+ FullyQualifiedErrorId : ModuleIsNotCatalogSigned,Validate-ModuleAuthenticodeSignature,Microsoft.PowerShell.
PackageManagement.Cmdlets.InstallPackage

2 Replies

I reported the same issue yesterday in the GitHub repo. I think that @Erwin van Hunen may already be investigating. 

 

I did some digging on my machine and found some old modules that I removed and then this one updated without any issues. 


@Dean Gross wrote:

I reported the same issue yesterday in the GitHub repo. I think that @Erwin van Hunen may already be investigating. 

 

I did some digging on my machine and found some old modules that I removed and then this one updated without any issues.

 

Thanks, I should have really reported it on GItHub ..  I am just creating a few Site columnst to be referenced in a Nintex Worflow so the older module works fine.