PowerApp forms get stuck on "Getting your data..."

Not applicable

Some, but not all of my SharePoint Forms that are built using PowerApps are getting stuck saying (Getting your data...".  The strange thing is that sometimes the data will load then this will happen, or I can click out of the form and reopen it and then it will work.  Anyone experiencing a similar issue?  

48 Replies

Yes. I am seeing the same problem. I rebuilt the app with no success. 


If you found a fix, please do share. Thanks in advance. 

I was able to fix one of the apps.  I had added extra functions into the SharePoint Integration for "New Form" and "On Edit".  I just changed the order of the functions to put the standard functions that it automatically creates first, and it seemed to fix the problem.  

Thank you so much. I can confirm that that fixed the issue. I added a couple of functions to refresh data source and calling NewForm for OnSelect. Much appreciated for the pointers!



I was also stuck on this and just figured it out as I was in the process of writing a post here, so I'll explain it for the sake of anybody else who comes along.


The part that was missing for me was on the CreateItemForm. Click on the problematic screen in the Screens panel on the left, Advanced Properties, and the OnSuccess field. That needs to be:


ResetForm(CreateItemForm); RequestHide()


I guess when I copied from other forms it didn't keep that default, or it otherwise somehow got lost along the way. I kept looking at the SharePoint Integration formulas and wasn't getting anywhere before I eventually stumbled across that.

I have the same issue, my edit forms and datatables dont load for some users when navigated to these screens and they see the message "getting your data" and they never load. Any ideas?

Please check the Item property from your Form.

I have entered the following selection ('OrderForm MCPD_1' is the SP datasource):




Have you managed to find the cause of the issue? We have the same behaviour with one of our PowerApps. 



I'm experiencing the same issue, "Getting your data..." after submitting a form. OnSuccess I put the Navigate(SuccessScreen), but it is not navigating to success screen just displaying "Getting your data...". Although SharePoint list has been updated successfully. Is this bug in Powerapps or am I missing any configuration?

Hi guys,


I too was having the same issue but resolved it by:


1. Changing the form name in the Tree view to the left to its default value, which is SharePointForm1.

2. by adding 


ResetForm(CreateItemForm); RequestHide()


to the OnSuccess field as Ryan Robinson suggested but obviously added my Form name instead of using "CreateItemForm", so my string looked something like this ResetForm(SharePointForm1); RequestHide()


3. I also added:


If(IsBlank(SharePointIntegration.Selected) || IsEmpty(SharePointIntegration.Selected),First('insert data source name'),SharePointIntegration.Selected) 


to the Item field in the same advanced properties menu for the problematic form as the field was blank for me for some reason.


I hope this works for somebody else as well :)



This solved my problem. 

@Sheldor  THANK YOU for this helpful information -- this worked like a charm for me and saved me a LOT of web searching. 

@Erin Napier , you are most welcome!

Glad I could be of assistance :D

@Becca1987 , it is only a pleasure :D

Always happy to help if possible.

I only had to do steps 2 & 3, but that fixed my issue too - thanks @Sheldor!

@StaceyLaney You are most welcome :D

Thank you @Sheldor.

Just calling out "insert data source name here" needs to be replaced with what you select/see in datasource such as sharepoint list.


@Luca Ziegler 


This worked for me. Looks like for Custom Edit Form, SharePointIntegration.Selected in blank where as SharePointIntegration.SelectedListItemID has the ID value so we have to first fetch the Item by using your above formula which is:


If(IsBlank(LookUp('Active Proposals', ID = SharePointIntegration.SelectedListItemID)), First('Active Proposals'), LookUp('Active Proposals', ID = SharePointIntegration.SelectedListItemID))


Note that this is only true for 'Custom Edit Forms' and not if you are using a single default Form for both New and Edit cases.


Note: Specify your own data source (SP List name) here instead of 'Active Proposal' in above formula. 


@Sheldor This is brilliant.  Thanks.  You saved me HOURS of frustration.  It's like Christmas came early.  ;)




I feel like I'm missing something here. Are we saying that if you just straight up follow the instructions located here...that we still have to add extra formulas to get the form to work properly? I followed this well written tutorial and I'm getting stuck in the same spot as y'all. I wonder if the PowerApps and SharePoint teams actually know about this?


I have a ticket in the hopper with the SharePoint team on this. It will be interesting to see how it all turns out.