Teams open and close itself when you change Team scope. Ubuntu; userStorageMisMatch

Copper Contributor


We have a problem with Microsoft Teams breaking down. After logging in to the client's scope (switching the team from main 'company' scope to client Team), the application turns off and then returns to our scope. Operating system is Linux Ubuntu 20.04, Teams for linux application. The same is true for the different versions of the teams app from to version


So in other words:

We open Teams application, login to main account (confirm with SMS OTP), then I change Team (scope) from company-team-scope( MyCompany), to client-scope (CompanyX), the application closes, opens again, asks for login confirmation (in the Authenticator), the Teams window with correct client (CompanyX) scope, I see all messages, Teams, Activity, etc. BUT the windows closes itself in 1 second, and login-back to MyCompany main account Team scope.

We have created a support ticket to Microsoft, but as you can see, I'm upset as little HELP was provided, the guy is asking about Microsoft Installer when he was told I use Ubuntu Linux (like above)... 


 So regardless of my initial skepticism, I did provide answers as follows:


1. Was it working previously ? 
Yes, the teams stopped to work at random, I switched to my main Teams Scope, then I wanted to switch again to a client scope, it logs in, and then it is being dropped somehow.... It was working until 15.04.2021
Hint: I was accessing some file on OneDrive or a SharePoint - maybe there is some 'session' or reference to that file on my Account that makes this 'scope' to crush?

2. Is Teams installed using MSI installer or Click to run Application ? if you have used MSI kindly check after installing Click to run version.
I use Lenovo laptop, with a Linux (Ubuntu) operating system.

I did try multiple versions of Teams
installed with 

apt-get install teams=

and version installed with 

snap install teams 

I also tried cache clean-up like
3. Also confirm if issue is specific to 64bit or 32bit version ?

4. Which license is assigned to affected user ?
Microsoft 365 Business Basic
I have some questions:
5. I would kindly ask you to ask the developers, how to enable debug logging for teams?
This was answered by the Support (thanks!)

Ctrl + Alt + Shift + 1

I did provide logs with initial support ticket, there are some lines that makes me wonder if all is OK:
6. Did you have a chance to review attached logs?
is this line important?
Fri Apr 16 2021 11:10:52 GMT+0200 (Central European Summer Time) <14721> -- error -- getInstallOrUpdateTime failed

what do you think about this
Fri Apr 16 2021 11:10:52 GMT+0200 (Central European Summer Time) <14721> -- error -- Error occurred while saving env_config.json

it seems that after this line the Teams context of my customer is closed, and I'm being drooped back to my main Teams context...

and I actually this may be the reason it fails
Fri Apr 16 2021 11:14:38 GMT+0200 (Central European Summer Time) <14721> -- info -- Logout event occurred due to reason:userStorageMisMatch 
WHY does it happen? What do you see in the logs on the server side?


If you are from Microsoft or Techdata, this is the support case:
We would like to inform you that your  [Techdata Cloud Support Services (CSS)] Support Request 129838 regarding issue "Microsoft Teams problem in Linux Ubuntu​" has been escalated to Microsoft and an engineer will be in contact with you shortly to work on the issue reported. MSFT SR# ‎25334458‎



I can provide you with any logs


.config/Microsoft/Microsoft\ Teams/logs.txt

Just please tell me if I should obfuscate any confidential information.



I did find a machine with Windows operating system - as expected - switching client context works with Windows desktop Teams application.

So the problem may be with
1) something on Linux app, 

2) change in Teams API that is not reflected in Linux App

3) error on Teams SERVER side, like some account parameter or sth



I did try 3 different machines, 4 different operating systems
Ubuntu 20.04 (here Teams were working until 15.04.2021)

Ubuntu 18.04 (here Teams were working until 15.04.2021)

Ubuntu 18.04 (another PC, fresh Teams - not working)

Windows 10 (works)

so I think it is not a case with a cache, or having 'factory default' installation.






I was told that Teams for Linux have no support, and that I should reach out personally to MS developers.
I hope this is the correct place!

I heard that Microsoft <3 Linux
This seems to be far from the truth.

Please look at this situation like a professional. You sell a product, force clients to use it (one way or another), then when it breaks, you say "not my problem".

Give someone 4-leg chair, and when one leg breaks, make him continue sitting on 3 legs, or tell him to find a solution, without providing any help.

I do not ask for much, I just ask you to do your job - check the Server side logs, check if everything is on with the account on the Server side, check if you did not BREAK YOUR API (as this happened in the past).


11 Replies
I want to be very clear, that I do not blame Support Engineers for not having the knowledge about Linux (though asking about Microsoft Installer (MSI) makes me sad as I know I cannot expect help = waste of my time). This is a fault of their bosses, who create faulty procedures.
Why there is NOT a Support Team with a Linux knowledge?
Why in the past (before Teams), when I called to support, I was offered (By Microsoft Azure support) video call with Skype for Business, that MS is not providing for Linux? !!!!!!!!
Who is creating that procedure?

This is fundamental. This is about being professional.
Microsoft <3 Linux?
So put your mouth where your words are and be responsible for your products, make a 'special task force Linux Support team', update your procedures, be more transparent, be honest, be helpful.

How one could say: 'sorry to hear you I caused you a problem, but I don not care'
Would Bill or Satya approve your approach?
I got the same issue, and it was resolved.
Seems, this issue only happened on Linux version, it works fine on Mac, Browser and iOS app.
I'm not sure if it can work on your side, but let try some below steps:
- Logout your account from Teams
- Open an invitation link to this scope (the link that you have received when you were added to this scope) like:
- Login screen will appear, try to log in to your account and see the result.
Thank you.
huh, not sure if I still have that link, I'd try and let you know

My friend have a similar case to your solution - he says, teams are crushing after changing the scope, but luckily they open after crash into recent scope, so he can work. In my case I'm reverted to main TeamScope.

I've heard that updated linux version was released
I did not see it yet neither in snap nor in apt
but I look forward to test it

I hope that Linux version of the Teams would incorporate the Windows/Mac version of the app - that would be only 2-3 month release delay... maybe Teams Developers could be more aware of app and API lifecycle, because I really suspect that the problems are caused by Microsoft changing server-side API that is not reflected in Teams linux desktop app, as it is not yet released...
If only someone could confirm that... and fix internal Microsoft procedures...

I still see:
latest/stable: 2021-03-29 (4) 127MB
I'm having the same problem as @sirkubax and this procedure did not change anything for me.

What I did:

* sign out from teams in the desktop app
* sign out from teams in any browser tabs
* sign back into to access my email
* find my "your request to join $ORG has been approved" email
* click the "Join teams", which is a link
* this opened a new tab, some redirects, then prompted me to get the linux app. The "Get linux app" button leads to the normal download page. The "Linux DEB (64-bit)" button downloads `teams_1.4.00.7556_amd64.deb`, which is what I have installed already
* I opened desktop teams
* it prompts me to sign in, I do so
* it opens with my default organization, not the $ORG related to the email link
* the "crash and switch back" behavior described here still occurs

I also had no luck with the "clear cache" snippet.

A few other things I tried:

  1. rm -rf "~/.config/Microsoft/Microsoft Teams" No change
  2. sudo apt remove teams && rm -rf "~/.config/Microsoft/Microsoft Teams" && sudo apt update && sudo apt install teams No change, installed again
  3. change `enableUserMismatchCheck` to false in settings.json, with various reboots no change, it got flipped back to true
  4. disable ad blocking no change
  5. rm "~/.config/Microsoft/Microsoft Teams/Cookies" then change orgs without restart no change
  6. change desktop-config.json to set `guestTenantId` to the $ORG I want and `homeTenantId` to my home org. This starts the desktop app in $ORG, but then I get the userStorageMisMatch and it restarts to my home org
  7. reboot no change
  8. install teams= no change


The only other clue I see is this error in my logs :


Sat Jun 05 2021 17:50:13 GMT-0400 (Eastern Daylight Time) <23633> -- error -- Error saving cookie


Maybe teams is trying to update the sqlite db in ~/.config/Microsoft/Microsoft Teams/Cookies and having a problem? The file permissions look fine: 600.




For now I'm using the browser client, but this is a bad workaround.

Still seeing this on (64-bit).


Same here, still does not work.


My guess is that M$ did change something on the API SERVER side, and the linux client is not compatible.

I'd really love to hear some answer from MS developer, OR M$ support member who know what Linux operating system is....

It is a shame, that M$ have no support team that understand linux, one want's to ask - how they develop Azure.... 

If anyone from M$ reads it, please forward the ticket to someone who can check Teams logs on the server side, or Teams developer...

best response confirmed by ThereseSolimeno (Microsoft)
This workaround worked for me:

1. sign out of teams
1. open teams, get to the sign in page
1. click "Sign-in options" on the O365 login screen and choose "Sign in to an organization"
1. type in the domain name of the organization to sign in to - you can see what these are in the azure portal's "switch directory" option, for me it was "$"
1. enter user/pass as normal

There are a few related issues on uservoice, consider upvoting those to raise the profile of this issue:



For me the log-in is not the problem
I'm able to switch to Guest organisation, but the app log-out itself within 1 second and revert to my main organisation scope :\ 
As there are some messages about null token I guess there is an issue passing some authorization data


So this did not work...

had the same problem (on Fedora 33), this worked for me.
Thank you, very much! This advice saved my day.