MS Teams crashes *sometimes* during Video calls/meetings

Occasional Contributor

I've been researching an issue where several users are experiencing periodic Teams crashes always during a Video call/meeting. A call that crashes once is often successful right after, and the crashes don't follow any pattern. I haven't found any commonalities across hardware or drivers, and have been checking network quality pretty closely. It really seems like it's a Teams software issue. Is anyone else dealing with this kind of inconsistent stability?


The errors in logs (that I've seen) are always:

Renderer process crashed; rendererName=mainWindow; crashType=crashed; url=; restarting app=YES


Other forum threads haven't been useful; they usually point to a software glitch that has since been patched, or some common hardware issue with a specific laptop model (Surface) or webcam (Logitech). 


I tried to figure out if I could disable GPU rendering (just as a test) and that doesn't appear to be an option. Is there another test we could try? This seems to be related to graphics rendering, particularly since it always happens during a beginning of a Video call or meeting, and the detail in the error logs...


I opened a Microsoft support case, but it's going no where fast, particularly since the issue isn't reproducible on-demand. 


In my various testing and research, I tried launching Teams from a command prompt window (thinking maybe "--disable-gpu" would be an option to launch with). It launched and then I stumbled upon this strange output; I eventually canceled with Ctrl+C and Teams closed. 


I think this is totally unrelated, but figured I'd share it in case it ends up being relevant. The messages sure look like Teams is experiencing a memory leak ("MaxListenersExceededWarning: Possible EventEmitter memory leak detected.").  In any case, this output was on a system where Teams has never crashed as described before, so probably not the best clue.

51 Replies

@Steven CollierSo far the issue that we are seeing in our own tenant and other corporate customers is that the crash manifests most commonly with back to back video conference calls that are one on one or repeat calls for a group. The first teams call/video conference goes smoothly and then when you are done, initiate an additional call and the person being called can see the incoming call, attempts to answer, and then everything locks up on both sides. The log shows that it fails and causes a reload of TEAMS, but the only way to clear the stability is a complete reboot of the computer. The reloaded teams is still unstable if you don't do this. Teams log also makes reference to the audio and video driver missing after the software crashes, but then the operating system will recover the audio and video devices on their own and works with other programs, just not teams.

@TIER4TS We are having the same issues as you described. It only happens to our new Dell AIOs that we purchased in over the last 5-6 months. It does not happen on any of our other desktops or laptops. We have tried installing older Realtek drivers, newer Realtek drivers and removing the Realtek program from the programs and features list. The frustrating thing is that the fixes appear to work for some and not others. We have three computers that all had this issue fixed by removing the Realtek program from the programs list and rebooting. Not a problem since on those, yet others that fix does not work. Trying to find a commonality of the systems between what works and what doesn't is proving difficult. We have reach out to Dell Pro Support and they are just as stumped as we are currently. If you have any ideas please let me know.

@KDubsThis is our issue as well, I don't think it is a hardware driver issue. Although the driver for both audio and video temporarily are suspended AFTER the MS Teams app performs its crash. The operating system recovers the use of the two device back, after the MS Teams program no longer has them "locked." This is something that has to be definitely addressed by the Microsoft Support and soon. This has consumed a considerable amount of time and Microsoft doesn't have sufficient resources assigned to the issue. Even my Dell Precision with a Logitech Mic/Cam attached suffers after a couple of back to back meetings. Do you want to clear your log and post immediately the results of the crash? In the TEAMS icon in the lower right, just right click and "Get Logs" but only do this after you clear them and then do a fresh test and then post here. That should give me enough to continue the process with Microsoft Support proving that it is not just one "tenant" experiencing the issue. They continually say that if it was a larger issue they would have more support calls, but I argue not many people rely on their support and that they are being brushed off by resellers about it.

@TIER4TS Here is the log from an affected computer. I cleared the logs. Started up Teams, went into settings and used the Test Call button. Teams immediately froze and relaunched itself after a minute or two, these logs are from right after it relaunched.

@ecmillionHave you had any additional responses from Microsoft Support on this issue. It is like they are allowing the cases to die at the first support level. They claim to have analysts reviewing, but nothing makes sense on their replies so far. Rudimentary troubleshooting that was already communicated to them.

@TIER4TSNo, not at all. For a time I had one affected employee experiencing the crash so consistently I engaged with Microsoft regularly on the issue and it never escalated out of tier 1 support. It was a struggle to even convince them there was an issue needing investigation even after displaying the crash repeatedly with the support tech - It just never escalated and I kept repeating the same demonstrations and log gathering. It was a huge waste of time.


I strongly suspect Microsoft is just not supporting/developing to account for some hardware. My most interesting data point was connecting with another enterprise through an employee's spouse, whose company NEVER experienced any Teams crashing org-wide. The employee and their spouse worked from the same network (at home), had the same version of Teams, and had high volume of Teams calls every day - my employee's Teams crashed all the time, their spouse's did not. After connecting with that company's IT department I found out the only notable difference from their org and mine is they have a more modern and higher-end laptop fleet (we both use W10 and Dell laptops) So, throwing money at the problem to upgrade laptops would be one fix... obviously that's not really a solution for those of us with tighter budgets / slower replacement schedules.

Completely unrelated to Teams crashing problems, we've noticed that Microsoft isn't developing some Teams features for older hardware. Most recently we discovered the new "background effects" feature requires the AVX2 video extensions, which were introduced in Haswell processors (model is 4000 series). This means Dell Latitude 6330 and earlier laptops don't support it. 

Seeing the same issue.  The common denominator here appears to be a Plugable dock that uses a Displaylink driver.  Issue appears under no other circumstances.

@TIER4TS  I have been having increasing freezes for 5 seconds on teams calls using video and only voice. I am using a newer Lenovo Yoga with a thinkpad docking station. I believe this used display link and i am running two monitors off of it. I just changed one monitor off of the docking station and direct into to the PC. This seems to have resolved the problem

I have one user out of 100 that has reported this issue.

when plugged into the dock and I try the  "meet now" meeting. the interface freezes not allowing any actions. I have to force close teams at this point.

I undocked and then tried "meet now" issue what so ever.

the user reported issues with sharing when in meetings and Teams crashing while trying to share desktop.@natsgreg 

@eberrocalIt certainly is bizarre regarding the range of issues that result in the crash. So far I tried the Microsoft Dock and sometimes get the freeze up audio/video crash on back to back calls but it is the same on the Microsoft Surface Pro whether on the dock or not. On the Dell Platforms we aren't using Docking Stations, but most are last two models of All in One's and a Precision only after updating past 1803.

@jmc4499a couple of people are reporting the display link, do you have a specific model number of the display link/docking station that you are using and driver version? Thank you!


ThinkPad universal Docking Station model (40AN0135US)


Not sure of specific drivers. I was running two monitors through it and also using the laptop to extend my desktop. I now run one monitor through USB C and the other through the docking station. I wave not had a problem since. Been on several calls

I have been trying to troubleshoot similar app crash.  However our users are not using any docking stations with their Surface Pro devices.  The only clue I have is from the Event Viewer;

Log Name:      Application

Source:        Application Error

Date:          4/21/2020 2:24:20 PM

Event ID:      1000

Task Category: (100)

Level:         Error

Keywords:      Classic

User:          N/A

Computer:      Asset-146


Faulting application name: Teams.exe, version:, time stamp: 0x5e443048

Faulting module name: VCRUNTIME140.dll, version: 14.13.26118.0, time stamp: 0x5a603d9f

Exception code: 0xc0000005

Fault offset: 0x000000000000ca27

Faulting process id: 0xc18

Faulting application start time: 0x01d61322cf52c961

Faulting application path: C:\Users\FNameLName\AppData\Local\Microsoft\Teams\current\Teams.exe

Faulting module path: C:\WINDOWS\SYSTEM32\VCRUNTIME140.dll

Report Id: 969792b3-ae70-4a81-b9ed-5dc61c42164d

Faulting package full name:

Faulting package-relative application ID:

Event Xml:



    <Provider Name="Application Error" />

    <EventID Qualifiers="0">1000</EventID>




    <TimeCreated SystemTime="2020-04-21T18:24:20.158379300Z" />




    <Security />























I have searched Bing and Google and cannot find any clues.  This only happens once in a while so I am assuming there is some sort of memory leak that causes the Teams app to crash.

@Forrest Hoffman The only machines experiencing crashes for us are the new Dell AIOs we purchased, all our other machines work fine. The AIOs do not have any sort of dock attached to them and we have found that on some removing the Realtek drivers from programs and features fixes the issue. On others it has no affect.

@TIER4TS We think we finally found a fix for this. So far has worked for 4/4 of the machine who had this issue.


From Admin profile 
Update all firmware BIOS, Chipset, etc. 
Dell Command Update works well for this.  Select all Critical updates and you are covered. 

Control Panel > Programs and features 
Delete all Realtek software 
For this and all subsequent Realtek installs follow the InstallShield Wizard and allow to reboot as needed (sometimes multiple times) 

Browse to 
Enter the service tag for the unit at hand 
Go to Drivers & Downloads 
Enter Keyword "audio" 
Download Realtek High Definition Audio Driver ver 6.0.8816.1_A06.EXE (01 Nov 2019) 
Install following InstallShield Wizard (multiple reboots) 

When complete open Device Manager. Select and uninstall all devices under Audio Inputs and Outputs 
Select and uninstall all devices under Sound, Video, and Game Controllers 
NOTE: Where it is an option,  check the box to “Delete the driver software for this device” 

Open Teams and test 
If Teams crashes or freezes within the first 4-5 calls, (in and/or out) reboot again.

We have confirmed that the resolution is also as follows @KDubs:


Go into Control Panel and then ADD/REMOVE Programs

Remove the Realtek High Definition Audio Driver (Publisher Realtek Semiconductor Corp.) Program

It will prompt you to reboot the computer, do not reboot yet



Scroll down to Sound, Video and Game Controllers (expand)

Double Click "Realtek Audio"

Click Driver Tab

Click Update Driver

Click Browse My Computer for Driver Software (Locate and install driver software manually)

Click "Let me pick from a list of available drivers on my computer"

Select "High Definition Audio Device"

Click Next

A pop-up will state "Installing this device driver is not recommended because Windows cannot verify that it is compatible with your hardware..."

Click Yes to the pop-up

You will receive a screen that states "Windows has successfully updated your drivers"

Click Close

Click Close again



Problem is resolved. On occasion if the issue presents itself again, it will require changing from the native REALTEK driver to the Microsoft High Definition Audio Driver.


This has worked 100% of the time so far. Microsoft has some homework to do on this issue.








Is the Realtek High Definition Audio Driver ver 6.0.8816.1_A06.EXE (01 Nov 2019) driver for a specific series of Dell machines?
Was not able to find this driver to Dell Latitude 7390, so went with TIER4TS solution:

Waiting to se if customer confirms that the problem is solved.

@simon_bedsysThe version that 100% an issue is 6.0.8816.1 and it isn't just specific to the dell machines. The date on the driver on the machines is normally 10/15/2019. This is also in combination with Microsoft Windows 10 Builds 1809 and higher. It wasn't manifesting in 1803. Some clients were coming up with arguments like "we just got new computers a couple of months ago" and things like that not realizing that Microsoft TEAMS, Microsoft Windows, and Realtek are all independent products/software/solutions. 


Make sure that you uninstall the REALTEX software from control panel in my original directions to keep it from rewriting the driver back after you change it manually in device manager. Report back your findings. 


Microsoft hasn't reached out or handled these tickets appropriately on the TEAMS platforms and business partners likely give up trying to tackle it. These leaves a blind spot in the support of the platform that Zoom and WebEx do not have.

As you said I removed the Realtek software but since I could't find the new correct driver version from Dell I went with TIER4TS solution to use the native Realtek driver.

Will give an status update if this has solved the problem.
FYI; This is W10 Build 1903 and 1909 with the latest of Dell Command Update drivers.

@TIER4TS i have same problem in DELL AIO new. have you found any solution?