Jabra Evolve 75 UC Mute/Unmute Sync Issue With Teams 1.5.00.22362 (8/26/22)

Occasional Contributor

I am having a problem with the Jabra Evolve 75 UC where moving the boom arm up (mute) and down (unmute) works at a hardware level but does not stay in sync with the mute/unmute status in MS Teams.  It doesn't fail 100% of the time, it is about 50/50 being in sync to not in sync.

 

Means that if I want to talk on a call I can't just lower the boom arm down, I also have to check what the mute status is in Teams and manually click on the unmute button so that the software and the hardware are in sync.  It is terribly distracting for my calls, having to worry about the mute status in the software being different from the hardware.

 

This started happening in August 2022, though I can't be sure it first became an issue with the MS Teams 1.5.00.22362 release.  Here is more information on the versions of things.

 

  • Computer: MacBook Pro, 16-inch, 2021 (M1)
  • OS: macOS Monterey 12.5.1
  • Running Jabra Direct version 6.3.22201.  Preferred Softphone is set to Microsoft Teams in Jabra Direct settings.
  • Jabra Evolve 75 UC with firmware version 2.38.0
  • Jabra Link 370 with firmware version 1.87.0

 

I have tried unpairing the Jabra Evolve 75 from the Jabra Link 370 and then re-pairing them.  No change to the observed issue and MS Teams is still out of sync with the mute status of the hardware about 50% of the time.

 

I have tried connecting the Jabra Evolve 75 directly via bluetooth instead of through the Jabra Link dongle.  No change to the issue.

 

I have tried a USB wired connection for the Jabra Evolve 75. This does seem to improve the frequency of how often the mute in MS Teams is in sync with the hardware to about 75% working and 25% failure, but even at 25% failure this is a problem.

 

I have tried killing the Teams app and restarting it.  I have tried killing the Jabra Direct app and restarting it.  I have tried rebooting the Mac.  The issue remains.

 

Also note that this all works perfectly in the Zoom application.  100% of the time the Zoom mute status is fully in sync with the mute status of the Evolve 75 headset.  Raise the boom arm on the headset, Zoom shows mute is applied.  Lower the boom arm on the headset, Zoom shows mute is not applied.

 

I realize the headset is the UC and not the MS version, but this issue with the software mute status not being in sync with the hardware mute status was not a problem over the 18 months.  It seems like this mute sync issue started sometime in August 2022.

9 Replies

I have also tried disabling all audio processing features in Teams by disabling:

  • Automatically adjust mic sensitivity
  • Noise Suppression
  • High fidelity music mode, which also disables Enable echo cancellation

I rebooted the Mac after changing these settings.  No change to the issue.

I have also validated that the issue where the software mute status in Teams is in sync with the hardware mute status of the Evolve 75 UC only about 50% of the time remains even if the Zoom application is not running on the computer.

I too am having this issue. Newer M1 mac, same software versions. @harmonjeff 

@harmonjeff and others. I have a similar issue with the Jabra Evolve 75 UC and Teams since last week. Running on Windows 10 but no software updates have been installed (not for MSTeams, Jabra, Windows) recently. Everything worked just fine.

 

Now the headset and Teams interact 'weirdly'. Some examples: in the middle of a call I'm put on pause without a clear cause. Sometimes triggered when someone types a message in the chat but not always. The option to mute myself by lifting the mic doesn't work or mutes both mic and speakers. A test call in Settings starts up, the screen flickers and after a couple of seconds the call is terminated without even hearing the result. No clue which component is causing this.

 

Windows Version 10.0.19044 Build 19044

Microsoft Teams Version 1.5.00.21668 (64-bit). It was last updated on 19/08/2022

Jabra Direct Version: 6.3.22201

Jabra Evolve 75 Firmware version: 2.38.0

Jabra Link 370 Firmware version: 1.87.0

 

Restarts, reinstallations have not helped at all. And just like Jeff posted, no problems with Zoom.

Hi people , same issues with teams and Zoom and the reinstallation have not changed something.
Someone have an update about this behavior ?
I have a support ticket open with Logitech on this issue. They have had me try a number of things, none has made a difference. The latest was to use the button at the top of the right ear cup to mute/unmute. Same behavior where it seems to be in sync with the software mute status in Teams about 50% of the time (or worse).

Outside of that, I have had no updates.

I have the same issue...
If you have any solution, could you please share ?

thanks

I have no solution thus far. Jabra has said they are working on this and to watch out for new versions of Teams and/or drivers from Jabra. So far nothing. Mid-October and the issue remains exactly the same for me.

Here at the end of November the issues remain exactly the same. There have been a couple of updates to the Jabra and MS Teams software. None of them have changed anything. The hardware mute status (boom arm up) is not in sync with the software mute status in Teams more than 40-50% of the time.