Graph Explorer

%3CLINGO-SUB%20id%3D%22lingo-sub-1858411%22%20slang%3D%22en-US%22%3EGraph%20Explorer%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1858411%22%20slang%3D%22en-US%22%3E%3CP%3EI've%20started%20to%20use%20the%20Graph%20API%20as%20part%20of%20some%20Power%20Automate%20Flows%20to%20get%20at%20some%20data%20that%20isn't%20otherwise%20exposed%20and%20it%20works%20great!%26nbsp%3B%20I%20tend%20to%20use%20Graph%20Explorer%20to%20test%20out%20the%20results%20etc%20so%20I%20can%20plan%20what%20I'm%20doing%20but%20I%20recently%20hit%20an%20issue%20using%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fgraph.microsoft.com%2Fv1.0%2Fusers%2F%7BUserID%7D%2FmailboxSettings%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fgraph.microsoft.com%2Fv1.0%2Fusers%2F%7BUserID%7D%2FmailboxSettings%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20will%20only%20return%20data%20for%20my%20mailbox%2C%20for%20any%20other%20mailboxes%20it%20says%20I%20need%20to%20grant%20permissions%20but%20the%20permissions%20have%20been%20granted.%26nbsp%3B%20Doing%20it%20in%20Flow%20works%20fine%20but%20I%20just%20don't%20understand%20why%20it%20won't%20work%20in%20Explorer.%26nbsp%3B%20Anyone%20have%20any%20ideas%3F%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

I've started to use the Graph API as part of some Power Automate Flows to get at some data that isn't otherwise exposed and it works great!  I tend to use Graph Explorer to test out the results etc so I can plan what I'm doing but I recently hit an issue using https://graph.microsoft.com/v1.0/users/{UserID}/mailboxSettings 

This will only return data for my mailbox, for any other mailboxes it says I need to grant permissions but the permissions have been granted.  Doing it in Flow works fine but I just don't understand why it won't work in Explorer.  Anyone have any ideas? 

0 Replies