Fillable PDF forms cache data from previous time it was open

Brass Contributor

When I open up a fillable PDF using MS Edge, the PDF contains the text I entered the last time even though I didn't save the file. I am opening the file from a website. Same thing happens when opening a file from local filesystem if the name of the file stays the same. 


This is erroneous behaviour, and it might cause data to leak when using a public computer or something similar. The issue happens in Edge Stable 114 and Edge Dev 115. 


I'm not sure how long the issue has been here, most likely from the start of 114 stable. 

19 Replies
The only short-term solution I've found for this is to delete your entire edge profile. Just clearing cache and cookies is not enough. Unsure how this interacts with profiles using sync.
Also seeing the same issue, it arrived with 114.
Deleting the profile "fixes" it, but this isn't a solution. There are "recovered" PDF data files that get corrupted, once removed, the PDFs load properly. Not sure what is causing this.
It would be nice if we could get Microsoft's attention on this matter.

Our users are also experiencing this bug. When filling out PDFs in Edge, the previous data is never removed. When attempting to print it either to a new PDF or printer, the previous data remains.

The only workaround I've found is to set Adobe Reader as the default PDF viewer and set Edge to download all PDFs by default. This is very cumbersome long term.



This is definitely an issue with 114 as I've reverted to 112 and 113 and the issue does not exist. The issue also exists in 115 and 116 edge dev/canary. 


The pdf files are being cached in the user profile folder "Pdf Restore data". You can trigger the issue if you edit a form field in the PDF and wait 10 seconds, save, reload it and try to edit it. 


In 112 the cache file gets deleted properly. It doesn't get deleted properly in 114 and persists indefinitely. 

Having the same issue. The only way I have found to "fix it" is a workaround of removing "Write" access to the signed in user via permissions in the folder (Disabling inherited permissions, then removing "Write" access). It's terrible and cumbersome but we need it, unfortunately that also means editing folder access left and right, which isn't working very well in an organization.

Same experience for many users here.
Honestly its kinda mindboggling how many issues the PDF reader seems to be having at the moment. I'd understand that if these issues would show up in Canary, Dev and Beta but them trickling down all the way to Stable is not cool.

Just now we had two versions where the "PDF view settings" setting didn't save properly and caused mass confusion in our users.
We're experiencing the same issues too. Mostly with pdfs saved in the SharePoint library that open through Edge 114, for users with read-only access.
I am having the same issue. It is really frustrating because I even "Save As" but when I print, the fields contain the previous values.


Appears to still be occuring on the Stable update from Jun 15. Version 114.0.1823.51

Yep, I am seeing the error in 114 update on Jun 15th as well

That is the same version that I am running, as a workaround I have changed PDF to open in Chrome and it seems to be working. @-_RT_- 



Just ran into this here and moving to Adobe reader also works.  First time opening did show the last edge content but using Adobe we could save the form locally and make changes.  The changes would stick between closing and re-opening the pdf.

I am pushing the script identified here and hoping it works. It worked in my local testing:
If others jump in and tweet the issue to MSEdgeDev on twitter or comment on their tweets we might get some traction there as well.

@Clint_J It looks like the update that was released today has a fix for this issue. The Microsoft Engineer that I have a support case open with has asked me to test the update today, and it appears the bug was fixed.

@Oriennnn what update fixed this for you? I have tried the Stable Version 115 that was released 7/21, but it still pulls the cashed info.

Out company still faces this issue - is there any update on this?

We have the version 115.0.1901.203


I had success with unchecking all of the edge options in settings under "Personal Info" that say "fill into"


-Save and fill basic info

-Automatically fill my info on sign up forms

-Save and fill custom info


In my companies use case, PDFs were saved as templates, and opened in edge to fill out forms. The templates, when opened in Edge, autofilled previously entered information. Turning off these settings, for us, stopped this.


Hope this helps.