SOLVED

Unexpected ConfigurationType" error when attempting to onboard to Defender ATP with MECM

%3CLINGO-SUB%20id%3D%22lingo-sub-1810793%22%20slang%3D%22en-US%22%3EUnexpected%20ConfigurationType%22%20error%20when%20attempting%20to%20onboard%20to%20Defender%20ATP%20with%20MECM%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1810793%22%20slang%3D%22en-US%22%3E%3CP%3ECrossposting%20from%20the%20Security%20and%20Compliance%20forum...%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20attempting%20to%20onboard%20some%20clients%20to%20Defender%20ATP%20using%20Microsoft%20Endpoint%20Configuration%20Manager.%20I've%20followed%20the%20instructions%20here%3A%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fwindows%2Fsecurity%2Fthreat-protection%2Fmicrosoft-defender-atp%2Fconfigure-endpoints-sccm%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fwindows%2Fsecurity%2Fthreat-protection%2Fmicrosoft-defender-atp%2Fconfigure...%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHowever%2C%20the%20clients%20are%20not%20being%20onboarded%2C%20and%20when%20I%20look%20at%20the%20C%3A%5CWindows%5CCCM%5CLogs%5CATPHandler.log%20file%2C%20I%20see%20the%20following%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CPRE%3EATPHandler%3A%20Handling%20policy%20originating%20from%20AdminConsole%3A%20AdvancedThreatProtectionSettings_Configuration%202020-10-21%205%3A09%3A35%20PM%2010148%20(0x27A4)%0AATPHandler%3A%20Unexpected%20ConfigurationType%2C%20%202020-10-21%205%3A09%3A35%20PM%2010148%20(0x27A4)%0AATPHandler%3A%20Failure%20in%20CATPHandler%3A%3AHandleUIPolicy%3A%200x80070057%202020-10-21%205%3A09%3A35%20PM%2010148%20(0x27A4)%3C%2FPRE%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20haven't%20found%20any%20reference%20to%20this%20%22ATPHandler%3A%20Unexpected%20ConfigurationType%22%20error%20anywhere.%20Does%20anyone%20know%20what%20I%20should%20be%20looking%20at%20to%20troubleshoot%20this%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMECM%20Client%20version%205.00.9012.1034%2C%20site%20version%205.0.9012.1000%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1810793%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESecurity%20and%20Compliance%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1812263%22%20slang%3D%22en-US%22%3ERe%3A%20Unexpected%20ConfigurationType%22%20error%20when%20attempting%20to%20onboard%20to%20Defender%20ATP%20with%20MECM%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1812263%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F80266%22%20target%3D%22_blank%22%3E%40Ryan%20Steele%3C%2FA%3E%26nbsp%3BAre%20you%20sure%20the%20affected%20devices%20ran%20the%26nbsp%3BWindowsDefenderATPOnboardingScript.cmd%20successfully%3F%20Did%20you%20deploy%20this%20script%20using%20a%20package%2Fprogram%20or%20as%20an%20application%3F%20When%20using%20an%20application%20(which%20I%20would%20prefer)%2C%20make%20sure%20you%20define%20the%20registry-based%20detection%20rule%20using%20the%20OnboardingState%20value%20correctly%2C%20as%20described%20in%20the%20article.%20Did%20you%20set%20the%26nbsp%3BAllowSampleCollection%20registry%20value%20correctly%3F%20Please%20note%20that%20this%20has%20to%20be%20a%20REG_DWORD%20value.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1812494%22%20slang%3D%22en-US%22%3ERe%3A%20Unexpected%20ConfigurationType%22%20error%20when%20attempting%20to%20onboard%20to%20Defender%20ATP%20with%20MECM%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1812494%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F241578%22%20target%3D%22_blank%22%3E%40Michiel%20Overweel%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EOkay%2C%20now%20I'm%20really%20confused%26nbsp%3B%3CIMG%20class%3D%22lia-deferred-image%20lia-image-emoji%22%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Fhtml%2Fimages%2Femoticons%2Flaugh_40x40.gif%22%20alt%3D%22%3Alol%3A%22%20title%3D%22%3Alol%3A%22%20%2F%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20just%20realized%20that%20the%20link%20I%20provided%20above%20isn't%20actually%20the%20link%20to%20the%20instructions%20I%20was%20following.%20I%20was%20following%20these%20ones%3A%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fmem%2Fconfigmgr%2Fprotect%2Fdeploy-use%2Fdefender-advanced-threat-protection%3Fredirectedfrom%3DMSDN%22%20target%3D%22_self%22%20rel%3D%22noopener%20noreferrer%22%3EMicrosoft%20Defender%20Advanced%20Threat%20Protection%3C%2FA%3E.%20Nowhere%20in%20those%20instructions%20does%20it%20say%20anything%20about%20deploying%20a%20.cmd%20file.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ETo%20my%20reading%2C%20the%20.cmd%20file%20isn't%20required%20when%20deploying%20with%20a%20current%20version%20of%20Configuration%20Manager.%20Indeed%2C%20the%20deployment%20package%20that%20is%20downloaded%20from%20the%20Onboarding%20page%20in%20the%20Defender%20ATP%20console%20when%20selecting%20the%20%22Microsoft%20Endpoint%20Configuration%20Manager%20current%20branch%20and%20later%22%20deployment%20method%20contains%20a%20.onboarding%20file%2C%20not%20a%20.cmd%20file.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EEdit%3A%20I%20also%20forgot%20to%20mention%20that%20one%20of%20the%20machines%20in%20this%20group%26nbsp%3B%3CEM%3Ewas%3C%2FEM%3E%20successfully%20onboarded%2C%20but%20the%20rest%20were%20not.%20I%20haven't%20yet%20investigated%20whether%20there%20were%20any%20particular%20configuration%20differences%20which%20would%20account%20for%20this.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Regular Contributor

Crossposting from the Security and Compliance forum...

 

I'm attempting to onboard some clients to Defender ATP using Microsoft Endpoint Configuration Manager. I've followed the instructions here: https://docs.microsoft.com/en-us/windows/security/threat-protection/microsoft-defender-atp/configure...

 

However, the clients are not being onboarded, and when I look at the C:\Windows\CCM\Logs\ATPHandler.log file, I see the following:

 

ATPHandler: Handling policy originating from AdminConsole: AdvancedThreatProtectionSettings_Configuration	2020-10-21 5:09:35 PM	10148 (0x27A4)
ATPHandler: Unexpected ConfigurationType, 	2020-10-21 5:09:35 PM	10148 (0x27A4)
ATPHandler: Failure in CATPHandler::HandleUIPolicy: 0x80070057	2020-10-21 5:09:35 PM	10148 (0x27A4)

 

I haven't found any reference to this "ATPHandler: Unexpected ConfigurationType" error anywhere. Does anyone know what I should be looking at to troubleshoot this?

 

MECM Client version 5.00.9012.1034, site version 5.0.9012.1000

4 Replies

@Ryan Steele Are you sure the affected devices ran the WindowsDefenderATPOnboardingScript.cmd successfully? Did you deploy this script using a package/program or as an application? When using an application (which I would prefer), make sure you define the registry-based detection rule using the OnboardingState value correctly, as described in the article. Did you set the AllowSampleCollection registry value correctly? Please note that this has to be a REG_DWORD value.

@Michiel Overweel 

Okay, now I'm really confused :lol:

 

I just realized that the link I provided above isn't actually the link to the instructions I was following. I was following these ones: Microsoft Defender Advanced Threat Protection. Nowhere in those instructions does it say anything about deploying a .cmd file.

 

To my reading, the .cmd file isn't required when deploying with a current version of Configuration Manager. Indeed, the deployment package that is downloaded from the Onboarding page in the Defender ATP console when selecting the "Microsoft Endpoint Configuration Manager current branch and later" deployment method contains a .onboarding file, not a .cmd file.

 

Edit: I also forgot to mention that one of the machines in this group was successfully onboarded, but the rest were not. I haven't yet investigated whether there were any particular configuration differences which would account for this.

best response confirmed by Ryan Steele (Regular Contributor)
Solution

Okay, I've just checked again, and all devices have enrolled as expected. There must have been an issue on the Defender ATP back end that was causing this error which has since been resolved.

@Ryan Steele My bad; I failed to noticed that the instructions you referred to were outdated. Anyway, glad to hear that the issue is resolved!