Issue with deployment of Hybrid Topology to Linux HDInsight Storm Cluster

Highlighted
Occasional Visitor

I used a simple Hybrid (C#/Java) Storm Topology which is reading data from an Azure Event Hub and steams the data to a WebApplication where the data was visualized directly within a chart. This worked perfectly with a "Windows" Storm Cluster on Azure. However, Microsoft decided to stop the offering of "Windows" Storm Clusters and since some months only allows to use "Linux" Storm Clusters in Azure. I'm still able to deploy my topology successfully from Visual Studio, however it seems the topology just never really arrives on the server. I can not see any Bolt or Spout in the Topology Viewer in Visual Studio:

(Picture 1)

Also I'm not able to see a Topology in the Storm Web UI:

(Picture 2)

 

So I really think the topology is correct, I even tried a sample topology from Microsoft. However something seems not to work with this deployment. Does anybody has an idea whats going wrong here? I'm glad to provide more information if needed.

0 Replies