RDAgentBootLoader reports "Waiting for Agent to install" Event ID 3389

Brass Contributor

Current state of a HostSession shows as UNAVAILABLE.

Followed guidelines in https://docs.microsoft.com/en-us/azure/virtual-desktop/troubleshoot-vm-configuration and restarted the VM. Still no change. Attempted to reinstall the Agent via the following PS script: 


$Token = "<valid token or blank>"

.\DeployAgent.ps1 -AgentInstallerFolder .\RDInfraAgentInstall -AgentBootServiceInstallerFolder .\RDAgentBootLoaderInstall -RegistrationToken $token


whether I pass a valid token, or just blank. still no change in the Status of the session host.

AgentVersion : 1.0.1288.2700
AllowNewSession : True
AssignedUser :
Id : xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
LastHeartBeat : 5/6/2020 10:30:54 PM
LastUpdateTime : 5/6/2020 10:30:51 PM
Name : xxxxxxxxxxxxxxxxxxxxxxx
OSVersion : 10.0.18363
Session : 0
Status : Unavailable
StatusTimestamp : 5/6/2020 10:30:51 PM
SxSStackVersion : rdp-sxs200326004
Type : Microsoft.DesktopVirtualization/hostpools/sessionhosts
UpdateErrorMessage :
UpdateState : Succeeded


appreciate if anyone can shed some light on this. 


2 Replies
Did you ever find a solution to this issue?

@ABWCC the problem happened so long ago, and unfortunately I oculdn't find the root cause. after so many updates, etc.. the problem has not reoccurred.