Enable failed with exit code 53 Installation failed due to incorrect workspace key

%3CLINGO-SUB%20id%3D%22lingo-sub-1880437%22%20slang%3D%22en-US%22%3EEnable%20failed%20with%20exit%20code%2053%20Installation%20failed%20due%20to%20incorrect%20workspace%20key%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1880437%22%20slang%3D%22en-US%22%3E%3CP%3EI%20was%20trying%20to%20enable%20a%20log%20analytic%20workspace%20in%20a%20VM%2C%20but%20i%20received%20the%20error%20%22%3CSPAN%3EEnable%26nbsp%3Bfailed%26nbsp%3Bwith%26nbsp%3Bexit%26nbsp%3Bcode%26nbsp%3B53%26nbsp%3BInstallation%26nbsp%3Bfailed%26nbsp%3Bdue%26nbsp%3Bto%26nbsp%3Bincorrect%26nbsp%3Bworkspace%26nbsp%3Bkey%3C%2FSPAN%3E%22.%20Does%20anyone%20knows%20what%20could%20be%20happening%20here%3F%20Thanks.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1897706%22%20slang%3D%22en-US%22%3ERe%3A%20Enable%20failed%20with%20exit%20code%2053%20Installation%20failed%20due%20to%20incorrect%20workspace%20key%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1897706%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F864580%22%20target%3D%22_blank%22%3E%40gaboh89%3C%2FA%3E%26nbsp%3B%2C%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EBesides%20be%20using%20the%20wrong%20workspace%20key%2C%20which%20you%20can%20find%20on%20the%20log%20analytics%20workspace%2C%20%22agents%20management%22%20tab%20and%20you%20can't%20mix%20with%20the%20workspace%20id%2C%20I%20can't%20imagine%20any%20reason.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EIn%20order%20to%20make%20it%20a%20bit%20easier%2C%20on%20the%20same%20tab%20you%20can%20download%20the%20agent%20for%20the%20installation.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EKind%20Regards%2C%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EDennes%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

I was trying to enable a log analytic workspace in a VM, but i received the error "Enable failed with exit code 53 Installation failed due to incorrect workspace key". Does anyone knows what could be happening here? Thanks.

2 Replies

Hi, @gaboh89 ,

 

Besides be using the wrong workspace key, which you can find on the log analytics workspace, "agents management" tab and you can't mix with the workspace id, I can't imagine any reason.

 

In order to make it a bit easier, on the same tab you can download the agent for the installation.

 

Kind Regards,

 

Dennes

Hello @gaboh89

Did you find any solutions for this error ?

I have the same one when trying to create VMs with standard load balancer and OMS custom extension : OMS extension deployment fails with the same error.

And in my case, I'm sure it's not really a workspace key error, because :
- I'm deploying with ARM template, and the key is injected in Custom Extension ARM from Log Analytics ARM output variable.
- when I only change LB SKU from "Standard" to "Basic", it works

Thanks in advance for your answer.
Regards,