Azure PIM Powershell module error

Contributor

hi guys

Recently I’ve been having issues with AzureAD PIM PowerShell ver 2.0.0.1762( it was all working perfectly fine before).  

Connect-PimService works just fine, Disconnect-pimservice works as well, however when I run Get-PrivilegedRoleAssignment I get the following error 

 

:An error occurred while processing this request. 

at line:1 char:1

 

What I did next was to run $error[0] | select * and here is what got:

 

error: {

        “code”:”TenantEnabledInAadRoleMigration”, “message”:”The current endpoints of AAD roles have been disabled for the tenant for migration purposes.

... ” 

 

Any idea what does this mean ? 

1 Reply

@Plamen Gavrailov the rest API's used by the PIM module have been migrated. Check out this link. https://aka.ms/PIMAPIUpdateDoc