Home

The Exchange team is announcing today the availability of Update Rollup 3 for Exchange Server 2010 Service Pack 3. Update Rollup 3 is the latest rollup of customer fixes available for Exchange Server 2010. The release contains fixes for customer reported issues and previously released security bulletins. Update Rollup 3 is not considered a security release as it contains no new previously unreleased security bulletins. A complete list of issues resolved in Exchange Server 2010 Service Pack 3 Update Rollup 3 may be found in KB2891587.

Note: The KB article may not be fully available at the time of publishing this post.

The release is now available on the Microsoft Download Center.

The Exchange Team

90 Comments
Not applicable
Issue is present in UR3 and UR4
Not applicable
I can reproduce it on Outlook 2013.
Not applicable
Can anyone tell me that is RU3 is good to install or we still facing the issues with it.
Not applicable
Same problem with categories on our side, customers are heavily complaining about that. Normally we wait longer for implementing Rollups and were on RU2 before - until RU4 came with critical security updates.

We have also opened a PSS call #113121811037366

An hotfix for that would be much appreciated - rolling back to RU2 doesn't seem to be a good idea from a security perspective.

Best regards

Martin

Not applicable
We did not experience the 'Categories'-problem when we were on Exchange 2010 SP3 Update Rollup 3
Not applicable
The 'categories view issue' is definitely present on RU4!
Not applicable
Categories view issue seems to only impact users in online mode and can be reproduced every time by switching between online/cached mode (UR3). Cached mode users have not seen this issue and switching to cached mode fixes issue for user.
Not applicable
I can reproduce it using Outlook 2007 & 2010.
Not applicable
Question - is the Outlook issue with categories specific to certain versions of Outlook or all Outlook versions? I can leave compatibility mode on for our OWA users, but don't want to introduce an Outlook issue by upgrading.
Not applicable
The workaround for IE11 we came up with is to create an iRule in our F5 load balancer to intercept any OWA connection coming from NT 6.1, 6.2, 6.3 with "rv:11" in the string and replace the user-agent submitted to the Exchange server with "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.x; Internet Explorer 11 via iRule)"

Working great so far.

Not applicable
Hi,

Spoke today to Microsoft Exchange Support Engineer concerning the 'categories'-issue. Apparently for this issue there are only 8 cases worldwide. An intermediate fix will not be available, as this problem will be fixed in the upcoming Service Pack 4 for MS Exchange 2010.

That's what I am told.

greetings,

Wouter

Not applicable
Hi,

I installed Rollup Update 4 for Exchange 2010 SP3 and I am now experiencing the following:

In Outlook 2007 if you choose to change the current view with Arrange By 'Categories' the following is noticed:

- Items that you set unread or read are not changed until you refresh the view

- If you open an unread email by doubleclicking, it's status stays unread until you refresh the view.

- New mail items are not automatically seen until refresh.

This is a very annoying issue, and our servicedesk already received a lot of calls for this issue ...

What to do?

Anyone already installed Update Rollup 4 that can reproduce this issue??

gr,

Wouter

Not applicable
I can reproduce it on Outlook 2013.
Not applicable
We did not experience the 'Categories'-problem when we were on Exchange 2010 SP3 Update Rollup 3
Not applicable
Sorry, I did not read through the whole blog. I also created a Microsoft case 113121911041630 describing the issue with sorting by categories. As soon as an engineer contacts me, I will notify him of the other case numbers.

greetings,

Wouter

Not applicable
I can reproduce it on Outlook 2013.
Not applicable
Hi,

I installed Rollup Update 4 for Exchange 2010 SP3 and I am now experiencing the following:

In Outlook 2007 if you choose to change the current view with Arrange By 'Categories' the following is noticed:

- Items that you set unread or read are not changed until you refresh the view

- If you open an unread email by doubleclicking, it's status stays unread until you refresh the view.

- New mail items are not automatically seen until refresh.

This is a very annoying issue, and our servicedesk already received a lot of calls for this issue ...

What to do?

Anyone already installed Update Rollup 4 that can reproduce this issue??

gr,

Wouter

Not applicable
I'm assuming that UR 4 contains all the fixes in UR3 as well, as with all other UR's....
Not applicable
is the issue with Categories view on RU4? any major issues with RU3?
Not applicable
About the 'Categories' issue - anyone got further info from their PSS Case?
Not applicable

KB link doesn't work as of yet...2:35pm CST.

Not applicable

KB link not working for me either.

Not applicable

@Doogie412

@Derek_ZA

"Note: The KB article may not be fully available at the time of publishing this post."

From previous experience it is usually added a few hours after the EHLO Blog is published.  

Not applicable

Are there any plans to support Exchange 2010 on Windows 2012 R2 ?  or is Windows 2012 the end of the line for Exchange 2010 ?  Thanks.

Not applicable

Does this address the IE11 defaulting to OWA light problem like the latest 2013 CU? Cheers

Not applicable

Does this update allow compatibility with EX2010SP3CU3 & Windows 2012R2 DC's?  I'd like to start updating our DC's for other reasons but can't if they will break Exchange.

There's nothing on the compatibility matrix but EX2013CU3 hints at compatibility.

Not applicable

As Aextral comments:

Does UR3 address the IE11-OWA-Light problem ?

I cannot read this from the KB-article - couldn't read it out of the KB-article for E2013-CU3 either though (only from the blog-post) - that's why I'm asking :)

Not applicable

@ Aextral

Yes  the IE11 OWA light issue is fixed

Not applicable

I don't speak for the Exchange team, but it looks like KB article 2866064 has been updated to say that this update fixes the "IE 11 only gets OWA light" issue.  I installed this update on my SBS 2011 server running Exchange Server 2010 and confirmed that IE 11 on Windows 8.1 now gets the standard OWA experience instead of the OWA light experience.

Not applicable

@JeffB - Validation of Exchange Server 2010 Service Pack 3 has not been completed on Windows Server 2012 R2.  We understand that there is customer interest in this scenario.  We cannot say that this is supported at this time.

Not applicable

Can I install Update Roll up 3 without Roll up 2?

Thanks

Not applicable

@Lama, yes you can!

Not applicable

Does RU3 still ask for SP3 installer files like RU2 did?  Just curious as our prod environment is still on SP2 RU5v2.  With all the prior issues from SP3, SP3 RU1, etc, we didn't upgrade yet.  I just need to make sure to have the SP3 files available if RU3 still asks for them.

Not applicable

@Jason, you must install SP3 before installing this roll-up.  Roll-ups are cumulative only within the service pack (so SP3 RU3 contains all changes included in SP3 RU1 and SP3 RU2).  

You can skip roll-ups, but not service packs.

Not applicable

I was technically incorrect and unclear - you cannot install Roll-ups for a service pack you don't have installed.

You could install Sp3 on a system running SP1 - so you can skip service packs.  sorry for the wordiness

Not applicable

@Brent Alinger [MSFT]  

I had posted a query re Windows 2012 R2 support earlier in the thread.  Thanks for your post.

"Validation of Exchange Server 2010 Service Pack 3 has not been completed on Windows Server 2012 R2.  We understand that there is customer interest in this scenario.  We cannot say that this is supported at this time."  is stating the obvious.  

Unfortunately that's not very helpful.  For those of us planning server deployments we need a simple yes/no as to whether Microsoft plans to support Exchange 2010 on Windows 2012 R2 or not so that we can plan accordingly.  If the answer is yes then we're obviously interested in a timeframe for this support.

Checking into this blog day after day waiting for an announcement of some sort is not acceptable.  Microsoft must know already whether they plan on offering this support or not.

Not applicable

@ sime3000: We really do understand that a deterministic answer is needed (yes vs. no or whatever caveats might exist etc.), and that is what we are working on. The truth of the matter is that if we "knew" that everything works and that we were committed to supporting it (meaning - we completed the validations AND addressed any issues that might have arisen in any update that might be needed) - we would announce this. I assure you that we get those questions very regularly though various channels (internally and externally) and are committed to communicating that "final answer" but not before we are ready to do so.

Once all the ducks are in the row, we will announce this on the blog, but also update the Supportability Matrix on TechNet where is where all of this is tracked officially.

Not applicable

Works great on Microsoft Exchange Server - Edge Role - 2010 SP3 RU2 !

Not applicable

@JC - that was not what i was asking.  I was asking if you try to install SP3 RU3, will it ask for the SP3 installer files if you don't have them present. example, ran SP3, installed it, and removed the sp3 files?

Not applicable

@Jason - The RU3 installer will not ask for the SP3 media during installation of Update Rollup 3.  The issue seen with Update Rollup 2 was resolved.  If you attempt to rollback Update Rollup 3, that is you use Add/Remove Programs to remove it, you will be prompted for SP3 media.  Rolling back has always required the previous version of the media and that is by design behavior.

Not applicable

Just to confirm, I think a lot of people aren't looking to install Exchange 2010 on Windows 2012R2 and I doubt that will ever be supported.

What most people are looking for is the ability to have W2012R2 domain controllers as this holding us up from deploying W2012R2 and some of its new features.

Hopefully this will be supported soon.

Jeff

Not applicable

Patch for IE 11 and OWA Premium for Exchange 2010 SP3 works. But if you want to configure your E-Mail signature via OWA (Options:See all Options:Settings:Mail), the page doesn't show up. When you switch to compatibility mode, the page comes up again...

Tested with:

Windows 7 Enterprise x86, IE11

Windows 8.1 Enterprise x64, IE11

Not applicable

I have a Question about W2012R2 DCs: as long as I let the domain/forest-level approx. at 2008R2 or 2012 there shouldn´t be any problem, isn't it?

Not applicable

It's not supported to have an Exchange server connecting to a 2012r2 GC.

And if you consider how great Exchange even with supported configurations works, I wouldn't try it...

Not applicable

Patch for IE 11 and OWA Premium for Exchange 2010 SP3 works. But if you want to configure your E-Mail signature via OWA (Options:See all Options:Settings:Mail), the page doesn't show up. When you switch to compatibility mode, the page comes up again...

...same problem with automatic replies...

Tested with:

Windows 7 Enterprise x86, IE11

Windows 8.1 Enterprise x64, IE11

Not applicable

I have a customer running Exchange 2007 with latest SP and CU in a domain environment with one DC Windows 2012 and two DC Windows 2012 R2

The forest/domain level is Windows 2003

So fa so good since one month after migration from 2003 to 2012 Domain Controller

I've never bothered about Domain Controller version in an Exchange environment, should I?

Cheers

Marco

Not applicable

@Juergen

We have the same issue with IE 11 and the oof en signature options in owa after CU3

Not applicable

I could not install the CU. Error code 1603. I was successfull only on one server. Rest of them show in most case this error. Any help?

Not applicable

Finally I solved the issue. It is a little bit sad cause problem called UAC. I do not now why MS update could not elevate rights automatically :-(. I just downloaded the CU and ran and saw that there is a problem until I ran other application as an admin and then everything worked fine. And what more it is not possible run these CU as an admin. I uderstand that if the update will not be install manually problem never appears but... and sorry for my english...

Not applicable

@RS I suggest to disable UAC on servers. Theres actually no need to use this. The servers are usually managed by proffesionals...

@all Installed UR3 - everything went fine.