Home

Number & decimal separators cannot be changed - does VBA interfere with it?

Highlighted
539090
New Contributor

Dear Community,

 

It's lovely to meet you all and I wish everyone a HAPPY NEW YEAR! Unfortunately, the formatting on here doesn't allow for confetti.

 

It would be very much appreciated if you could help us with the following issue, which the Microsoft support team could not resolve, even though they remotely logged onto our system and tried a many things - we were really surprised by how engaged they were since they spent 3 full hours with us.

 

But - back to the nitty-gritty (see attached screenshot): 

 

Two days ago we got a new colleague and provided him with a new MacBook, that we had bought for his sole use. Together we set up the system, as well as the Microsoft Office Suite 365. At first, everything was completely fine, but after a few hours Excel suddenly swapped all decimal (",") and number separators (".") for "-" and "_". 

 

Fair enough we thought and checked in the most common places: The Excel settings (which on Macs seem to be fairly simplified compared to the Windows equivalent) and the regional "Language & Region" settings of our MacBook. Strangely, the global settings of our system were correct. As were all other programs but Excel.

 

Whenever we send an affected Excel file to one of our other machines the file looks just fine. And this is the case for Excel 14.20, as well as 16.20. (181208). All of our machines use MacOS High Sierra.

 

In our company we're using a budgeting template, which uses Macros (based on VBA) and this was what my colleague was using when Excel went bonkers. Can VBA have a long-term impact on Excel itself, even when the Cache etc. get deleted? Most likely not? 

 

So - apart from the Microsoft team fiddling around with the local formatting settings in our file - what did we try in a global sense:

 

- Re-Installing Excel

- Re-Installing MacOS

- Deleting the temporary Cache files

- Re-Starting the MacBook

- Starting the MacBook in SafeMode

- Deleting the User Profile 

- Changing back and forth the "Language & Region" settings

- Opening & saving the Excel files in different manners

- Updating the MacOS High Sierra system to MacOS Mojave (right now we're back to Sierra)

 

Did anyone ever have this problem ever before or do you have any ideas on how to get this fixed, without replacing the MacBook entirely? 

 

Thank you very much and have a spiffing weekend!

 

Related Conversations
flashing a white screen while open new tab
cntvertex in Discussions on
13 Replies
Tabs and Dark Mode
cjc2112 in Discussions on
22 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
28 Replies
PacketMon Components are not loading in WAC 1909
HotCakeX in Windows Admin Center on
2 Replies