Can't install Office Insider

%3CLINGO-SUB%20id%3D%22lingo-sub-2597878%22%20slang%3D%22en-US%22%3ECan't%20install%20Office%20Insider%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2597878%22%20slang%3D%22en-US%22%3E%3CP%3EI%20registered%20account%20in%20Office%20Insider%20a%20month%20ago%20(beta%20channel)%20and%20still%20have%20build%202106.%20After%20check%20update%2C%20it%20says%20that%20all%20is%20up%20to%20date.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2615629%22%20slang%3D%22en-US%22%3ERe%3A%20Can't%20install%20Office%20Insider%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2615629%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20having%20the%20same%20issue%20with%20autoupdater.%26nbsp%3B%20I%20want%20the%2016.52%20version%20of%20Excel%20but%20it%20says%20I%20am%20all%20up%20to%20date%20even%20though%20I%20have%2016.51%20build%26nbsp%3B%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1118427%22%20target%3D%22_blank%22%3E%40AdamFierek%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Regular Visitor

I registered account in Office Insider a month ago (beta channel) and still have build 2106. After check update, it says that all is up to date. 

1 Reply

I am having the same issue with autoupdater.  I want the 16.52 version of Excel but it says I am all up to date even though I have 16.51 build 

@AdamFierek