Periodic EWS Response Delay(Time out).

%3CLINGO-SUB%20id%3D%22lingo-sub-3177260%22%20slang%3D%22en-US%22%3EPeriodic%20EWS%20Response%20Delay(Time%20out).%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3177260%22%20slang%3D%22en-US%22%3E%3CP%3EHellow.%3C%2FP%3E%3CP%3EProblems%20are%20occurring%20while%20using%20EWS.%3C%2FP%3E%3CP%3Ebasic%20authentication%20is%20being%20used.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EBelow%20is%20part%20of%20the%20code.%3C%2FP%3E%3CP%3E-------------------------------------%3C%2FP%3E%3CP%3Eservice.Credentials%20%3D%20new%20WebCredentials(%22adminAddress%22%2C%20%22adminPassword%22)%3B%3CBR%20%2F%3Eservice.ImpersonatedUserId%20%3D%20new%20ImpersonatedUserId(ConnectingIdType.SmtpAddress%2C%20%22userAddress%22)%3B%3CBR%20%2F%3Eservice.HttpHeaders.Add(%22X-AnchorMailbox%22%2C%20%22userAddress%22)%3B%3C%2FP%3E%3CP%3Eservice.Url%20%3D%26nbsp%3Bnew%20Uri(%22%3CA%20href%3D%22https%3A%2F%2Foutlook.office365.com%2FEWS%2FExchange.asmx%22%20target%3D%22_blank%22%20rel%3D%22noopener%20nofollow%20noreferrer%22%3Ehttps%3A%2F%2Foutlook.office365.com%2FEWS%2FExchange.asmx%3C%2FA%3E%22)%3B%3C%2FP%3E%3CP%3E-------------------------------------%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThere%20is%20usually%20no%20problem.%3C%2FP%3E%3CP%3EHowever%2C%20the%20EWS%20response%20time%20is%20always%20delayed%20at%205%20p.m.%20in%20Korean%20time.%3C%2FP%3E%3CP%3E%3CSPAN%3EAfter%2010%20minutes%2C%20the%20response%20speed%20returns%20to%20normal.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EIt%20is%20believed%20to%20have%20lasted%20more%20than%203%20months.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EWhat%20is%20the%20cause%20of%20this%20phenomenon%3F%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EIs%20there%20a%20case%20where%20the%20same%20phenomenon%20occurred%3F%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-3177260%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EEWS%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Occasional Visitor

Hellow.

Problems are occurring while using EWS.

basic authentication is being used.

 

Below is part of the code.

-------------------------------------

service.Credentials = new WebCredentials("adminAddress", "adminPassword");
service.ImpersonatedUserId = new ImpersonatedUserId(ConnectingIdType.SmtpAddress, "userAddress");
service.HttpHeaders.Add("X-AnchorMailbox", "userAddress");

service.Url = new Uri("https://outlook.office365.com/EWS/Exchange.asmx");

-------------------------------------

 

There is usually no problem.

However, the EWS response time is always delayed at 5 p.m. in Korean time.

After 10 minutes, the response speed returns to normal.

It is believed to have lasted more than 3 months.

 

What is the cause of this phenomenon?

Is there a case where the same phenomenon occurred?

 

0 Replies