Support for Free Microsoft Teams

Frequent Contributor

Officially, Free Microsoft Teams does not have support - which I can understand. We have an Office 365 for Education subscription, but I have an issue with a Free Microsoft Teams account. It seems to me to be a bug of some sorts. I've tried almost every avenue to sort it out. I've got screenshots that document the problem - but I need access to a knowledgeable person to help me out.


Where and how can I obtain support for this kind of thing. It is pretty frustrating. I tried Azure support but they say it is not their baby. I tried Microsoft Of...65 support - but they only support commercial customers and did not seem Microsoft Teams savvy.


I'm pushing for the adoption of Microsoft Teams, on a wider scale, but this issue is delaying me.


Where to now?

15 Replies

Looping in @Albert Chen and @Raanah Amjadi they have been very helpful on the Microsoft Community post about free Teams and may be able to help or point you in the right direction. 

Thank you, @Deleted, I hope one of them will respond. I have tried to call Microsoft Support but they transferred me to someone who said I would be charged for the support. Although I can understand this - it does not seem right in my case where I feel the problem lies with some authentication problem on Microsoft's side. I declined the offer. I do have a paid for Microsoft Office subscription, but the problem I have is with a private (free) account. It seems like a bug to me.

Ok, after jumping through a lot of hoops, I can now say that this issue has been resolved.


It was quite a challenge to get to the right person who knew what I was talking about. After a lengthy period on the phone and then with a remote support session, it was quite a simple solution. The support person synched whatever had to be synched on his side - and voila!


My Free Microsoft Teams organization has regained its sanity and I can now log into it with the Microsoft Account that I had used to create it with!

Hey Marius, sorry I got to this so late. I'm glad to hear your issue was resolved, but sorry to hear the issues you were experiencing and the hoops with support.


Out of curiosity, what was the issue you were running into? If it was an issue on our side, would like to make sure that we understand it properly so we can prevent it in the future. 




Hello, @Albert Chen, thank you for your interest. My issue was that when I logged into Teams, be it online app, desktop app, phone app - I could not access the organization that I had created with Free Microsoft Teams.


I was an early adopter of the Free Teams offer that Microsoft had made and had created a Free Microsoft Teams organization, using my private Microsoft account (email address) which was not used for any other Business or Educational Office 365 tenant. Soon after that someone else added me to their Free Microsoft Teams organization as a member. That meant that my email address was now "linked" to two different Free Microsoft Teams organizations. I was global admin of the one (my own) and a member of the other one.


However, when I logged into Teams, I did not "see" my own Free Teams organization. Where the email address is linked to more that one organization, you expect to see a drop down list giving you the option to choose the organization you want to log into. The drop down list also allows you to switch organizations. In my case, I was automatically routed to one of the organizations, which happened to be the one of which I was only a member. My own organization of which I was global administrator, had seemingly "vanished".


The issue was on your side (Microsoft). After I eventually got hold of a support person who understood the issue, he did something and then I could see my organization again. As far as I understand it, the account had not synched properly and when he synched it manually it came right immediately. I could then see a list of the two organizations and choose the one I wanted to access.


If you wanted to trace it internally, it was Microsoft Office 365 Sup... Ticket #:10918866

Dear @Marius Pretorius and @Albert Chen


I am now in the same exact situation. I have created a free team with my own private (Office365) account, added members and tons of content over the past month. And now cannot access this team as 'owner'! See below for a more detailed description.


This is extremely frustrating. Could you tell me who at Microsoft Support I could contact to resolve this issue?








I don’t think there are any certain support numbers for teams free..just call the ordinary support for you country and go from there. Always caveats to free stuff :)

Right. This is like hitting a wall.

The end outcome of this may be to head back to Slack.

@Anders SkanderupI had tried to PM you, but somehow was blocked. I went through many hoops but eventually was able to log a call to O365 support. Once I got hold of the correct person, it was resolved in 5 min. If I had your email address I could forward the relevant communication to you.

Thanks @Marius Pretorius, I just sent you a PM.

@Albert Chen and @Raanah Amjadi




I have registered for Microsoft Teams free but I am struggling, I understand this a free product so support will be limited but I have tried this on multiple devices, left it for 72 hours and tried to register with a different account too.


In teams, I get the error message:




and in a private chat I get the error message:




if anyone could shed some light on this please it would be appreciated. 




I have exactly the same problem...
From several days. Microsoft, help us!!

@Beata180 ours resolved its self after about a week. 

I have a similar problem. Earlier this week, after using Teams Free for more than 6mths and advocating with my colleagues that this is the future and everything should go into Teams, I get reports that the WIKIs and FILEs uploaded into various teams are all inaccessible. We get...  





Sooooo annoying given the amount of effort I've put into the negative people that said they're not a fan of MS and there's plenty of free alternatives.

Can anyone assist? 

Had the same issue (it was working, and not it's not)