Laggy typing in MacOS

Occasional Contributor

This seems to be a well documented issue caused by CPU usage spikes. Typing lags constantly in teams, perhaps once every 5 to 10 seconds, regardless of background CPU usage. I'll be typing a message and hit enter to post it, and start typing another one only to find the start of my next sentence has been included in the first message because Teams has lagged. I've checked activity monitor and can see noticeable spikes caused by the 'Microsoft Teams Helper' process.


When does Microsoft plan to fix this? I would have thought this issue to be paramount given that Teams is a messaging program which is seemingly incapable of doing its primary task in any sort of proficiency.



10 Replies
This isn't a Mac specific issue, we are working to improve overall responsiveness through better resource utilization. There are a number of efforts underway to reduce CPU and memory utilization while better aligning rendering and video performance to a systems specific configuration be that independent GPU or software rendering.

@Marc Lauinger Yeah this is desperately needed. I can't type more than a few characters without getting lag and my colleagues on iMacs of the same spec report similar problems. Very frustrating.


Hey @Marc Lauinger 


Can you help me with a separate issue?


Somehow I have both an Office 365 and a Guest account registered under the same email in Teams. I can only access the Office 365 account however all correspondence go to my guest account which I can no longer access.

These are both set up under the same email address,

No matter what I try, I can't get to the guest account however it exists and up until Teams automatically logged me out today, I was in there and working as normal.


Is there any progress on this? I'm still having the same issue as described above today - using modern MacOS version, up-to-date Teams and high spec Mac Book Pro 15" with a dedicated GPU.


I guess typing few words in a text input field should not be a challenge for a 4-core i7 CPU and a discreet GPU? Somehow in Teams it is. I think such things used to work much better in software created 20-30 years ago.. which is kind of sad taking into account the progress that was made in hardware. 


Could you please work on this now?




@robeggleston hey there, did you ever get help with this?  


I would leave the org with the guest account you no longer use:


@witoldbolt I am running a similar setup on my MacBook Pro and have not had this issue- have you tried "Disable GPU hardware acceleration" in settings and/or clearing your Teams cache?  Could be a file went rogue in there...

Clear Teams Cache on a Mac


/Library/Application Support/Microsoft/Teams - you can delete everything in the folder



@Ethan Stern It got sorted by Teams support, however I can only access one of the organisations on the computer in which I accepted the invitation. If I log in on another computer or my mobile, I only see one organisation.


So weird considering the invite was sent to the same email I'm using to login.


@Ethan Stern the other weird thing is that even though I registered for an account on this forum using my work email, I had to re-register using my work email to respond to you. So there is something seriously weird going on with my Microsoft account.


@Ethan Stern Thanks for advice.


/Library/Application Support/Microsoft/Teams - this was not existing on my machine, yet this exists:

$HOME//Library/Application Support/Microsoft/Teams.


I've deleted it, and as I side effect the local settings have been deleted (not a problem anyway). I've tried turning off GPU and animations and will see if this helps! For now it works OK, but in the past it used to be like that - working fine for a while, then lagging again... 


@robeggleston This is really horrible, I agree.  often Teams ends up in a state where every time I start to type it lags behind 3-4s.  Also switching between chat and teams takes 3-10s.  The only thing that helps is to restart.

If I use search, I immediately end up in this state. So I have stopped trying to search :( 


It is pitty that the phone app is performing better than the one on my $5000 laptop.