Error switching groups, I can only connect in a guest group

New Contributor

Hello everyone,

Using Teams, I'm part of two organization groups, one it's the company that I work for and another I'm a guest, the switching between both worked fine until last week, more precisely until October,15th, when the Windows updated on my machine and after the reboot, the switching orgs just didn't work anymore. The stranger thing it is that now I'm only able to connect in the org that I'm a guest, when I try to connect in my own company group, it shows the error "We ran into a problem. Reconnecting… Refresh now". It is not a network issue because if I select the guest group I connect normally, I can send and receive emails normally as well, so definitely it is not a network issue.

I tried to open the Teams on browser (Firefox and Edge) but it happens the same issue as the screenshot attached, it doesn't matter if using app installed on my machine or running into a browser, the error message keeps showing. I tried to uninstall Teams from my machine, delete the old folders, install an old Teams version, sttill nothing.

Also I contact the IT department that manage my company Teams, they removed my account and add again, sent the invite to join, everything that we found online and still nothing.

So please if someone could help me because I have no more alternatives available.



6 Replies

@brunogarcia Hi there - looks like it might be a Teams license issue.  Can you check your user account in the admin center?  Make sure you have a license to Teams - if you do try unchecking it and re-checking it.


Prior to doing that, did you attempt to clear your Teams cache?


1. Quit Microsoft Teams.
2. Cut and paste the following location into File Explorer: %appdata%\Microsoft\Teams
3. Delete contents of the entire folder.
4. Restart Microsoft Teams.

Hello Ethan, thank you for your answer.

I checked in admin center and my company is using a free version of Teams, however this should be working?

About the cache, I already try this and the issue still happening.

@brunogarcia If you have a license selected for Teams in the admin center, you can try un-checking it hitting save and then reapplying the license.


This has worked for me in the past.



My company didn't use a paid version of Teams, they are using a free version. So I don't have a license.
However this should work right? using a free or a paid version.
Is it possible your org was using the exploratory version of teams and it’s expired? Anyone else having the issue?

Or, have you used the same account to sign up for a Microsoft account? Try logging in to just from a private web browser and navigating to Teams that way- let us know if you have any luck with that.

@Ethan SternMy company always used a free version of Teams, so there is no exploratory version here.

I have a colleague that have the same problem, but he can log in our company group but can't log in the guest group (contrary situation of mine, the opposite in fact). But as he doesn't use Teams as much I use, for him it's okay.


About the in a private tab, I attached the screenshot about what it happens.


I don't know what to do anymore, the IT of my company can't help me, I called Microsoft Local Support and they can't help my with Teams only Windows. It is a very stressful situation, but I appretiate you effort to help me.