TimeZone redirection not working on iOS Remote Desktop App

TimeZone redirection not working on iOS Remote Desktop App



 Nov 07 2023
18 Comments (18 New)

Since the clock change on the 29th the RD iOS app is not redirecting the correct time on the server. 


I can see this was fixed over summer in the macOS RD app, but it’s still in an issue on iOS.

Brass Contributor

Hi ,


If you have the latest IOS Remote Desktop app installed, then your best option is to either manually change the timezone in the session your in and or create a support ticket with Microsoft.

Because it seems to be a new issue that Microsoft hasn't tackled yet in the previous app versions. 


Support ticket -> https://go.microsoft.com/fwlink/p/?linkid=2202692&clcid=0x809

Copper Contributor



I understand the issue is relating to the RD client not able to pick up the boundaries of daylight saving and standard time. You can check this in Command Prompt using the command 'w32tm /tz'.


Here is output taken while using the RD Client (10.5.0) on iOS 16.7.2. The time zone ID is unknown, the bias is incorrect, and the date boundaries are unspecified.


H:\>w32tm /tz
Time zone: Current:TIME_ZONE_ID_UNKNOWN Bias: -630min (UTC=LocalTime+Bias)
  [Standard Name:"Cen. Australia Standard Time" Bias:0min Date:(unspecified)]
  [Daylight Name:"Cen. Australia Daylight Time" Bias:0min Date:(unspecified)]


Following is output taken from the RDP client on a Windows local machine. All information is set correctly.


H:\>w32tm /tz
Time zone: Current:TIME_ZONE_ID_DAYLIGHT Bias: -570min (UTC=LocalTime+Bias)
  [Standard Name:"Cen. Australia Standard Time" Bias:0min Date:(M:4 D:1 DoW:0)]
  [Daylight Name:"Cen. Australia Daylight Time" Bias:-60min Date:(M:10 D:1 DoW:0)]


 Can this be corrected in the next RD Client release for iOS?

Copper Contributor

Apologies, I have updated the RD Client to version 10.5.2 and the bias and boundaries have updated. However the daylight boundaries are different for the M, D and DoW compared to the RDP client on Windows.


H:\>w32tm /tz
Time zone: Current:TIME_ZONE_ID_DAYLIGHT Bias: -570min (UTC=LocalTime+Bias)
  [Standard Name:"Cen. Australia Standard Time" Bias:0min Date:(M:4 D:1 DoW:6)]
  [Daylight Name:"Cen. Australia Daylight Time" Bias:-60min Date:(M:9 D:5 DoW:6)]


Iron Contributor

Got exactly the same situation. Users devices on IOS is 1 hour behind. It looks like it swapping the daylight and standard time the wrong way round when connecting via the iOS RD Client App.

Works fine on Web Client and Windows Devices.


iOS device:



Windows Device:




Hopefully they can fix it soon.

I also posted on the AVD Community forum yesterday as I hadn't seen this post until now Time Redirection not working with iOS RD Client app - Microsoft Community Hub


Copper Contributor

I have the same from the latest iOS version on my iPhone.

I've reproduced the following:  When you go into the time settings of the AVD and hit the "Adjust for daylight savings time automatically" slider, the slider "blips" (which seems buggy) and then the time rolls forward an hour and is then set correctly.  Users can't change the time but this workaround allows them to do it themselves.

Copper Contributor

Having the same issue.

Time is 1 hour behind on the iPad app

Time is correct if launched on Remote Apps from windows machine.


iOS v17.1.1

Microsoft Remote Desktop App v10.5.2 (5374)


launched the MS remote app on my iPad and ran the w32tm /tz


launched Remote App on my windows machine and ran the w32tm /tz




Iron Contributor

Any movement from Microsoft on this one, no new iOS clients fixes coming out?

Copper Contributor

I just checked for updates on the remote app for iPad.

No updates available.


Launched the RA and verified the time issue still present. 

Copper Contributor

Same problem here.

Microsoft, please fix this, we have hundreds of users that are affected.

Copper Contributor

Same Issue.  Please Fix MS, Upvoted.

Copper Contributor

This is still an issue, need Microsoft to release a fix. If anyone knows a better place to report this problem, please let us know, so everyone reading this thread can go report the issue, as it seems like no one at Microsoft is reading this specific thread, not even an acknowledgement of this  serious problem......

Copper Contributor

Is this being looked into, it looks like it is being ignored

Copper Contributor

Still no update to the iOS Microsoft Remote Desktop App   v10.5.2 (5374).


Time issue persists. 

Copper Contributor

So, I decided to called Microsoft (US 800-642-7676) to open a ticket. 
Used the following page to find: Global Customer Service phone numbers - Microsoft Support

MS reports there is a known bug with the TZ redirect with the latest app. They are 'working on it' and all we can do is wait for the software engineers to fix this.
They offered to send me links on how to change the time but will revert each time you log on.


Guy on phone was very pleasant.

I got my own ticket for my call in. 


Copper Contributor

Thank you for bird dogging Mr. Guerra.

Copper Contributor

So we are getting the same issue with timezone issues during RD connections. In our instance this is using the newest AVD application component in ThinOS which is Dell's Wyse Thin Client OS. 


This impacts any system with the newest update, old update has no issues.


We are in EST and observe Daylight Savings Time in Indiana, so as a workaround I just changed the timezone from UCT-5 America/Indiana to UTC-5 America/Bogota. This is a city in South America that does not observe DST, but has the time we currently have.


You should all be able to do this as a workaround for right now, just change the system timezone from one that uses DST to one that is the current time for your area without DST.

Iron Contributor

Just bumping this thread so Microsoft don't sweep it under the carpet ;)

Copper Contributor

They fixed it!   Go update your app... well on the iPad at least.