Bug with Mac Remote Desktop 10.9.0, cannot remote in without manually logging in first

Bug with Mac Remote Desktop 10.9.0, cannot remote in without manually logging in first



 Aug 30 2023
10 Comments (10 New)

Now when I try to Remote Desktop into a vm that is on a domain, it will not let me connect because of a security error. This used to connect just fine. The only way to get around this is to manually log in. Once a user has logged into the computer, I can then remote into it like normal. Every time the vm is restarted though, I once again have to manually login to get remote access.


The error I receive:

We couldn't connect to the remote PC because of a security error. If this keeps happening, contact your network administrator for assistance. Error code: 0x1807


Copper Contributor

I get exactly the same behaviour, did you sort it??

Copper Contributor

I think it's an issue Microsoft will have to acknowledge and fix. The only workaround I have is finding a previous version of Mac Remote Desktop and going back to 10.8.4

Copper Contributor

Please le me know download of 10.8.4.
And, I have same issue 10.9.2 and 10.9.3beta.

I found URL of download for some beta.


Brass Contributor

I have same issue even I have turned on NLA on server-side

* NLA turned OFF

* First RDP login attempt fails

* After logging in locally once, RDP works.


This issue started after summer, maybe even when the client was updated to 1.9.x


Does MSFT have any better feedback channels for bug reports?

Help => Submit feedback open this forum but for me it looks like MSFT does not monitor messages sent here.


I can send more information and log files if requested

Brass Contributor

Update for support:




* Windown 10 Pro, 22H2: [Version 10.0.19045.3570]

* On same LAN segment than client



* OS X 13.6 (22G120)

* Microsoft Remote Desktop: Version 10.9.3 (2158) and Version 10.9.4 (2161)

* Support ID: D1D8E640-1610-4BB5-9EBB-801576816CA9



The error dialog on first RDP login after server reboot:



After logging in once on "Server" RDP connection works.

Brass Contributor

Support on Twitter escalated this internally but looks like nobody bothers to write here or update status of the thread.

Copper Contributor

Microsoft doesn't seem to make it easy to report or escalate issues. Maybe that's their way of prioritizing what to work on. This seems like such an obvious issue I don't know how the team who develops the mac client didn't run into this right away. This seems to be an issue if you use a newer version of mac remote desktop to connect.


Not much to be done from our end until they decide to fix it. Only workaround I know is to use an older version of the client before 10.9.0.

Copper Contributor

This is happening to me as well. How in the world was this not caught in testing?

Brass Contributor

How in the world was this not caught in testing?


And bigger question is why there iss no zero feedback from the team if issue iss being worked with or not.

Copper Contributor



I was successful by turning of IPv6 on the remote client.

I found this hint somewhere else and IT WORKED IMMEDIATLEY.


I was able to connect to that R-PC with a local ADMIN, BUT NOT WITH a DOMAIN Admin.

ONCE after removing the PC from the Domain and re-itroduce to domain, the DOMAIN Admin loging worked.

Hours later it failed until I turned off IPv6 ... very strange and silly behaviour.