Adding "prefer" returns zero results

%3CLINGO-SUB%20id%3D%22lingo-sub-1313990%22%20slang%3D%22en-US%22%3EAdding%20%22prefer%22%20returns%20zero%20results%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1313990%22%20slang%3D%22en-US%22%3E%3CP%3EHello%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EBased%20on%20this%20method%3A%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fdev.loganalytics.io%2Freference%2Fpost-query%22%20target%3D%22_blank%22%20rel%3D%22noopener%20nofollow%20noreferrer%22%3Ehttps%3A%2F%2Fdev.loganalytics.io%2Freference%2Fpost-query%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20adding%20a%20query%20param%2C%20%22prefer%22%2C%20with%20value%20of%20%22maxoutputcolumns%3D3000%22%2C%20but%20really%2C%20any%20value%20set%20on%20this%20query%20param%20caused%20the%20same%20behavior%20(even%20the%20value%20in%20the%20example)%20-%3C%2FP%3E%3CP%3Ea%20search%20query%20performed%20without%20the%20%22prefer%22%20http%20query%20has%20results%2C%3C%2FP%3E%3CP%3Ewhen%20the%20same%20search%20query%20is%20with%20the%20%22prefer%22%20http%20query%20no%20results.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EPlease%20assist%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1313990%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAzure%20Log%20Analytics%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
New Contributor

Hello,

 

Based on this method:

https://dev.loganalytics.io/reference/post-query

 

I'm adding a query param, "prefer", with value of "maxoutputcolumns=3000", but really, any value set on this query param caused the same behavior (even the value in the example) -

a search query performed without the "prefer" http query has results,

when the same search query is with the "prefer" http query no results.

 

Please assist

0 Replies