Home

displayName of user who liked a conversation is null in "Reactions" JSON

%3CLINGO-SUB%20id%3D%22lingo-sub-680064%22%20slang%3D%22en-US%22%3EdisplayName%20of%20user%20who%20liked%20a%20conversation%20is%20null%20in%20%22Reactions%22%20JSON%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-680064%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3EThe%20%3CSTRONG%3EdisplayName%3C%2FSTRONG%3E%26nbsp%3Bthat%20is%20being%20passed%20in%20the%20%3CSTRONG%3EReactions%20%3C%2FSTRONG%3Eproperty%20is%20%3CSTRONG%3Enull%3C%2FSTRONG%3E%20for%20the%20user%20who%20liked%20the%20conversation.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CEM%3ESample%20response%20JSON%3A%26nbsp%3B%3C%2FEM%3E%3C%2FP%3E%3CPRE%3E%22reactions%22%3A%20%5B%3CBR%20%2F%3E%7B%3CBR%20%2F%3E%22reactionType%22%3A%20%22like%22%2C%3CBR%20%2F%3E%22createdDateTime%22%3A%20%222019-06-10T07%3A51%3A29.692Z%22%2C%3CBR%20%2F%3E%22user%22%3A%20%7B%3CBR%20%2F%3E%22application%22%3A%20null%2C%3CBR%20%2F%3E%22device%22%3A%20null%2C%3CBR%20%2F%3E%22conversation%22%3A%20null%2C%3CBR%20%2F%3E%22user%22%3A%20%7B%3CBR%20%2F%3E%22id%22%3A%20%22user-id%22%2C%3CBR%20%2F%3E%3CSTRONG%3E%3CU%3E%22displayName%22%3A%20null%3C%2FU%3E%2C%3C%2FSTRONG%3E%3CBR%20%2F%3E%22userIdentityType%22%3A%20%22aadUser%22%3CBR%20%2F%3E%7D%3CBR%20%2F%3E%7D%3CBR%20%2F%3E%7D%3CBR%20%2F%3E%5D%3C%2FPRE%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECan%20somebody%20please%20confirm%20whether%20this%20is%20a%20bug%3F%3C%2FP%3E%3CP%3EOr%20am%20I%20doing%20something%20wrong%20here%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-680064%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ECommunity%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EConversations%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EDeveloper%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ETips%20%26amp%3B%20Tricks%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Nilay Dhamecha
Occasional Contributor

Hi,

The displayName that is being passed in the Reactions property is null for the user who liked the conversation.

 

Sample response JSON: 

"reactions": [
{
"reactionType": "like",
"createdDateTime": "2019-06-10T07:51:29.692Z",
"user": {
"application": null,
"device": null,
"conversation": null,
"user": {
"id": "user-id",
"displayName": null,
"userIdentityType": "aadUser"
}
}
}
]

 

Can somebody please confirm whether this is a bug?

Or am I doing something wrong here?

Related Conversations
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
28 Replies
Early preview of Microsoft Edge group policies
Sean Lyndersay in Discussions on
65 Replies
*Updated 9/3* Syncing in Microsoft Edge Preview Channels
Elliot Kirk in Articles on
201 Replies
Tabs and Dark Mode
cjc2112 in Discussions on
2 Replies