SOLVED
Home

Umlauts in notification emails

%3CLINGO-SUB%20id%3D%22lingo-sub-353871%22%20slang%3D%22en-US%22%3EUmlauts%20in%20notification%20emails%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-353871%22%20slang%3D%22en-US%22%3E%3CP%3EHello%2C%3C%2FP%3E%3CP%3Ewe%20have%20noticed%20that%20for%20Teams%20notification%20emails%20German%20umlauts%20%C3%A4%2C%20%C3%B6%2C%20%C3%BC%20are%20displayed%20incorrectly%20in%20some%20of%20our%20users%20Outlook%20clients.%20It%20looks%20like%20this%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F83690i0702C747304D9709%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22OUTLOOK_2019-02-20_10-20-16.png%22%20title%3D%22OUTLOOK_2019-02-20_10-20-16.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENow%2C%20where%20would%20you%20suggest%20we%20start%20looking%3F%20This%20particular%20example%20is%20from%20a%20Mac%20user%20who%20has%20his%20UI%20language%20of%20Outlook%20%2F%20and%20or%20Mac%20set%20to%20English%20instead%20of%20German.%20However%2C%20usually%20such%20a%20problem%20does%20not%20occur%20except%20for%20Teams.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECould%20this%20have%20to%20do%20with%20the%20sender%2C%20i.e.%26nbsp%3Bnoreply%40email.teams.microsoft.com%3F%20I%20don't%20suspect%20the%20Teams%20client%20itself%20from%20which%20a%20user%20mentions%20the%20recipient%20who's%20having%20the%20umlauts%20issue%20has%20something%20to%20do%20with%20it.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20for%20your%20help.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-353871%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ENotification%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ETeams%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-393655%22%20slang%3D%22en-US%22%3ERe%3A%20Umlauts%20in%20notification%20emails%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-393655%22%20slang%3D%22en-US%22%3E%3CP%3EDiscovered%20this%20same%20issue%20at%20my%20end%20today%20and%20mildly%20frustrating.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ELooking%20forward%20to%20when%20this%20bug%2Fissue%2Fanomaly%20can%20be%20rectified.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-358763%22%20slang%3D%22en-US%22%3ERe%3A%20Umlauts%20in%20notification%20emails%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-358763%22%20slang%3D%22en-US%22%3EI%20voted!%20Hope%20it%20gets%20fixed%20soon!%20Great%20spot!%3CBR%20%2F%3E%3CBR%20%2F%3EBest%2C%20Chris%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-358762%22%20slang%3D%22en-US%22%3ERe%3A%20Umlauts%20in%20notification%20emails%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-358762%22%20slang%3D%22en-US%22%3E%3CP%3EDone%2C%20thanks%20for%20your%20help%20Chris.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fmicrosoftteams.uservoice.com%2Fforums%2F555103-public%2Fsuggestions%2F36989200-bug-umlauts-in-notification-emails-displayed-in-a%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fmicrosoftteams.uservoice.com%2Fforums%2F555103-public%2Fsuggestions%2F36989200-bug-umlauts-in-notification-emails-displayed-in-a%3C%2FA%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-356119%22%20slang%3D%22en-US%22%3ERe%3A%20Umlauts%20in%20notification%20emails%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-356119%22%20slang%3D%22en-US%22%3EThanks%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F37813%22%20target%3D%22_blank%22%3E%40Florian%20Hein%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3ESounds%20in%20this%20case%20like%20a%20bug%20as%20it%E2%80%99s%20not%20rendering%20despite%20the%20above%20changes.%3CBR%20%2F%3E%3CBR%20%2F%3ERecommendation%20is%20to%20raise%20as%20a%20uservoice%20with%20BUG%3A%20prefix%20here%20as%20is%20recommended%20with%20bugs%3CBR%20%2F%3E%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fmicrosoftteams.uservoice.com%2Fforums%2F555103-public%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fmicrosoftteams.uservoice.com%2Fforums%2F555103-public%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3EHope%20that%20answers%20your%20question!%3CBR%20%2F%3E%3CBR%20%2F%3EBest%2C%20Chris%3CBR%20%2F%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-356110%22%20slang%3D%22en-US%22%3ERe%3A%20Umlauts%20in%20notification%20emails%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-356110%22%20slang%3D%22en-US%22%3E%3CP%3EHey%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F169605%22%20target%3D%22_blank%22%3E%40Christopher%20Hoard%3C%2FA%3E%2C%26nbsp%3Bthanks%20a%20lot%20for%20the%20plentiful%20list%20of%20ideas.%3C%2FP%3E%3CP%3E1.%20No%3C%2FP%3E%3CP%3E2.%26nbsp%3BNo%20difference%3C%2FP%3E%3CP%3E3.%26nbsp%3BNo%20difference%3C%2FP%3E%3CP%3E4.%26nbsp%3BNo%3C%2FP%3E%3CP%3E5.%26nbsp%3BNo%3C%2FP%3E%3CP%3E6.%20Yes%2C%20in%20header%20and%20body%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThen%2C%20I%20had%20our%20email%20team%20analyze%20the%20auto-generated%20mail%20from%20%22noreply%40email.teams.microsoft.com%20and%20the%20umlauts%20were%20displayed%20in%20ascii%20even%20before%20they%20hit%20our%20clients.%20So%20there's%20a%20strong%20suspicion%20that%20the%20issue%20originates%20from%20the%20Microsoft%20side.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20tried%20experimenting%20with%20the%20Teams%20client%20language%20settings%20but%20even%20setting%20it%20from%20my%20native%20language%20(German)%20to%20English%20on%20either%20the%20sending%20and%20receiving%20user%20does%20not%20change%20anything.%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20319px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F84237i7D7BE8E315785BAF%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Teams_2019-02-25_08-27-08.png%22%20title%3D%22Teams_2019-02-25_08-27-08.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20not%20sure%20Microsoft%20is%20aware%20of%20this%20yet.%3C%2FP%3E%3CP%3EThanks.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-353938%22%20slang%3D%22en-US%22%3ERe%3A%20Umlauts%20in%20notification%20emails%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-353938%22%20slang%3D%22en-US%22%3EHi%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F37813%22%20target%3D%22_blank%22%3E%40Florian%20Hein%3C%2FA%3E%2C%3CBR%20%2F%3E%3CBR%20%2F%3EI%20guess%20the%20first%20step%20would%20be%3CBR%20%2F%3E%3CBR%20%2F%3E1.)%20Does%20it%20render%20correctly%20in%20OWA%20(Web%20Version)%3CBR%20%2F%3E2.)%20Does%20it%20render%20correctly%20if%20they%20change%20the%20language%20to%20German%20in%20Outlook%3F%3CBR%20%2F%3E3.)%20Does%20it%20render%20correctly%20if%20they%20change%20the%20language%20to%20German%20in%20Office%20365%2C%20Teams%20and%20Outlook%3F%3CBR%20%2F%3E4.)%20Does%20it%20render%20correctly%20on%20phone%20(Outlook%20App%20for%20IPhone%2FAndroid)%3F%3CBR%20%2F%3E5.)%20Does%20it%20render%20correctly%20in%20Outlook%20on%20Windows%3CBR%20%2F%3E6.)%20Does%20it%20render%20if%20sending%20umlauts%20in%20regular%20emails%3F%3CBR%20%2F%3E%3CBR%20%2F%3ETeams%20is%20known%20to%20have%20issues%20with%20special%20characters%20so%20it%20may%20be%20along%20these%20lines%2C%20but%20I%20guess%20the%20first%20step%20is%20to%20try%20and%20nail%20down%20where%20explicitly%20this%20issue%20is.%3CBR%20%2F%3E%3CBR%20%2F%3ELooking%20forward%20to%20hearing%20from%20you%3CBR%20%2F%3E%3CBR%20%2F%3EBest%2C%20Chris%3CBR%20%2F%3E%3C%2FLINGO-BODY%3E
Florian Hein
Regular Contributor

Hello,

we have noticed that for Teams notification emails German umlauts ä, ö, ü are displayed incorrectly in some of our users Outlook clients. It looks like this:

 

OUTLOOK_2019-02-20_10-20-16.png

 

Now, where would you suggest we start looking? This particular example is from a Mac user who has his UI language of Outlook / and or Mac set to English instead of German. However, usually such a problem does not occur except for Teams.

 

Could this have to do with the sender, i.e. noreply@email.teams.microsoft.com? I don't suspect the Teams client itself from which a user mentions the recipient who's having the umlauts issue has something to do with it.

 

Thanks for your help.

6 Replies
Solution
Hi @Florian Hein,

I guess the first step would be

1.) Does it render correctly in OWA (Web Version)
2.) Does it render correctly if they change the language to German in Outlook?
3.) Does it render correctly if they change the language to German in Office 365, Teams and Outlook?
4.) Does it render correctly on phone (Outlook App for IPhone/Android)?
5.) Does it render correctly in Outlook on Windows
6.) Does it render if sending umlauts in regular emails?

Teams is known to have issues with special characters so it may be along these lines, but I guess the first step is to try and nail down where explicitly this issue is.

Looking forward to hearing from you

Best, Chris

Hey @Christopher Hoard, thanks a lot for the plentiful list of ideas.

1. No

2. No difference

3. No difference

4. No

5. No

6. Yes, in header and body

 

Then, I had our email team analyze the auto-generated mail from "noreply@email.teams.microsoft.com and the umlauts were displayed in ascii even before they hit our clients. So there's a strong suspicion that the issue originates from the Microsoft side.

 

I tried experimenting with the Teams client language settings but even setting it from my native language (German) to English on either the sending and receiving user does not change anything.

Teams_2019-02-25_08-27-08.png

 

I'm not sure Microsoft is aware of this yet.

Thanks.

Thanks @Florian Hein

Sounds in this case like a bug as it’s not rendering despite the above changes.

Recommendation is to raise as a uservoice with BUG: prefix here as is recommended with bugs

https://microsoftteams.uservoice.com/forums/555103-public

Hope that answers your question!

Best, Chris
Highlighted
I voted! Hope it gets fixed soon! Great spot!

Best, Chris

Discovered this same issue at my end today and mildly frustrating.

 

Looking forward to when this bug/issue/anomaly can be rectified.

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
46 Replies
Extentions Synchronization
Deleted in Discussions on
3 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
29 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
13 Replies