Home

Deploy pre-trained ML model on VisionAI Dev Kit

%3CLINGO-SUB%20id%3D%22lingo-sub-733573%22%20slang%3D%22en-US%22%3EDeploy%20pre-trained%20ML%20model%20on%20VisionAI%20Dev%20Kit%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-733573%22%20slang%3D%22en-US%22%3E%3CP%3EI'm%20successfully%20running%20VisionAI%20dev%20kit%20camera%20with%20VisionSample%20module%20detecting%20approximately%20183%20objects.%20Now%20I%20want%20to%20deploy%20caffe%20squeezenet%20model%2C%20so%20I'm%20following%20this%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fazure.github.io%2FVision-AI-DevKit-Pages%2Fdocs%2FDeploy_Model_using_Module_Twin%2F%22%20target%3D%22_blank%22%20rel%3D%22noopener%20nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fazure.github.io%2FVision-AI-DevKit-Pages%2Fdocs%2FDeploy_Model_using_Module_Twin%2F%3C%2FA%3E%26nbsp%3Blink%2C.%20I've%20uploaded%20model%20zip(with%20dlc%2Clabel%20and%20config.json)%20on%20my%20storage%20account%20and%20changed%20module's%20twin%2C%20updated%20%22ModelZipUrl%22.%3CBR%20%2F%3E%3CBR%20%2F%3EBut%2C%20when%20seeing%20my%20device%2C%20it%20is%20running%20the%20same%20model%20I've%20deployed%20initially%2C%20no%20changes%20detected.%20What%20I'm%20doing%20wrong%20here%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-736741%22%20slang%3D%22en-US%22%3ERe%3A%20Deploy%20pre-trained%20ML%20model%20on%20VisionAI%20Dev%20Kit%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-736741%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F369695%22%20target%3D%22_blank%22%3E%40nayangiri%3C%2FA%3E%26nbsp%3BWhat%20firmware%20version%20are%20you%20running%20on%20the%20device%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-737571%22%20slang%3D%22en-US%22%3ERe%3A%20Deploy%20pre-trained%20ML%20model%20on%20VisionAI%20Dev%20Kit%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-737571%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F250568%22%20target%3D%22_blank%22%3E%40jkubicka%3C%2FA%3E%26nbsp%3B%3CBR%20%2F%3E%3CSPAN%3Ev0.4940%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-740377%22%20slang%3D%22en-US%22%3ERe%3A%20Deploy%20pre-trained%20ML%20model%20on%20VisionAI%20Dev%20Kit%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-740377%22%20slang%3D%22en-US%22%3EIs%20the%20Twin%20Module%20Saved%20after%20updating%20the%20ModelZipURL%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-746698%22%20slang%3D%22en-US%22%3ERe%3A%20Deploy%20pre-trained%20ML%20model%20on%20VisionAI%20Dev%20Kit%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-746698%22%20slang%3D%22en-US%22%3E%3CP%3EYes.%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F250568%22%20target%3D%22_blank%22%3E%40jkubicka%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-746836%22%20slang%3D%22en-US%22%3ERe%3A%20Deploy%20pre-trained%20ML%20model%20on%20VisionAI%20Dev%20Kit%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-746836%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F250568%22%20target%3D%22_blank%22%3E%40jkubicka%3C%2FA%3E%26nbsp%3B%20Hi%2C%3C%2FP%3E%3CP%3E%3CBR%20%2F%3EI%20got%20it%20working%2C%20I%20mean%2C%20I'm%20able%20to%20deploy%20pre-trained%20ML%20model%20on%20my%20VisionAI%20development%20kit%20by%20uploading%20my%20model%20files%20on%20azure%20blob%20storage.%3CBR%20%2F%3E%3CBR%20%2F%3EPlease%20find%20below%20details%3A%3C%2FP%3E%3CP%3E%3CBR%20%2F%3E%3CU%3E%3CSTRONG%3EScenario-1%3C%2FSTRONG%3E%3C%2FU%3E%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CUL%3E%3CLI%3ECreated%20IoTedge%20Device%20from%20azure%26nbsp%3Bportal%20manually%20and%20configured%20VisionAI%20camera%20with%20the%20connection%20string.%3C%2FLI%3E%3CLI%3EFollowed%20this%20link%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fazure.github.io%2FVision-AI-DevKit-Pages%2Fdocs%2FDeploy_Model_IoT_Hub%2F%23add-modules%22%20target%3D%22_blank%22%20rel%3D%22noopener%20nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fazure.github.io%2FVision-AI-DevKit-Pages%2Fdocs%2FDeploy_Model_IoT_Hub%2F%23add-modules%3C%2FA%3E%26nbsp%3Bto%20deploy%20default%20VisionSample%20model.%3C%2FLI%3E%3CLI%3EAs%26nbsp%3B%3CSPAN%3EModelZipUrl%20is%20not%20present%20by%20default%2C%3C%2FSPAN%3E%26nbsp%3BAdded%20ModelZipUrl%2C%20saved%20and%26nbsp%3Btested.%3C%2FLI%3E%3CLI%3E%3CSPAN%3EResults%3A%20Device%20is%20not%20updating%20the%20model.%3C%2FSPAN%3E%3C%2FLI%3E%3C%2FUL%3E%3CP%3E%3CU%3E%3CSTRONG%3EScenario-2%3C%2FSTRONG%3E%3C%2FU%3E%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FP%3E%3COL%3E%3CLI%3EFollowed%20this%20link%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fazure.github.io%2FVision-AI-DevKit-Pages%2Fdocs%2FGet_Started%2F%22%20target%3D%22_blank%22%20rel%3D%22noopener%20nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fazure.github.io%2FVision-AI-DevKit-Pages%2Fdocs%2FGet_Started%2F%3C%2FA%3E%26nbsp%3Bto%20create%20IoTEdge%20device%2C%20where%20the%20device%20is%20getting%20created%20automatically%20on%20the%20azure%20portal%20and%20device%20is%20running%20with%26nbsp%3B%3CSPAN%3EAIVisionDevKitGetStartedModule%20as%20a%20default%20ML%20module.%3C%2FSPAN%3E%3C%2FLI%3E%3CLI%3E%3CSPAN%3EAs%26nbsp%3BModelZipUrl%20is%20present%20by%20default%20and%20it%20is%20blank(%22%22)%2C%26nbsp%3BAdded%20ModelZipUrl%2C%20saved%20and%26nbsp%3Btested.%3CBR%20%2F%3E%3C%2FSPAN%3E%3C%2FLI%3E%3CLI%3E%3CSPAN%3EResults%3A%20Device%20is%20running%20with%20the%20new%20model.%3C%2FSPAN%3E%3C%2FLI%3E%3C%2FOL%3E%3CP%3E%3CBR%20%2F%3ENow%20two%20things%2C%20I'm%20seeking%20answers%20for%3A%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3COL%3E%3CLI%3EWhy%20the%20Scenario-1%20is%20not%20working%20for%20me.%20(Scenario-1%20is%20the%20reason%20I%20raised%20this%20issue%20and%20explained%20initially).%3C%2FLI%3E%3CLI%3EThere%20are%20lots%20of%20different%20properties%20in%20module%20identity%20twin%20when%20VisionAI%20Kit%20itself%20is%20creating%20IoTEdge%20Device.%20So%2C%20how%20much%20impact%20we%20will%20have%20in%20case%20we%20create%20a%20device%20from%20the%20azure%20portal%20manually%20where%20we%20will%20not%20be%20having%20all%20such%20properties%20in%20module%20identity%20twin%20by%20default.%3C%2FLI%3E%3C%2FOL%3E%3CP%3EThanks%20for%20reading!!!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-748424%22%20slang%3D%22en-US%22%3ERe%3A%20Deploy%20pre-trained%20ML%20model%20on%20VisionAI%20Dev%20Kit%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-748424%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F369695%22%20target%3D%22_blank%22%3E%40nayangiri%3C%2FA%3E%26nbsp%3BScenario%201%20is%20not%20ideal%20for%20user%20experience%20and%20is%20too%20manual%20which%20may%20leave%20room%20for%20error%20-%20for%20example%3B%20the%20device%20might%20be%20created%20as%20an%20IoT%20Device%20instead%20of%20an%20IoT%20%3CSTRONG%3EEdge%3C%2FSTRONG%3EDevice.%20Scenario%202%20has%20the%20correct%20documentation%20to%20deploy%20a%20custom%20model%20with%20a%20quicker%20easier%20process.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Deleted
Not applicable

I'm successfully running VisionAI dev kit camera with VisionSample module detecting approximately 183 objects. Now I want to deploy caffe squeezenet model, so I'm following this https://azure.github.io/Vision-AI-DevKit-Pages/docs/Deploy_Model_using_Module_Twin/ link,. I've uploaded model zip(with dlc,label and config.json) on my storage account and changed module's twin, updated "ModelZipUrl".

But, when seeing my device, it is running the same model I've deployed initially, no changes detected. What I'm doing wrong here?

6 Replies
Highlighted

@Deleted What firmware version are you running on the device?

Is the Twin Module Saved after updating the ModelZipURL?

@jkubicka  Hi,


I got it working, I mean, I'm able to deploy pre-trained ML model on my VisionAI development kit by uploading my model files on azure blob storage.

Please find below details:


Scenario-1

 

Scenario-2

  1. Followed this link https://azure.github.io/Vision-AI-DevKit-Pages/docs/Get_Started/ to create IoTEdge device, where the device is getting created automatically on the azure portal and device is running with AIVisionDevKitGetStartedModule as a default ML module.
  2. As ModelZipUrl is present by default and it is blank(""), Added ModelZipUrl, saved and tested.
  3. Results: Device is running with the new model.


Now two things, I'm seeking answers for:

 

  1. Why the Scenario-1 is not working for me. (Scenario-1 is the reason I raised this issue and explained initially).
  2. There are lots of different properties in module identity twin when VisionAI Kit itself is creating IoTEdge Device. So, how much impact we will have in case we create a device from the azure portal manually where we will not be having all such properties in module identity twin by default.

Thanks for reading!!!

@Deleted Scenario 1 is not ideal for user experience and is too manual which may leave room for error - for example; the device might be created as an IoT Device instead of an IoT Edge Device. Scenario 2 has the correct documentation to deploy a custom model with a quicker easier process.

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
35 Replies
Extentions Synchronization
Deleted in Discussions on
3 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies