Home

Sysmain causing high CPU usage, possibly with new Edge

%3CLINGO-SUB%20id%3D%22lingo-sub-417457%22%20slang%3D%22en-US%22%3ESysmain%20causing%20high%20CPU%20usage%2C%20possibly%20with%20new%20Edge%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-417457%22%20slang%3D%22en-US%22%3E%3CP%3ESince%20installing%20the%20Edge%20beta%20and%20restarting%20it%20a%20few%20time%20I%20have%20observed%20a%20problem%20with%20a%20service%20called%20sysmain%20using%20larger%20amounts%20of%20system%20recourses.%20This%20may%20be%20completely%20unconnected%20from%20the%20Edge%20Beta%20and%20I%20simply%20didn't%20notice%20it%20before%20however%20I%20thought%20I%20would%20share%20just%20in%20case%20anyone%20else%20has%20experienced%20the%20same%20thing.%20It%20normally%20sits%20at%20around%2030%25%20of%20the%20CPU%20usage%20on%20my%20Surface%20Book%201%20and%20doesn't%20subside%20until%20I%20force%20it%20to%20end%20the%20process.%20This%20spawns%20another%20process%20with%20high%20usage%20which%20I%20also%20kill%20which%20then%20fixes%20the%20problem%20entirely.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-678582%22%20slang%3D%22en-US%22%3ERe%3A%20Sysmain%20causing%20high%20CPU%20usage%2C%20possibly%20with%20new%20Edge%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-678582%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F316244%22%20target%3D%22_blank%22%3E%40Cameron_Bush%3C%2FA%3E%26nbsp%3B%3CBR%20%2F%3E%3CBR%20%2F%3EBased%20on%20what%20I%20was%20able%20to%20see%20on%20my%20own%20system%2C%20Sysmain%20is%20the%20first%20subprocess%20of%20the%20Microsoft%20Edge%20Insider%20Build%20process%20tree.%26nbsp%3B%20It%20is%20running%20everything%20that%20isn't%20specifically%20part%20of%20a%20single%20Tab%20in%20the%20Browser.%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EGabriel%3C%2FP%3E%3C%2FLINGO-BODY%3E
Cameron_Bush
Contributor

Since installing the Edge beta and restarting it a few time I have observed a problem with a service called sysmain using larger amounts of system recourses. This may be completely unconnected from the Edge Beta and I simply didn't notice it before however I thought I would share just in case anyone else has experienced the same thing. It normally sits at around 30% of the CPU usage on my Surface Book 1 and doesn't subside until I force it to end the process. This spawns another process with high usage which I also kill which then fixes the problem entirely. 

1 Reply

@Cameron_Bush 

Based on what I was able to see on my own system, Sysmain is the first subprocess of the Microsoft Edge Insider Build process tree.  It is running everything that isn't specifically part of a single Tab in the Browser. 

 

Gabriel