Home

Audio device not available on MS Azure VM

%3CLINGO-SUB%20id%3D%22lingo-sub-67770%22%20slang%3D%22en-US%22%3EAudio%20device%20not%20available%20on%20MS%20Azure%20VM%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-67770%22%20slang%3D%22en-US%22%3E%3CP%3EHello%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EPlease%20forgive%20for%20asking%20basic%20question.%20I'm%20a%20newbie%20w.r.t.%20MS%20Azure.%3CBR%20%2F%3E%3CBR%20%2F%3EI'm%20accessing%20a%20media%20rich%20website%20on%20my%20Azure%20VM%20and%20want%20to%20record%20the%26nbsp%3Bscreen%20%2B%26nbsp%3Bsystem%20audio%20as%20played%20by%20the%20website.%26nbsp%3BI%20can%20record%20the%20screen%20as%20well%20as%20the%20audio%20when%20I'm%20connected%20to%20VM%20via%20a%20RDP%20(with%20RDP%20configuration%20to%20playback%20on%20local%20computer).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20can%20hear%20the%20audio%20on%20my%20local%20machine%20(when%20I%20connect%20to%20VM%20using%20a%20RDP%20connection).%3CBR%20%2F%3EHowever%2C%20I%20want%20the%20audio%20to%20be%20played%20on%20VM%20itself%20so%20the%20recorders%20can%20capture%2Frecord%20it.%20(recording%20on%20VM%20%3CVERY%20critial%3D%22%22%3E%20%2B%20local%20playback%20%3CNOT%20as%3D%22%22%20important%3D%22%22%3E)%3CBR%20%2F%3E%3CBR%20%2F%3EI'm%20using%20Camtasia%20or%20SnagIT%20to%20record%20the%20screen%20video%20%2B%20audio.%20Camtasia%26nbsp%3Bcannot%20start%20as%20it%20doesn't%20find%20an%20audio%2Fsound%20card%2Fdevice%20installed%20on%20VM%20and%20so%20it%20fails%20to%20start%20capture.%3CBR%20%2F%3E%3CBR%20%2F%3EI'm%20running%20a%20Windows%20Server%202016%20Data%20Center%20edition%20without%20the%20audio%20hardware%20installed%20on%20the%20VM%20(took%20the%20image%20from%20Azure%20market%20place%2C%20not%20sure%20how%20to%20use%20other%20VMs%20with%20an%20audio%20device%20installed).%3CBR%20%2F%3E%3CBR%20%2F%3EPlease%20let%20me%20know%3A%3C%2FNOT%3E%3C%2FVERY%3E%3C%2FP%3E%3CP%3E1.%20If%20I%20can%20install%20a%20virtual%20audio%20hardware%20to%20solve%20my%20issue%20or%3C%2FP%3E%3CP%3E2.%20If%20you%20know%20of%20any%20VM%20image%20with%20audio%20card(s)%20installed%20in%20the%20VM%20image%20or%3C%2FP%3E%3CP%3E3.%20Do%20you%20know%20of%20any%20screen%2Baudio%20recorder%20which%20decodes%20the%20incoming%20stream%20and%20identifies%20audio%20and%20thus%20records%20audio%20(even%20though%20there%20is%20no%20hardware%20installed%20-%20as%20SnagIT%20can%20record%20without%20local%20hardware%20but%20Camtasia%20cannot%20record%20without%20a%20local%20hardware)%3C%2FP%3E%3CP%3E3.%20Please%20suggest%20a%20workaround%20to%20this%20issue.%3CBR%20%2F%3E%3CBR%20%2F%3ECould%20you%20please%20help%20me%3F%3CBR%20%2F%3E%3CBR%20%2F%3ECheers%2C%3CBR%20%2F%3ErKabra%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-67770%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EVirtual%20Machine%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-71889%22%20slang%3D%22en-US%22%3ERe%3A%20Audio%20device%20not%20available%20on%20MS%20Azure%20VM%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-71889%22%20slang%3D%22en-US%22%3E%3CP%3EHello%20Ruchir%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EFirst%20of%20all%2C%20windows%20server%20does%20not%20give%20you%20the%20capabilities%20of%20audio%20at%20provisioning%20both%20on-premises%20and%20in%20Azure.%20But%20you%20can%20still%20get%20audio%20services%20from%20your%20windows%20server.%26nbsp%3B%3C%2FP%3E%3CP%3E1.%26nbsp%3Bopen%26nbsp%3B%3CSPAN%3EServer%20Manager%20%2C%20click%20on%20%3C%2FSPAN%3E%3CSTRONG%3ETools%3C%2FSTRONG%3E%3CSPAN%3E%20in%20the%20top%20right%20of%20the%20window%20and%20select%20%3C%2FSPAN%3E%3CSTRONG%3EServices%3C%2FSTRONG%3E%3CSPAN%3E.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3E2.%26nbsp%3BIn%20the%20right%20pane%20of%20Services%2C%20scroll%20down%20to%20%3CSTRONG%3EWindows%20Audio%3C%2FSTRONG%3E%20and%20double%20click%20on%20it.%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3E3.%26nbsp%3BIn%20Windows%20Audio%20Properties%2C%20change%20%3CSTRONG%3EStartup%20Type%3C%2FSTRONG%3E%20to%20Automatic%20and%20click%20on%20%3CSTRONG%3EStart%3C%2FSTRONG%3E%20under%20Service%20Status.%20Once%20done%2C%20click%20%3CSTRONG%3EOK%3C%2FSTRONG%3E.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EHowever%2C%20you%20need%20to%20make%20sure%20your%20RDP%20connection%26nbsp%3Bsupport%20remote%20audio%20which%20mostly%20will%20support%20if%20you%20using%20Microsoft%20Native%20RDP%20Client.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3COL%3E%3CLI%3E%3CSPAN%20class%3D%22Text11Pt%22%3ELaunch%20Remote%20Desktop%20Connection%3C%2FSPAN%3E%3C%2FLI%3E%3CLI%3E%3CSPAN%20class%3D%22Text11Pt%22%3EClick%20to%20expand%20Options%2C%20if%20it%20is%20not%20already.%3C%2FSPAN%3E%3C%2FLI%3E%3CLI%3E%3CSPAN%20class%3D%22Text11Pt%22%3EClick%20the%20Local%20Resources%20tab.%3C%2FSPAN%3E%3C%2FLI%3E%3CLI%3E%3CSPAN%20class%3D%22Text11Pt%22%3EUnder%20%E2%80%9CRemote%20computer%20sound%E2%80%9D%2C%20ensure%20that%20%E2%80%9CBring%20to%20this%20computer%E2%80%9D%20is%20selected.%3C%2FSPAN%3E%3C%2FLI%3E%3CLI%3E%3CSPAN%20class%3D%22Text11Pt%22%3ELogin%20to%20the%20Web%20Server%20which%20needs%20audio%20enabled.%3C%2FSPAN%3E%3C%2FLI%3E%3C%2FOL%3E%3CP%3E%3CSPAN%20class%3D%22Text11Pt%22%3EI%20hope%20this%20helps.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
RUCHIR KABRA
Occasional Visitor

Hello,

 

Please forgive for asking basic question. I'm a newbie w.r.t. MS Azure.

I'm accessing a media rich website on my Azure VM and want to record the screen + system audio as played by the website. I can record the screen as well as the audio when I'm connected to VM via a RDP (with RDP configuration to playback on local computer).

 

I can hear the audio on my local machine (when I connect to VM using a RDP connection).
However, I want the audio to be played on VM itself so the recorders can capture/record it. (recording on VM <very critial/important> + local playback <not as important>)

I'm using Camtasia or SnagIT to record the screen video + audio. Camtasia cannot start as it doesn't find an audio/sound card/device installed on VM and so it fails to start capture.

I'm running a Windows Server 2016 Data Center edition without the audio hardware installed on the VM (took the image from Azure market place, not sure how to use other VMs with an audio device installed).

Please let me know:

1. If I can install a virtual audio hardware to solve my issue or

2. If you know of any VM image with audio card(s) installed in the VM image or

3. Do you know of any screen+audio recorder which decodes the incoming stream and identifies audio and thus records audio (even though there is no hardware installed - as SnagIT can record without local hardware but Camtasia cannot record without a local hardware)

3. Please suggest a workaround to this issue.

Could you please help me?

Cheers,
rKabra

1 Reply
Highlighted

Hello Ruchir,

 

First of all, windows server does not give you the capabilities of audio at provisioning both on-premises and in Azure. But you can still get audio services from your windows server. 

1. open Server Manager , click on Tools in the top right of the window and select Services.

2. In the right pane of Services, scroll down to Windows Audio and double click on it. 

3. In Windows Audio Properties, change Startup Type to Automatic and click on Start under Service Status. Once done, click OK.

 

However, you need to make sure your RDP connection support remote audio which mostly will support if you using Microsoft Native RDP Client.

 

  1. Launch Remote Desktop Connection
  2. Click to expand Options, if it is not already.
  3. Click the Local Resources tab.
  4. Under “Remote computer sound”, ensure that “Bring to this computer” is selected.
  5. Login to the Web Server which needs audio enabled.

I hope this helps.

 

 

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
48 Replies
Extentions Synchronization
Deleted in Discussions on
3 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
30 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
13 Replies