SOLVED
Home

Azure Sentinel Fortinet Data Connector issues

%3CLINGO-SUB%20id%3D%22lingo-sub-885278%22%20slang%3D%22en-US%22%3EAzure%20Sentinel%20Fortinet%20Data%20Connector%20issues%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-885278%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20having%20issues%20using%20the%20Fortinet%20Data%20Connector.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20followed%20the%20configuration%20details%20given%2C%20and%20configured%20the%20rsyslog%20daemon%20on%20the%20syslog%20server%2C%20as%20well%20as%20the%20omsagent%2C%20however%20I%20am%20receiving%20syslog%20events%20in%20to%20Azure%20Sentinel%2C%20and%20not%20CommonSecurityLog%20events%2C%20from%20the%20data%20being%20ingested.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20suspect%20this%20is%20because%20there%20is%20no%20communication%20between%20the%20rsyslog%20daemon%20and%20the%20omsagent%2C%20but%20I%20cannot%20work%20out%20why.%20To%20test%20that%20comms%20elsewhere%20were%20working%2C%20I%20configured%20omsagent%20to%20collect%20syslog%20data%20on%20local4%20facility%2C%20within%20the%20log%20analytics%20workspace%20advanced%20settings%2C%20and%20these%20are%20now%20collected%20-%20but%20obviously%20there's%20no%20parser%20currently%20configured%20that%20understands%20the%20fields%20within%20the%20syslog%20messages%20received%2C%20and%20ideally%20I'd%20like%20to%20work%20out%20why%20rsyslog%20is%20not%20communicating%20on%20port%2025226%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F134097iA4A37D57CFA908E5%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20alt%3D%22netstat-an.PNG%22%20title%3D%22netstat-an.PNG%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20following%20command%20was%20run%20to%20give%20security-config-omsagent.conf%20the%20following%20config%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3Esudo%20bash%20-c%20%22printf%20'local4.debug%20%40127.0.0.1%3A25226%3Amsg%2C%20contains%2C%20%22Fortinet%22%20%40127.0.0.1%3A25226'%20%26gt%3B%20%2Fetc%2Frsyslog.d%2Fsecurity-config-omsagent.conf%22%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EHowever%2C%20the%20syslog%20events%20being%20received%20do%20not%20contain%20%22Fortinet%22%2C%20but%20even%20if%20I%20change%20this%20to%20%22%3Amsg%2C%20contains%2C%20*.*%20%40127.0.0.1%3A25226'%22%20in%20the%20config%2C%20I'm%20still%20not%20seeing%20any%20logs%20under%20the%20Fortinet%20data%20connector%2Fcommonsecuritylog%20events%20in%20Sentinel.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EI've%20confirmed%20using%20wireshark%20that%20syslog%20events%20are%20being%20received%20from%20the%20firewalls.%20I%20can%20also%20confirm%20that%20syslog%20data%20from%20facility%20local4%20is%20being%20received%20in%20Sentinel%20-%20so%20the%20omsagent%20is%20working%2C%20it%20appears%20the%20rsyslog%20daemon%20is%20not%2C%20but%20I%20cannot%20understand%20how%20to%20resolve%20this%20issue.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EAny%20assistance%20would%20be%20gratefully%20received.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-891819%22%20slang%3D%22en-US%22%3ERe%3A%20Azure%20Sentinel%20Fortinet%20Data%20Connector%20issues%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-891819%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F409192%22%20target%3D%22_blank%22%3E%40srthomson%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3Edid%20you%20add%20the%20Set%20format%20cef%20below%3F%3F%20sounds%20like%20you%20might%20be%20missing%20CEF%20format.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3Efrom%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fsentinel%2Fconnect-fortinet%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fsentinel%2Fconnect-fortinet%3C%2FA%3E%3C%2FP%3E%0A%3CP%3E%3CSPAN%3E%20config%20log%20syslogd%20setting%20%3C%2FSPAN%3E%3C%2FP%3E%0A%3CP%3E%3CSPAN%3Eset%20format%20cef%20%3C%2FSPAN%3E%3C%2FP%3E%0A%3CP%3E%3CSPAN%3Eset%20facility%20%3CFACILITY_NAME%3E%20%3C%2FFACILITY_NAME%3E%3C%2FSPAN%3E%3C%2FP%3E%0A%3CP%3E%3CSPAN%3Eset%20port%20514%20%3C%2FSPAN%3E%3C%2FP%3E%0A%3CP%3E%3CSPAN%3Eset%20reliable%26nbsp%3B%3C%2FSPAN%3E%3CSPAN%3Edisable%3C%2FSPAN%3E%3C%2FP%3E%0A%3CP%3E%3CSPAN%3Eset%20server%20%3CIP_ADDRESS_OF_RECEIVER%3E%20%3C%2FIP_ADDRESS_OF_RECEIVER%3E%3C%2FSPAN%3E%3C%2FP%3E%0A%3CP%3E%3CSPAN%3Eset%20status%20enable%20end%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-891887%22%20slang%3D%22en-US%22%3ERe%3A%20Azure%20Sentinel%20Fortinet%20Data%20Connector%20issues%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-891887%22%20slang%3D%22en-US%22%3EThanks%2C%20that%20option%20isn't%20available%20on%20our%20firewalls%2C%20we%20have%20to%20run%20%22set%20csv%20disable%22%20instead.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-891959%22%20slang%3D%22en-US%22%3ERe%3A%20Azure%20Sentinel%20Fortinet%20Data%20Connector%20issues%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-891959%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F409192%22%20target%3D%22_blank%22%3E%40srthomson%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3Ewe%20only%20support%20CEF..%20can%20you%20upgrade%20your%20firewall%20os%3F%3F%20to%20get%20this%20option%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-916869%22%20slang%3D%22en-US%22%3ERe%3A%20Azure%20Sentinel%20Fortinet%20Data%20Connector%20issues%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-916869%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20upgraded%20the%20OS%20on%20the%20firewall%2C%20so%20now%20we%20are%20receiving%20CEF%20format%20syslogs%2C%20which%20is%20great.%3CBR%20%2F%3EThe%20logs%20are%20being%20received%20on%20port%20514%20on%20the%20syslog%20server%2C%20confirmed%20by%20running%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Esudo%20tcpdump%20-A%20-ni%20any%20port%20514%20-vv%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-center%22%20style%3D%22width%3A%20850px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F137920iC7CC5EDAAA37D8FD%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22CEF_Firewall.PNG%22%20title%3D%22CEF_Firewall.PNG%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHowever%2C%20when%20I%20try%20and%20confirm%20if%20there's%20traffic%20being%20passed%20to%20port%2025226%2C%20there's%20nothing%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-center%22%20style%3D%22width%3A%20865px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F137900i86C10FE812DB5212%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Port_25226_Nothing.PNG%22%20title%3D%22Port_25226_Nothing.PNG%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EYet%20the%20configurations%20are%20correct%2C%20for%20rsyslog%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-center%22%20style%3D%22width%3A%20832px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F137901i97D4E147C6D9367F%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22rsyslog_config.PNG%22%20title%3D%22rsyslog_config.PNG%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAnd%20for%20the%20OMS%20Agent%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-center%22%20style%3D%22width%3A%20769px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F137902i36862130BABC5D69%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Security-config-omsagent-config.PNG%22%20title%3D%22Security-config-omsagent-config.PNG%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHowever%2C%20the%20data%20is%20successfully%20being%20sent%20via%20oms%20agent%20for%20syslog%20data%20on%20port%2025224%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-center%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F137907i1F98E5B700DBC13F%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Syslog_25224.PNG%22%20title%3D%22Syslog_25224.PNG%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%3CP%3EWhich%20is%20being%20received%20in%20to%20Azure%20Sentinel%20fine.%20I've%20then%20removed%20the%20syslog%20data%20capture%20on%20local4%20facility%2C%20so%20that%20the%20%22local4.%3Dalert%3B....%22%20of%20the%20above%20screenshot'd%20config%20file%20is%20no%20longer%20evident%2C%20and%20syslog%20is%20no%20longer%20captured%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-center%22%20style%3D%22width%3A%20860px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F137913iDCC3CFCE53368138%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%2295-omsagent-config.PNG%22%20title%3D%2295-omsagent-config.PNG%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20omsagent.d%20security_events.conf%20file%20settings%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-center%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F137914i8694A1BC2DF4D2AB%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22security_conf-omsagent.PNG%22%20title%3D%22security_conf-omsagent.PNG%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20literally%20can't%20see%20what%20the%20issue%20is%20at%20all%2C%20and%20need%20some%20assistance%20please.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-917275%22%20slang%3D%22en-US%22%3ERe%3A%20Azure%20Sentinel%20Fortinet%20Data%20Connector%20issues%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-917275%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F409192%22%20target%3D%22_blank%22%3E%40srthomson%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EHi%3C%2FP%3E%0A%3CP%3EIm%20confused%20with%20this%20%22%3CSPAN%3EWhich%20is%20being%20received%20in%20to%20Azure%20Sentinel%20fine.%20I've%20then%20removed%20the%20syslog%20data%20capture%20on%20local4%20facility%2C%20so%20that%20the%20%22local4.%3Dalert%3B....%22%20of%20the%20above%20screenshot'd%20config%20file%20is%20no%20longer%20evident%2C%20and%20syslog%20is%20no%20longer%20captured%3A%22%3C%2FSPAN%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CSPAN%3Eso%20it%20was%20working%2C%20then%20you%20remove%20the%20local4%20data%20in%2095-omsagent%3F%3F%3F%26nbsp%3B%20if%20it%20was%20working%2C%20why%20remove%20it%3F%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-917383%22%20slang%3D%22en-US%22%3ERe%3A%20Azure%20Sentinel%20Fortinet%20Data%20Connector%20issues%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-917383%22%20slang%3D%22en-US%22%3EBecause%20that's%20not%20the%20right%20ingestion%20method%20-%20it%20should%20be%20being%20parsed%20in%20sentinel%20as%20CommonSecurityLog%2C%20not%20syslog.%20Once%20you%20change%20the%20firewall%20output%20to%20CEF%2C%20the%20syslog%20method%20doesn't%20work.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-917684%22%20slang%3D%22en-US%22%3ERe%3A%20Azure%20Sentinel%20Fortinet%20Data%20Connector%20issues%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-917684%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F409192%22%20target%3D%22_blank%22%3E%40srthomson%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3Egot%20it.%20i%20missed%20that%20it%20was%20going%20to%20syslog%20not%20Commonsecuritylog.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3Esilly%20question.%26nbsp%3B%20since%20removing%20the%20config%20from%2095-omsagent%20have%20your%20restarted%20syslog%20and%20OMS%20agent%3F%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-917687%22%20slang%3D%22en-US%22%3ERe%3A%20Azure%20Sentinel%20Fortinet%20Data%20Connector%20issues%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-917687%22%20slang%3D%22en-US%22%3ESilly%20question%2C%20but%20one%20I%20appreciate%2C%20yes.%20After%20every%20config%20change%2C%20both%20are%20restarted%20to%20pull%20through%20the%20config%20changes.%3C%2FLINGO-BODY%3E
srthomson
Occasional Contributor

I am having issues using the Fortinet Data Connector.

 

I have followed the configuration details given, and configured the rsyslog daemon on the syslog server, as well as the omsagent, however I am receiving syslog events in to Azure Sentinel, and not CommonSecurityLog events, from the data being ingested.

 

I suspect this is because there is no communication between the rsyslog daemon and the omsagent, but I cannot work out why. To test that comms elsewhere were working, I configured omsagent to collect syslog data on local4 facility, within the log analytics workspace advanced settings, and these are now collected - but obviously there's no parser currently configured that understands the fields within the syslog messages received, and ideally I'd like to work out why rsyslog is not communicating on port 25226:

 

netstat-an.PNG

 

The following command was run to give security-config-omsagent.conf the following config:

 

sudo bash -c "printf 'local4.debug @127.0.0.1:25226:msg, contains, "Fortinet" @127.0.0.1:25226' > /etc/rsyslog.d/security-config-omsagent.conf"

 

However, the syslog events being received do not contain "Fortinet", but even if I change this to ":msg, contains, *.* @127.0.0.1:25226'" in the config, I'm still not seeing any logs under the Fortinet data connector/commonsecuritylog events in Sentinel.

 

I've confirmed using wireshark that syslog events are being received from the firewalls. I can also confirm that syslog data from facility local4 is being received in Sentinel - so the omsagent is working, it appears the rsyslog daemon is not, but I cannot understand how to resolve this issue.

 

Any assistance would be gratefully received.

 

 

12 Replies

@srthomson 

 

did you add the Set format cef below?? sounds like you might be missing CEF format.

 

from https://docs.microsoft.com/en-us/azure/sentinel/connect-fortinet

config log syslogd setting

set format cef

set facility <facility_name>

set port 514

set reliable disable

set server <ip_address_of_Receiver>

set status enable end

Thanks, that option isn't available on our firewalls, we have to run "set csv disable" instead.

@srthomson 

we only support CEF.. can you upgrade your firewall os?? to get this option?

I have upgraded the OS on the firewall, so now we are receiving CEF format syslogs, which is great.
The logs are being received on port 514 on the syslog server, confirmed by running:

 

sudo tcpdump -A -ni any port 514 -vv

CEF_Firewall.PNG

 

 

However, when I try and confirm if there's traffic being passed to port 25226, there's nothing:

 

Port_25226_Nothing.PNG

 

Yet the configurations are correct, for rsyslog:

 

rsyslog_config.PNG

 

And for the OMS Agent:

 

Security-config-omsagent-config.PNG

 

However, the data is successfully being sent via oms agent for syslog data on port 25224:

 

Syslog_25224.PNG

  

Which is being received in to Azure Sentinel fine. I've then removed the syslog data capture on local4 facility, so that the "local4.=alert;...." of the above screenshot'd config file is no longer evident, and syslog is no longer captured:

 

95-omsagent-config.PNG

 

The omsagent.d security_events.conf file settings:

 

security_conf-omsagent.PNG

 

I literally can't see what the issue is at all, and need some assistance please.

@srthomson 

Hi

Im confused with this "Which is being received in to Azure Sentinel fine. I've then removed the syslog data capture on local4 facility, so that the "local4.=alert;...." of the above screenshot'd config file is no longer evident, and syslog is no longer captured:"

 

so it was working, then you remove the local4 data in 95-omsagent???  if it was working, why remove it?

Because that's not the right ingestion method - it should be being parsed in sentinel as CommonSecurityLog, not syslog. Once you change the firewall output to CEF, the syslog method doesn't work.

@srthomson 

got it. i missed that it was going to syslog not Commonsecuritylog.

 

silly question.  since removing the config from 95-omsagent have your restarted syslog and OMS agent??

Silly question, but one I appreciate, yes. After every config change, both are restarted to pull through the config changes.

@srthomson Hi ! 

 

I have exactly the same issue, and we still did not have any answer : even with MS team. 

 

In my opinion the agent might have so trouble, but no logs helps to confirm that. 

 

I will keep you informed if we find a way to make it work, 

 

(sorry for my english, it's not my mother tongue) 

Solution

@pingutux 

 

I resolved the issue for us.

 

First I had to upgrade the Fortinet OS to 5.6.x so that it supported CEF output format.
Then I had to ensure that on the analytics workspace page, under Advanced Settings>Data>Syslog that syslog was added:

 

syslog.PNG

 

Then altered the security-config-omsagent.conf with escape characters (that are missing from the copy-paste command within the Sentinel Data Connector page for Fortinet:

 

The command given:

sudo bash -c "printf 'local4.debug @127.0.0.1:25226:msg, contains, "Fortinet" @127.0.0.1:25226' > /etc/rsyslog.d/security-config-omsagent.conf"

 

The new amended command I ran:

sudo bash -c "printf 'local4.debug @127.0.0.1:25226:msg, contains, \"Fortinet\" @127.0.0.1:25226' > /etc/rsyslog.d/security-config-omsagent.conf"

 

However, I have noted that since I had this issue, Microsoft have updated their configuration documentation, and it is completely different now. So, what fixed it for me, might not fix it for you.

 

I was asked by MS Support to send them the following data:

 

Netstat -anp | grep syslog

Netstat -anp | grep oms

Netstat -anp | grep ruby

Tcpdump -nni any port 25244 or port 25246 ( just a few lines if present)

Tcpdump -nni any port 514 ( just a few lines if present)

tail -f /var/opt/microsoft/omsagent/log/omsagent.log

tail -f /var/log/syslog or this path $WorkDirectory /var/spool/rsyslog

 

And to check the following:

 

That the Log Analytics workspace is set to standard

LogAnalyticsWorkspaceSetting.png

 

Data collection is set to All Events

DataCollectionAllEvents.png

 

That the Log Analytics Workspace has syslog enabled

syslog.PNG

 

Hopefully you get to a resolution and some of the above helps you troubleshoot.

@srthomson I owe you and the MS support a Beer ---- It's working !!!

 

What I've done is

- Correcting the security-config-omsagent.conf 

- Adding the syslog facility

- Restart both services 

 

You made my day !

 

clipboard_image_0.png

My pleasure, glad I helped. I struggled for days trying to troubleshoot.
Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
46 Replies
Extentions Synchronization
Deleted in Discussions on
3 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
29 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
13 Replies