File not found error while trying to upload a file to a sharepoint site library

Occasional Contributor

I have been recently getting the following error while trying to upload a file to a SP site library.

"File not found". It pops up after I upload the file. Any help in this matter would be greatly appreciated.


6 Replies
best response confirmed by Hammad Hassan Khan (Occasional Contributor)

Please try below steps

  1. Navigate to the Library settings
  2. Click Manage files which have no checked in version
  3. go and checkin in all the files
  1. Delete everything at %USERPROFILE%\AppData\Local\Microsoft\WebsiteCache
  2. Delete everything at %APPDATA%\Microsoft\Web Server Extensions\Cache

If it still doesn't work try to update your file name and re upload.

I'm having the exact same issue only in the modern browser view. When I switch to classic view this works fine. I emptied both cache folders and had no unchecked in items. Any other thoughts? I've tried this in all browsers with the exact same result.

Hey. I am a newbie in this. Cant file the adresses that you mentioned. I tried them in the file explorer after putting my userprofile. Thanks in advance!

Here is what I did.


Open a command prompt and type (without quotes) `cd %USERPROFILE%\AppData\Local\Microsoft\WebsiteCache`


This will change the directory to the right directory. Then copy that Address (starting with C:\Users...) to Windows explorer to get to these files there.



I did the same thing and got this. Am I doing something wrong. I tried it with website cache and the other cache too but cudn't find the folders.


Windows + R 


Paste the url from above and voila!