Outlook for iOS: cannot load or send attachments

New Contributor

I am using the MS Outlook app on my iPhone and iPad.


Since about 2 weeks, I am unable to open any attachment (all file types are affected) and images embedded into emails are not shown. Furthermore, I am not able to send emails with attachments as emails just get stuck in the Outbox. I have no problems to open the files on my desktop computer or on the web. It is just in the app.


In the meantime, I have resetted my account in the app multiple times, have deleted and reinstalled the app and even deleted and reinstalled the company profile on the devices. All of this with no effect; the error persists. My colleagues don’t have any problems despite having the same hardware.


Has anybody else the same problems? Is there a solution available that the in-app support doesn’t know of?


16 Replies

@m-v-r, I am encountering the same issue, did you find a solution by any chance?


I have never heard of a solution.


But with the latest update (version 3.23.0) 2 days ago, this has been solved and I am finally able to open attachments on iOS again. On the iPad I had to quit and reopen the app 2 or 3 times but now it works as well.

Same for me



same issue here

@m-v-r  -> I'm on version 3.33.0 and this is still an issue with me. Not sure if it broke between 3.23.0 & 3.33.0, but I see a PGP signature attachment (which came across as S/MIME), but a PDF and two ICS attachments aren't showing on either iPhone or iPad Pro on iOs 12.3.1. I then updated my iPhone to 12.4 and still didn't see the attachments. 



Same here.  I can send emails from Outlook for iOS on my iPad Pro, using my Office 365 subscription ... as long as they don’t have an attachment.  In recent weeks, if I add a PDF or a file I get a failure message:




I’ve tried resetting the account, to no avail.  Eventually, I simply have to send the mail using the native iOS Mail app ... using the same ISP and email account.


So, what next?  Ditch Outlook?

I too am getting the same problem. Cannot attach any image, file etc from my iPhone to outlook. This happened after I updated to iOS 13. But have no problems with gmail

I have had the same issues.  I have even changed phones with more storage.  Any attachment it locks up or doest not load.  Please let me know.

Det. Rich@m-v-r 



Does this happen with all of the attachments or only particular one ? What are those attachments except for PDF or Excel ( I assume that you have those apps installed as well )

Please do a test. Create a Word file on another device and send it to your account and try to open it on IOS.

Please share the results.







Since Outlook for iOS 4.9.0 and iPadOS 13.2, at end October 2019, the problem of not being able to attach certain files to outgoing iPad Outlook mail messages has been resolved, in my experience.

I had the same issue - after updating the iOS (IpadOS 13.2.), updating the Google Drive and updating Outlook App. I cleared the 'Allowed Apps' in the Google Drive; Allow Microsoft again to be 'Allowed' Still the same issue. Finally what did it was to remove the Google E-Mail account from Outlook and rebuild it. It did ask for permission again (a bit different screen- newer looking) and it WORKED!

Not working here. I’ve tried to attach from within the app from Onedrive, attach within from iCloud drive, and drag and drop from the Onedrive app. Eventually gave up and used the stock mail app.



Kinda ridiculous to have a 6 month old issue for sending attachments on a business-oriented email app.

January 2020. I’m still having this issue! (Setup: iPad Pro with latest software. Outlook for iPad).





I am having the same issue.  PDF, Word, JPEG files are all showing the error message shown in the previous thread.  I am using an iPad with the Outlook app installed as my mail application.  I am using it for my gmail account.


I have tried attaching from OneDrive, the file system on my iPad Pro, DropBox.


iPad 13.6.1

iPad Pro

Model number: MZAW2LL/A



Same issue as above, no attachments can be viewed or downloaded via Outlook version 4.57.0 running IOS 140.0.1.

I am having the same issue, running Outlook (via Microsoft 365) on an iOS device (MacBook Pro with Outlook for Mac, version 16.42).  I am finding that when I access my Gmail account via Outlook, I am having the following issues:--


1) none of the emails with attachments are showing in the email (ie. the attachments do not appear with the email concerned)

2) none of the email footers (or graphics contained in the email) are downloading... (so they just appear as large, blank boxes within the body of the email).


Any thoughts / comments / advice on how to resolve these issues please?