Files on Demand - The Cloud sync engine failed to validate the download - Error 0x8007017F

Occasional Contributor



I have a customer whom we've recently turned on 'Files On Demand' (version 17.3.7076.1026 - most recent version). Intermittently when they open file's from Sharepoint (Via One Drive Files on Demand), they receive the below error (screenshot below)


Error 0x8007017F: The Cloud sync engine failed to validate the downloaded data.



Any ideas how we can resolve or why we are getting the above error?




34 Replies

Happening to me too after turning on the new OneDrive "on the fly" file sync.  PDFs seem to open, but Office Docs present that error with a TRY AGAIN, SKIP or CANCEL option.  CLicking TRY AGAIN multiple times (2-10) ultimately gets the file to open.  Clearly something is failing between the OS and the CLOUD validation/hand-off process when retrieving from the CLOUD.  Hopefully the bug gets worked out -- I can't roll this out to clients or end-users like this.



Same here... When I open a xls or doc file I get this error message. When I use the Try Again button the file opens correctly. But when I save the edited version One Drive also creates a copy...

Same problem on one of our workstations. At first I thought it might be an Office issue, but re-installing Office made no difference, so it definitely has something to do with OneDrive and "Files on Demand"



Do you know if there was any resolution to this? I'm getting it on one File (out of hundreds) I've sync'd but I've no idea why/what the difference with that file is!


As another contributor says, it's going to make roll-out of this difficult...





Same problem over here.. Anyone any news to share? I have it on a lot of files. Almost impossible to work. Think about rolling back the whole migration. Migrated the files with sharepoint migration tool from MS. Anyone else here using the tool. Could it be related to it?

Same here - none of us can get to any of our files. Seems like this has been going on for months now - just caught up to us, I suppose? Not seeing any activity - we'll pull our clients off and put them on amazon, I suppose - at least they get back to you.

Same issue here... only some document libaries are affected and usually Excel files. Users using OneDrive 18.044.0301.0006 (newst) version. Any update for this issue?

Did you ever find a resolution / solution to this?  We're experiencing this problem at a client.



for me it was resolved by the next update to Office, so worth checking for Office updates on affected PCs. ((I'm on Office Insider the actual version you have may not be the same)







My customer has the same issue on all his computers with the latest Windows 10 Updates for v1803 and the latest Office update (18.065.0329.0002) as of Friday 18th May. Very annoying and support didn't find a cause, yet.

just make it stay ,and it will be no error

Does anyone have an update on this yet?  We have about 6 users using Files On-Demand and 2 are experiencing this and the others are not.  The two that are are syncing the same libraries.  The other 4 are not.  So maybe an issue with the library?

I was able to reproduce this when a file was being edited on two PC's at the same time. Onedrive renamed the file on one computer, adding the computer name to the filename. The computer on which the file was renamed is now unable to sync the original file name (even though I deleted the renamed file).


I was able to resolve this by

  1. taking a copy of the file on the computer without the problem (saving out of OneDrive alltogether)
  2. delete the original file on the computer not reporting the error
  3. moving the copy to OneDrive in place of the file just deleted

HI has anyone a solution to this issue????

I have an ongoing ticket with Microsoft on this.  Several attempts at fixing have been made with unreleased versions of OneDrive.  No dice.

I'm having the same issue with a client. I removed the files on demand then readded. Waiting to see if that worked.

Hey. Any progress on this issue? I have same error for a new Doc Library seems to be effecting all users.
Yes, I had the same problem today trying to copy files from OneDrive to backup on a thumb drive; however, I got around it. I had to change the setting on OneDrive to share files. Right Click that drive, go to Properties, slick the Sharing tab and follow the instructions.
However, this does not like to copy entire folders unless they are empty, but you can select all files to copy at once (in a folder) to paste where you want.
Hope this helps.