Teams Recording Grayed Out

Occasional Contributor

Hi Teams,


All of the sudden, Teams Recording is Grayed Out for all users.

18 Replies
Can you check if someone made a change to the meetings policy?

Hi Adam,@adam deltinger 


Thank you for your prompt reply.. h ow can i check that.. until last night it was working perfectly fine..


can you please assist me on this.. ?




Haven’t yet heard of any service interruptions. Please check with an admin

Hi Adam,
Yes, that was surprised actually, I have logged a case with MS to investigate.. This it could be to the recent Migration activity happened on the Tenant from Exchange Unified to Cloud VoiceMail Service.. This could be a reason.. The problem we need the recording feature quite urgently to record couple of classes and meetings.. :)
First rule out that changes to the policy have been made and that users are assigned the stream license
Stream Lic Trail is off on my user account.. I have enabled it but still the same..I don't think this is a lic issue though..

I have verified this license also and its enabled .. Microsoft Stream for O365 E5 SKU and Microsoft Teams under this license is enabled to Microsoft 365 A5 for faculty

Hi Guys,

Anyone available to help,.. the o365 Engineer very slow in response to this issue.






Any resolve? Having the same issue, suddenly, no license issue, not a super user.




@kuykendall97 Hi Karen,


This has been a common issue with Teams Meeting. My recommendations would be the following:


  1. Ask your Teams Administrator if "Allow Recording" is deactivated in the Meetings Policy for all users.
  2. Reach out to your M365 Teanant Administrator to create a support ticket to resolve this issue with a Microsoft Engineer.

In my case, I'm the tenant admin in my company, and weeks ago this feature was grey when I tried to record a meeting and it stayed like that for over the weekend, but back in Monday everything was working fine, so it must be a Microsoft issue.

I'm having the same issue. However, does the OS make a difference? My colleagues are using work computers with Windows 10 and they say it works fine for them and they are able to record meetings. However, I am using my personal/home laptop, which has 8.1 Enterprise. I also am unable to change the background when the video is up.

Hi Christian!, Teams also should be able to work with Windows Enterprise 8.1, however it would be also beneficial if you could upragade it to W10. On the other hand, you have to consider the differents variables to why you can't start a meeting recording. Here you can see some of the requirements as to why you may no be eligible to record meetings, also consider some of the points that i shared above to Karen.

And to change the background you must be able to change it and customize it. If you have a Tenant admin, it would be easier to request him or her to open a suport ticket so a Microsoft support engineer can help you and maybe give you more insights related to your specific problem. :smile:

Backgrounds require AVX2 support on your CPU. If you have 8.1 you probabaly also have an older cpu architecture. That’s most likely the issue.





ykendall97 It is a setting in the Team Meeting settings if the owner of the Team Meeting has Who can Present set to "Only Me" then you can't record the meeting. It is not very intuitive by Microsoft.

Hi Team,


I recently moved the storage path from Stream to One Drive after that one to one meeting, recordings option gred out and not changed the messaging policies.  


HI there


I had the greyed out problem myself. 
I managed to fix it via PowerShell using the following.

Connect to ExchangeOnline


If module not installed yet :
Get-module MicrosoftTeams 

Install-module MicrosoftTeams

Import-Module MicrosoftTeams
Get-CsTeamsCallingPolicy -Identity Global
If the info shows : AllowCloudRecordingForCalls : False

Then run : Set-CsTeamsCallingPolicy -Identity Global -AllowCloudRecordingForCalls $true 

Run "Get-CsTeamsCallingPolicy -Identity Global" again to check that it is now reporting : 
AllowCloudRecordingForCalls : True
Have users restart their Teams Desktop app and it will work. 

Great share