Teams on macOS only shows a blank white screen

New Contributor

Hi all,

 

for a few weeks now, my Teams app on macOS doesn't work anymore. When I open it, I just get a blank white window. No possibility to do anything. Closing and Re-Opening the Window doesn't help. Quitting the app takes unusually long (~10-15 seconds).

 

What I've tried:

  • Deleting and re-installing the app
  • Deleting caches and other "Application Data" (while re-installing the app)
  • Logging out and back in
  • Sweeping the entire app and any data associated with it using AppCleaner, then re-installing the app

Up until now, I could use an old installer to get an older version of Teams (v1.00.333671). This would then still run with almost no issues, only the "virtual background" feature in video calls was not working.

However, since Teams has Auto-Update always enabled and it's impossible to turn off, this only lasts a few days. Starting today, it stopped working altogether and now only shows a "please update to the latest version" banner. So now I'm stuck using the web app in the browser, which is far from great.

 

Hardware is a 13-inch MacBook Pro from 2018, running the latest macOS Monterey.

Needless to say that up until this problem showd up, everything was running perfectly. No problems with the teams app whatsoever, and all features worked as expected. So I guess it can't be a hardware issue. Software-wise there isn't much going on apart from the usual macOS updates.

 

I'd appreciate any tips on how I can resolve this.

8 Replies

Hi @jlubberger This issue has shown up a lot in this community - you might want to search here for related posts...like this one: Microsoft Teams for MacOS is Blank - Microsoft Tech Community

Thanks for the reply, I didn't mention that in my post: Of course I already did an extensive search on the topic and stumbled upon a couple of threads in this community. However, most of them boil down to other problems or, in the case of the thread You mention, were solved with a solution that didn't work for me (logging out via the dock context menu didn't work for me, and even logging out in the "old-but-still-running" version didn't help).
Hi. I'm having the same issue and can not find any solution to this problem.. Did you find any solution for it? What I also found is that I also cannot open teams on any browser and even in incognito.

@ghostrider98No, so far I couldn't find any solution. I'm stuck using the Browser version which sadly is restricted to chromium-based browsers by Microsoft. However, at least that works acceptably.

If even this does not work for you, it seems the problem might be more fundamental in Your case, and not specific to the (Mac) app.

@jlubberger Try the utility at office-reset.com and do a "Factory Reset" of Teams. It is the best option I know of for addressing unusual issues with Office apps. I make the reset packages offered at that site available to my entire fleet in Jamf Self Service and I probably run that reset on Teams on my own computer 2-3x a year.

@finlay I tried your solution with a Factory Reset with office-reset.com and I'm at least getting now a new window where it says that Microsoft Teams is loading. But now it is stuck on this :( 

@finlaySame for me as with ghostrider98, unfortunately: Using that tool (which looks quite promising, I must say), I got to the point where I was asked for my credentials to log in, but after that, I got stuck at the splash screen / loading banner. A "second round" of resetting also didn't help.

Edit: After a long time, the loading screen disappears and I get the same blank window as described in the original post.

@jlubberger If you right-click on the teams icon that is in the dock you can also open the loading banner (or at least it is for me like that) and the blank window is unfortunately still there..