SOLVED

Mute button is stopped working in Teams with my Poly headset

New Contributor

Hi!

I have the following issue:
I have received a Platronics Savi 8220 UC series headset a month ago.
Still this week its worked properly, without any issue, but from this week I cannot mute myself during a Teams call. If I try to mute myself, its show muted icon for a sec, but immediately change back to unmuted state. And this is not only occur if I press the mute button on the headset, but also if I try to do the same on the screen.

The mute button is working in any other application, even in Teams online, only have the issue on Teams desktop app.
If I use the laptop default, build in speaker, the issue is gone.
So the problem is with the Poly Headset and Teams app.

I have tried to update version in Poly, also in Teams, and office365, also updated the drivers, but cannot solved the issue so far.

4 Replies
best response confirmed by Tauron112 (New Contributor)
Solution

Hi everybody,

we are also using Platronics Savi 8220 UC and 8210 UC headsets at our company. Today some of our users reported the same issue with Teams. In the Teams webclient muting is working without any problems. Also with our swyx client the headsets muting button is working too.

 

Found this thread at the poly community: https://community.polycom.com/t5/DECT-Wireless-Headsets/Savi-8220-and-Teams-Mute-Button-stopped-work... 

@Johnyrecon  And there is a solution on the comment section : simply swich off the Platronics Hub, and everything working perfetctly... thank you 

@Tauron112 i think it is not a realy solution, than a workaround :-). But for the moment this helps the users.

@Johnyrecon I had the same problem and the hub work around worked until today when the mute stopped working again. I can't see any update from Poly or MS to properly resolve this so if anyone has foumnd a solution ...