Email a Channel not working

Super Contributor

Anyone else experiencing emailing a Channel  not working.  We have it enabled but when I email a channel it does not post in the channel

25 Replies
Working for me. Just tested it in both my own and a GA test tenant.

1.) Have you literally just enabled it in the TAC? Could be a propagation time
2.) Do you have any smarthosts which sit in front of Exchange Online? May be interferring

Best, Chris

@Christopher Hoard Hi Chris, it has been enabled since we started using teams (back last year), and we don't have any smarthosts.


I can trace the message and it has been sent to the correct email


Just done a little more testing and have found a channel that I can email, but other channels within that Team I can't.  All the channels were setup months ago (it's our testing channel).!



Ah ok, there are a few more reasons

- The feature is not enabled by your IT admin
- The channel settings restrict who can send email
- The email contains more than 50 inline images.
- The email has more than 20 file attachments.
- The email has an attachment that's more than 10 MB.
- The SharePoint folder associated with the channel has been deleted or renamed

I would say it's more likely in generic cases to be 1, 2 or 6. Have either 2 or 6 occurred in consideration some do work and some don't

Best, Chris
best response confirmed by Christopher Hoard (MVP)

@Christopher Hoard Hi Chris, many thanks i had checked those.  I tested with a simply email.  However i have got it working by doing the following (tested this many times).


Edit the channel, made a change to the description just so i could save the channel again - then it worked fine :)


Not sure what that is all about!

Awesome. Good to know for the future :D

@Tanya Denton I tested some now and were not able to send e-mail either. Then I read that you edited the channel description and I did the same and it started to work. But I also had this problem on General channels, so there I changed permissions and it started to work.


The tenant I tested on with problem was a EMEA tenant, I tested the same to a tenant with address and no problems there.

Our company is having issues emailing channels as well. It started for us yesterday at around 8 am eastern. I had emails that would show up instantly in outlook if I CCed myself on them, but would take 6 hours to show up in the Teams channel. 

@Tanya Denton I'm having the same issues. No emails coming into Channels. This was working yesterday without an issue. I have a support ticket open, but no answer. Very frustrating.

@derekrocco12 Tested and confirmed that our email-to-channel flow is failing to several channels in our tenant, from senders who historically have been able to use this feature.  Last successful usage of email-to-channel for us was last night, 5-Feb-2020 @ 17:20 MST (GMT -7).  I also will be opening a ticket with M365 support to diagnose.

@mcat_greystone Thanks for posting this as mine are working but only if I email from Outlook direct, having resaved the channel.  However we have emails from a shared mailbox that have rules set up to forward certain emails to a channel - this is not working.  I wonder if this issue relates to the expired

authentication certificate incident earlier in the week?  Have you tried resaving your flows which may ask you to authenticate again?
BTW we have an azure logic app that posts Microsoft Incidents to multiple channels within a Team and that is still running fine.

@mcat_greystone Yep that is about the same time ours stopped working as well. I've also tried via my test tenant, and it is broken as well.

Ah, in my case, we are not leveraging actual MS Flow, so no reauthentication necessary. We have either our ticketing system or individual users sending a message to each channel's <alphanumeric>.<domain> directly

@mcat_greystone  Same thing with me. No flow

@Tanya Denton There is a Service Health Advisory for this now. 

I you have a support ticket number share it with MSFT365Status so they can review the escalation.

Posted mine (18613598) to the Twitter feed

@mcat_greystone Sorry only just had time to submit a support ticket.  Mine is #‎18615922 will tweet as well.

@Tanya Denton So update, this started working as of 8pm. Thanks for banding together on this one all!

Also confirmed that we are repaired as of this morning.  Cheers all!