Cannot Join Teams Meeting via Desktop Client on Mac

New Contributor

Hello. I have been successfully using Teams via the desktop app on my Macbook for the last two months.  Starting suddenly last week, I can no longer join a call/meeting. I am getting a "cannot connect to call" error.  I have uninstalled and reinstalled the app multiple times.  I have to use the web client, and that only lets me see video of the person speaking, not everyone. Is there a way to restore functionality on the desktop app?  Thanks for any insight!

15 Replies



Maybe try creating a new mac user profile.  Login with that and try and reinstall and login to Teams from there.  Not a solution I know, but at least it will show if it is profile specific or not.

Maybe there is some trouble shooting with your wifi connection. Try to disconnect and reconnect and then restart your system.
This Video Include Tips on:How to disable GPU hardware acceleration in MS TEAMS?How to Clear Teams cache........................................................

@SonaliMazumdar6  Good suggestion, but no luck.  Thank you.  What did end up working was multiple uninstall, restart, reinstall rounds. 



I’ve been have this issue too for about a week now. I’ve tried restarting my MBP, reinstalling Teams, signing out and signing back in. Nothing works. I’m getting by with the iOS app for now but I cannot share my laptop screen.


Hi @bitoven , I have the same issue too, when I try to join a meeting, the app will say"We ran a problem, try again in a few minutes". Are you fix it now?



Are your MacBooks up to date with the latest Mac OS and also up to date Teams client?

@PeterRising  No, I didn't update my iMac to date with the latest Mac OS, but up to date Teams client. So I need to update my iMac OS right? 

Yes you have to update!



Yes, I would recommend getting your Mac up to date too.

@Echo_g hi I have exactly the same with you. Did you manage it already? I've updated Mac os at the most recent version but it didn't help..

My Mac systems are up to date.  About a week or so ago, the Teams app suddenly stopped connecting. All other internet services work and I can connect to Teams using iOS or using the web version.  It is only the app that doesn't work.  I tried completely deleting the app, reinstalling, and it did work once, but then stopped connecting.  Only the Teams app is affected.  Cisco, Citrix, Podio, Zoom, Google Meet, Bluejeans and others work fine. @PeterRising 

I am experiencing the exact same issue - did you manage to sort it out? Thanks! @hwashcraft 

@hwashcraft I am having the same issue.  Teams is not connecting.  I have deleted and reinstalled several times and deleted cache, no luck.  Any suggestions?


I have the same problem, I cannot make a call, cannot receive a call nor Join a meeting on team.

I checked the system preference /security& privacy and I found that there was no entry for MS team in [Camera]. I didn't know how to put it in.

I tried to get MAc updated and now my Mac is up to date. the problem is resolved. I can make a team call now.


So you can try and I hope it works for you too.


+ go to [about this Mac] / Software update ...


good luck! (*.*)