Forms GCC Outage?

Copper Contributor

Is anyone else experiencing a GCC Forms outage? We sent out a survey through forms last week and now we are receiving multiple reports that when they click on the link it says "Sorry, something went wrong". I receive the same error when I try to get to Forms through the waffle

20 Replies

@AmandaLRoberts Yes, my Forms stopped working last week Friday during the middle of our surveying. The forms were working Monday-Thursday and then stopped. Here's the Technical details: 


Session id: 8d9347a3-c86e-45e2-8e32-456c74fa18e1, Correlation id: bc6a08fb-5b55-4a3d-be62-2a4220ac2d0a


Yep same for our GCC account. @AmandaLRoberts 


Yes, same here.  I noticed it on Friday 8/9/19;  Created a Service Ticket with MS about 9 am.  Have been playing phone tag with them ever since.


Have not connected with them yet today or heard anything about an ETA.  An update would be nice from somebody from MS.  O365 Status does not call out Forms.

@AmandaLRoberts  It looks like ours just came back online for GCC. Hopefully that resolves it for most.


I thought so as well.  Funny thing, MS just called me back and of course it looked like it as working.  I'm in GCC and the form I'm using is utilizing the option "Anyone with the link can respond".  So, if you are logged in, it seems to work, but if you log out and go anonymous, it hangs like before.  So, I'm wondering if this "feature" broke, as it recently rolled out in GCC.

I can edit the Form now, but it's still not accessible to my users. 

@AmandaLRoberts  YES. Having similar issues.  "Something went wrong" keeps showing up. For some users, the link creates a spinning dotted wheel  (Forms loading message)...

is everyone still having this issue? or has it been resolved? I haven't been able to successfully share my forms yet...

@Warwickshire We are experiencing the same issue.  Form does not load when accessed through the link to complete the survey.  Our for is internal only, and does not prompt for credentials.  I opened a support ticket Friday, ran diagnostics and uploaded files for support.  Current status is agent assigned and the logs forwarded to support team.

I did notice it working this morning for a little while.

Seems to be working now but you need to clear your browser cache (or open a private browser session). Looks like it was an authentication issue.


Thanks mhenniger.  That seemed to make things work for me.  As the user base for my solution are volunteers, not exactly sure how to instruct them how to do this.  Hopefully, session will expire after some point and not continue.  Will see of closing down and opening up a new/different browser will get around this.  It's a shame with the community has to explain solutions to you rather than MS.


Any idea  how to get around a user having to clear their cache or run in a private browser.  Without having to change the actual form being used?   Will experiment around with a couple of things as well.


Thanks again for pointing this out.

@bh56y'all may want to continue to kep an eye on these forms.  It is still not working for us.  We have a ticket opened with MSFT on this to see what might be happening.  Its seems to be on & Off. very flaky..


Yes, thanks for the heads up.  I've had a support ticket open with MS since Friday.  Been going round and round.

Yes, results are flaky.  I now was not able to get back into the forms, as an authenticated user to manage the form.  Unauthenticated user still works, once cache was cleared.

Keeping an eye on things.  Will let the group know if I hear anything back from MS or things get better/more predictable.

Getting my users to click on a link to take a survey is challenging enough (25% response rate so far).


But asking users to clear a cache first, then take a survey? I won't bother, I'll find another survey tool to use (my 2¢)



Agreed.  If MS "fixed" the issue, they should be able to "clear" things, so end users don't have to clear their cache.  Limited functionality.  Poor SLA.  Gotta questions if this is a platform you want to hook your wagon to.

Still no word from MS.  Unless I clear the cache, my anonymous form still hangs.

Did everyone else just work around this?

@bh56  This resolved itself for us on Wednesday 8/14/2019.  We have not  had any issues since.  No idea of how, who or what happened to resolve it but it happened.

We are still experiencing the issue. 


Looks like it might have been resolved?  Still no word from MS.

The browser I was testing with(anonymous, still cached), seems to work now.  Can anyone else confirm this?