SOLVED

Win 11 (on Lenovo Flex 5) won't connect to MS Display Adapter (V.2.0.8350)

Copper Contributor

Hi there,

 

I recently bought a brand-new laptop Lenovo Flex 5 (2-in-1) to use in my classroom (I am a teacher) to display and manage my lessons directly on a projector that has a MS wireless display adapter (V2) on it.
This Lenovo Flex 5 won't connect to the display adapter no matter what I did.

My other laptop that has win 10 on it connects no problem. But the new laptop Lenovo Flex 5 with win 11 won't.

I followed pretty much all recommended actions online including the one recommended by Microsoft.

 

Microsoft Support troubleshooting MS Widi 

 

and

 

Guiding Tech fix (wireless display feature not working on windows 11) 

 

I also got all the available Win 11 updates, checked and updated all possible display adapters. We got the most recent chipset drivers from the Lenovo website and installed it thinking it might have helped.

 

Then, I got a brand-new MS-Widi adapter (V2) just to rule out that something in the old MS-Widi might not be compatible with the Win 11. Still not connected.
I tried my friend's laptop (another brand) with Win 11 on it, and it connected.  

You may be tempted to say that there is a hardware issue on the new Lenovo Flex 5, And I would say no because it connects to SAMSUNG tv's built-in wireless adapter, it connects to ROKU TV no problem. :suprised:

It just won't connect to the Widi adapter made by the same company (Microsoft) that made the Operating System (Windows 11). How ridiculous is that? :facepalm:

 

I am out of options, and I have a few days left on the return window. If I can't make this work, I will have to return the laptop. The seller wanted me to do a fresh clean install of Windows 11 which I am not comfortable of doing. But instead, I performed the Windows Reset from Cloud (Remove my Files Option) which took almost an hour and pretty much factory reset the PC. Still NO GO. :cry:

 

Do you guys have any suggestion before returning this Laptop back. It is a great machine, I like it and would like to keep it, but I need it to work for me. It currently does not.

 

Thanks

10 Replies
Firstly, open start and search for feedback and open the Feedback Hub app and report this issue.
I also advise you to contact the Lenovo support.

@Reza_Ameri 

 

Thank you for your response. I am not familiar with how to use the feedback hub but I posted the same on Lenovo Support Community. I am curious to see what they say.

This might very well be a Lenovo issue rather than Windows 11.

 

Lenovo Support Forum link 

 

 

 

 

 

You may open start and search for feedback and open Feedback Hub app and then you have option to report a problem and just fill up the form and explain issue and submit it. If you have any issue in tis process, let me know.
Thanks again Reza. I figured out what the Feedback Hub is and successfully used it to upload all the details of my problem including a screen shot and a small recording. A nice feature of windows but not sure how soon I am going to get a result.
After reading some others' comments on how much problem they got with the MSWirelessDisplayAdapter, I lost my confidence in this adapter unit.
At this moment, I am still not sure if the issue is caused by Windows 11 or by the Lenovo Flex 5 Laptop. I have a few days left before the return window expires. If the issue is windows 11, I would keep the laptop. However, if it is a laptop issue, then returning it is a better route. How am I going to figure this out in 2 days?
Most likely you won't receive response in two days.
Your issue among with other issues will be reviewed and it might take some time to investigate and test and release a fix (if that is the Windows issue).
You may contact the Lenovo support team and check with them.
best response confirmed by Alex-iskoos (Copper Contributor)
Solution

Hi Reza,

I solved the problem :) Yes, it is solved, and I am very happy :)
The issue was the MSDisplayAdapter's firmware V.2.0.8350. Once I upgraded to the V.2.0.8442, the Lenovo successfully connected to it.
You may ask why I didn't upgrade the Widi firmware before. I tried many times with my other laptop that has Windows 10 on it. Because it was able to connect to the Widi adapter ,and I was able to use the MSDisplayAdapter app. However, it wasn't updating the firmware when I picked the "Update & Security" tab. It was just hanging and doing nothing. I was under the assumption that I already had the most recent firmware in the display adapter.
When I was using the app the other day (connected with Windows 10 from my other laptop) and desperately trying everything, looking for a solution. I left it connected for like an hour or so. And out of the blue, I tried to click on "Update & Security" tab thinking I would still get to nowhere. All of a sudden, it showed me that there was an available update. This had never happened before. It was showing the firmware V.2.0.8442 as available. It didn't say anything about Win 11 fix on "What's new on this version", but I went ahead and upgraded to it. Then I tried to connect the Lenovo and it connected immediately. :)
Wow, it is a huge relief. I now got to keep the laptop. It wasn't the Lenovo issue. It was the display adapter's firmware V.2.0.8350. For some reason this firmware (V.2.0.8350) has an issue when used with Lenovo laptops. I was able to connect to this firmware with a Win 11 from another brand laptop without a problem, and also from any laptop with Win 10 in it. But NOT with my Lenovo laptop.
V.2.0.8442 fixed this problem. And it added some nice wall papers to the Display Adapter.

Hope this post would help other people having this issue. And they would be able to fix it quickly. Due to the roadblocks at every step, I tried, it took me days to fix this problem. And I almost couldn't fix it.
Thank you for your help.

@Alex-iskoos  

Hi, thank you for posting how you managed to fix this -> I think you should mark your last post as (best answer) it will be helpful for other users.

Best regards

Hi A1,

I just did what you recommended.
Thanks

@Alex-iskoos  

Thank you, there are many posts that are not tagged - this causes other users to not find a solution ( because the post is not visible!

You are welcome at MTC. :)

Thank you for the update and glad the problem have been solved
1 best response

Accepted Solutions
best response confirmed by Alex-iskoos (Copper Contributor)
Solution

Hi Reza,

I solved the problem :) Yes, it is solved, and I am very happy :)
The issue was the MSDisplayAdapter's firmware V.2.0.8350. Once I upgraded to the V.2.0.8442, the Lenovo successfully connected to it.
You may ask why I didn't upgrade the Widi firmware before. I tried many times with my other laptop that has Windows 10 on it. Because it was able to connect to the Widi adapter ,and I was able to use the MSDisplayAdapter app. However, it wasn't updating the firmware when I picked the "Update & Security" tab. It was just hanging and doing nothing. I was under the assumption that I already had the most recent firmware in the display adapter.
When I was using the app the other day (connected with Windows 10 from my other laptop) and desperately trying everything, looking for a solution. I left it connected for like an hour or so. And out of the blue, I tried to click on "Update & Security" tab thinking I would still get to nowhere. All of a sudden, it showed me that there was an available update. This had never happened before. It was showing the firmware V.2.0.8442 as available. It didn't say anything about Win 11 fix on "What's new on this version", but I went ahead and upgraded to it. Then I tried to connect the Lenovo and it connected immediately. :)
Wow, it is a huge relief. I now got to keep the laptop. It wasn't the Lenovo issue. It was the display adapter's firmware V.2.0.8350. For some reason this firmware (V.2.0.8350) has an issue when used with Lenovo laptops. I was able to connect to this firmware with a Win 11 from another brand laptop without a problem, and also from any laptop with Win 10 in it. But NOT with my Lenovo laptop.
V.2.0.8442 fixed this problem. And it added some nice wall papers to the Display Adapter.

Hope this post would help other people having this issue. And they would be able to fix it quickly. Due to the roadblocks at every step, I tried, it took me days to fix this problem. And I almost couldn't fix it.
Thank you for your help.

View solution in original post