Unable to share a document from Word

Brass Contributor

Hi guys,


I've been working on trying to share documents from Office, and when I click share and choose another person from the organization, I get the attached error: "Sorry, we're having trouble connecting to OneDrive."

My sync client works fine, and I can share and collaborate in the browser too, but I just can't kick off the sharing from Office.

I'm using Office ProPlus Version 1704, Build 8067.2115 Click-to-run. Several other people in my company have the same issue.


Any help is welcome, especially as this is something I want to show off to our customer!

8 Replies

Can you please confirm that the relevant option is selected in the Office tab of the NGSC settings?

Hi Salvatore,


In the Office tab I have "Use Office 2016 to sync Office files that I open" and also under Sync conflicts (if relevant) I have the let me choose option selected.

Thanks for your response.

First time I see this error...no problems here when sharing files from Office

I have the same Office version as you mention, running OneDrive version 2016 build 17.3.6799.0327 and it works fine at my computer. 

Think you need to contact MS support and start troubleshooting with them.

Hi John,


I just wanted to check-in and see if you were able to resolve this issue (or had any luck with Microsoft support). Thanks!


Stephen Rice

OneDrive Program Manager II

Hi Stephen,


I just tried with a couple of other people in the office, one who has version 1701 and build 7766.2084, and they were able to get it to work. However myself and another colleague, who both have the same version, have the same problem.

I'll try and open a ticket later (I don't have access to the admin console).




Hi John,


Please let me know how that goes! Thanks!


Stephen Rice

Hi @John Marshall, this issue came out of nowhere for two of our users last week. What was the solution for this? I know it was years ago--just trying to implement a known solution to see if that does the trick, thank you!


Our environment is using Version 2305 Build 16501.20210 C2R. Have tried quick repairing Word and ran sfc /scannow thinking it was involving a corrupted file.