Teams call controls on jabra headset not working

New Contributor

Hi, 

 

I recently bought a new Jabra Evolve 75 headset to replace my old wired plantronics set. I purchased the Microsoft version of the headset, which is supposed to have better integration with Microsoft products such as Teams. It's a great product, but while i can change volume and mute calls using the headset controls, I can't accept or close a call, which is annoying. I've been in touch with Jabra support for last few days and reviewed all settings, but they have concluded it's nothing to do with the headset (as it works fine on my softphone client), and must be a Microsoft problem. 

 

Do you have any suggestions to sort this problem or is it a case of waiting and hoping for a new software update that will resolve the issue at some point in the future?

 

Cheers

94 Replies

@owler_77 

Just wanted to say, I am experiencing exactly the same issue with my Bluetooth Plantronics Voyager 5200 series headset. Cannot Answer call and cannot End call. 

If I press answer button while having Teams window in background, Teams window is activated and put in focus.

We have this same problem with all clients at office with different types of headset.

@owler_77I'm having the same issue with the same headset. It's been working flawlessly for months, but, a couple of weeks ago the Answer/End Call buttons stopped working in Teams. I've updated firmware for both the headset and the Link and uninstalled/reinstalled Jabra Direct. No change.

Hi,

I’ve been in contact with plantronic support. They say that Microsoft states that if Teams run in island mode that device controls are not supported or that issues with it are known.
I have tried to set my client to teams only mode and now I wait on changes to apply so I can test.

Same here with Jabra Evolve 80 Link.

 

Update:

I think I found out why this happened, and it is not good news. In fact it seems that the regression may have been intentional: https://techcommunity.microsoft.com/t5/microsoft-teams-blog/introducing-new-teams-certified-devices/...

@MaWest  What annoys me is that the likes of Jabra and Plantronics sell this functionality, but they don't seem to be pushing the issue with Microsoft on our behalf. Meanwhile, their customers have to spend wasted hours, fiddling with settings, deleting/reinstalling, calling customer support, turning machine off and on etc. with zero success! The last message I recieved from Jabra, was that it looks like a Microsoft issue, so to wait for an update to resolve it. :facepalm:

same here. My Jabra 75 has worked flawlessly for 6 months and latest Teams update seems to have broken the call pickup and hangup button. I have verified everyone on my team is having the same issue as well so it has to be a bigger problem

@owler_77You are right. I had a wireless headset that was excellent. I replaced it by a Jabber Evolve because I didn't have to dig through computer screens to open from MS Teams.

That is no longer the case.

@owler_77 

 

Exactly same here we bought 500 new Jabra devices 3 months ago now all are bricked and we rely on the Call Pickup and Hangup .. 

 

Its 150k worth of headsets thats just going down the drain! :(

 

REALLY hope that there will be some kind of interest in fixing this ..

Hi All,

 

After moving from Teams mode: "Island mode" to "Teams Only" most of our office clients (including my own) are working.

So I can recommend moving to "Teams Only mode, which seems to be the general problem for things not working.

Similar problem here, also with Jabra headsets.

Some users work perfectly, some just refuse to work, and 2 are our most senior partners.

I really need a solution?

@MaWest
Thank you for the suggestion. I passed it on to our IT people. Unfortunately, our current global configuration requires use of 'island' mode.

@Danny_B705 

 

Same issue.. had a client with several Evolve 75's that all of a sudden the control buttons stopped working.  Nothing changed, except presumably the rando teams client & windows updates that get shoved out.  Did the usual, upgraded jabra xpress, upgraded FW in headset/USB dongle.. no change.  Client is and has been in teams-only mode too, so that theory is out.

 

I opened ticket with MS... gave them background and all pertinent info.  They immediately tried closing ticket saying they don't support hardware, can't buy it and it's not certified.  I said, this is a certified device and sent him link to it on MS store under teams devices.  He continued to deflect and say ok, it's certified, but not supported.  What does that even mean?  His next play was to close ticket out on the premise that I wasn't onsite to test (i had worked with client beforehand extensively to head off all of this, but i digress).. so I set him up with client today for them to test directly.  He came back and said, client is using unsupported BT dock and they are closing ticket.  I said, no, they are using the jabralink 370 usb adapter that came with the headset.  No reply yet...

 

I also opened a ticket with jabra last week as well, and they seemed more willing to engage at first, but then they said "you have to uninstall SfB" to which I said "love to, but it's baked into o365 install, so I can't, but it's definitely shutdown and not running".  Then they gave the "oh, you can't be in islands mode" and i said "yeah, not the case here either.. next?" and radio silence.  

 

Jabra xpress does detect headset fine, and it shows teams as 'ready', so to that extent it's working fine.  Audio is fine too.  If i had to guess, MS changed API used for these apps to pass button controls to and didn't tell anyone in the fury of busted, untested updates they like to push for windows/teams these days.  This is in addition to the (8!) PSTN service outages on teams voice in the past 2 weeks.

 

Client is getting irked and wants out, and I don't blame them at this point.  It's embarrassing for me, and they are hugely dependent on reliable phones due to the nature of their business.  I understand issues happen, but this deflective and dismissive attitude when issues arise is unacceptable.

Jabra support is saying that the call control buttons (answer, hangup, etc) will only work if you have teams enabled as a full PBX (to allow out bound calling to external numbers, etc) Is anyone running teams just for meetings and teams-teams calls and able to get the call control buttons to work? Would be nice to be able to hit the "hang up" button to be able to end meetings without having to go to the teams app on the pc.

Since a couple of days it working!

@dheuts Are you using teams in full PBX mode where users can dial out to external numbers? Or just using it in teams mode where you can only call other teams users and join meetings?

@DanGuterman 

 

That's a cop out.. they told me same thing.  To the extent of call control, it doesn't matter for teams to answer an incoming call or hang up an active one.  In one environment, it worked without PSTN.

 

However, one of my clients does have full PSTN service (phone system) and it's not working there either..

Ok.. what version of teams, jabra direct, firmware & windows are you on? :)

@libby2cm 

This is what Jabra support reported to me

"The omission of dialpad implies HID command string coding, which dictates remote call control; ringtone to headset with answer/end from headset equipment is not in part or fully accessible in the Teams client.  What signal the Jabra is being presented that is causing it's awareness would require ID by MS. "

We're on teams 1.3.00.19173

Windows 10 1909 (18363.900)

Jabra Direct 4.0.8560

@DanGuterman 

 

Ok, but it worked a few weeks ago is the thing.

 

I tested today again.  I uninstalled teams, wiped out all app data folders, etc., (including machine wide teams installer) then reinstalled just teams client which was 1.3.00.15561.  I tested Jabra 9470 and logitech BCC950 from test account using test call from my clients tenant that was PSTN enabled, controls seemed to work (teams native mode).  I tried from my tenant with my user account, NO PSTN, teams native mode... controls seemed to work.  I tried from another tenant in island mode, controls DIDN'T work.  I upgraded teams client to 1.3.00.19173 by forcing update in teams client, didn't impact any above results.

 

I have client testing again now.  Current hypothesis is island mode isn't supported at all now (which, I still say there is a problem, as they did work with that tenant at least a few mos back).  And, in native teams tenant, uninstalling teams client and teams-wide installer, cleaning up all traces of data directories, and reinstalling, may fix it.

 

I think MS just has lost all insights into how the code works so they just point fingers wherever they can.  Look at Windows QC as a reference point...

 

I'm all for 'move fast and break things' not 'move fast, break things, gaslight customers by claiming they never worked, blame customer, ignore issue'...