SOLVED

Select my Background option not visible in my MS Teams

Occasional Contributor

Hi,

 

I have two laptops from work , don't seem to have "Select my Background option" visible in my MS Teams in one of them. For that particular model of the laptop no one in the company seems to have it.

 

I still have blur video option though. MS teams is updated on both systems. Both on Same O.S

 

Few devices in our company have it , majority don't. 

 

1. If it's done on the tenant level i assume everyone should get it at the same time. As one company should be under one Tennat- is that correct ? 

2. If it's account based then i understand it's probably rolled out to few accounts (i mean user accounts).

 

Is there a way to check how MS is doing that because users who have real high end devices have it working on their devices. The other devices we have are not at all old though but less fancy configuration

61 Replies
Microsoft has just rolled out the background feature so it might happen you have not received yet in your tenant

@Yadwinder1130 

 

Verify that your hardware meets the technical requirements: https://docs.microsoft.com/en-us/microsoftteams/hardware-requirements-for-the-teams-app

__

For a better experience with video calls and online meetings, we recommend using a computer that has a 2.0 GHz processor and 4.0 GB RAM (or higher).

  • The optional Blur my background video effect requires a processor with Advanced Vector Extensions 2 (AVX2) support. See Hardware decoder and encoder driver recommendations for a list of unsupported decoders and encoders.
  • Joining a meeting using proximity detection in a Microsoft Teams Room requires Bluetooth LE, which requires Bluetooth to be enabled on the client device, and for Windows clients requires the 64-bit Teams client. It's not available on 32-bit Teams clients.

Hi @Yadwinder1130 

 

In addition to the requirement mentioned by other folks. Also check in case you have the latest version of Microsoft Teams Client on the Laptop. The Background Option is working with the Version 1.3.00.8663 on the Windows Machine.

 

With Regards,

Satish U

@Satish2805  I have checked that my version is 1.3.008663, that my PC more than satisfies the CPU and memory requirements (12GB memory 3.3Ghz CPU) but this option still does not appear when I click on ... Others at my work have the same version and it works for them.

 

At the time I am on Teams on my home PC, I am usually also connected to my work desktop remotely via RDP - would that matter?

@DideeFur0531 

 

I connect to my laptop through RDP and I can still use the background effects.  I'm with the others, it could just be your tenant... Has it started working yet?

Same problem here. Other users in my tenancy have the backgrounds option. I also checked folder location on my local drive and not there. My Windows 10 machine is at least 5 years old, though. All other features of Teams appear to work

Seems to be a massive bug here Microsoft isn't addressing.

 

We have thirty computers in our group and all the exact same hardware / age and all have Teams 1.3.00.12058 installed. 23 have the "show background effects" option, 7 do not. Sad that after so many years it's still the same old Microsoft.

@Yadwinder1130 

Same with our tenant. I just put in a ticket to see if we can understand why. It's totally random. Out of 400 staff there is no explanation as to why some have the ability and others don't. I compared myself to my boss and 5 others with the exact same model laptop and all the exact same version of Teams, I don't have the feature, my boss does, and 1 other but 2 others don't. 2 in our IT dept received it but the rest did not. Frustrating not understanding the root of that.

@DideeFur0531 

It is not about CPU GBs or RAM, the main issue could be that your CPU do not support AVX2.

To check go here: https://ark.intel.com/content/www/us/en/ark.html

In the "Search Specification" search box write your CPU model (i.e: i7-4590U) and hit enter.

Under "Advanced Technologies" check what does it say for "Instruction Set Extensions".

Does it support AVX2 or just AVX?

@Tony999 You are correct - my CPU is an older i5-2500 and only has AVX.

Many thanks for the info.

@Tony999 I have AVX2, still I get only blur option. No option to change background on my macbook pro. Any idea?

@Srishti333  I'm sorry i'm not too familiar with Macbooks but technically the blur function and background effects uses the same technologies (it is just a blurred image set as your background) I find it weird that you have one and not the other.

The CPU requirement of AVX2 is the most common problem but there are other requirements too for your graphic card and your camera but those are usually met.

Try going to Application Support ->  Microsoft ->  Teams -> Backgrounds ->  Uploads

Can you find the Backrounds folder? can you find the Uploads folder? if yes try to put some picture there, restart teams and test. Note use the blur function at least one time before checking if the folder exist, you can just create a new meeting and activate the blur function and then close.

@Yadwinder1130 

 

This worked for me:

 

1. user file explorer to navigate to: %APPDATA%\Microsoft\Teams\Backgrounds\Uploads

2. if the folder structure doesn't exist - create it. 

3. drop a picture in there

4. restart 

5. option now showing

 

Hope this helps!

Jaco

@jacobos007 

 

Does not work for me. Maybe AVX2 is the problem - my Sony VAIO VPC is at least 6 years old

Thanks, all 

Thanks! Your guid work well for me.

@jacobos007 
Our machines that still do not have this option are all using the following processor: Intel® Core™ i7-8850H.

 

No folders named ...Backgrounds\Uploads are there already. And even if we create those new folders and restart, still no background options.

 

Any more ideas guys?

I am in the same boat here. I have a Processor that is 100% AVX2 enabled. I'm on the latest version on Teams. I have created the folder structure (and added a picture) since it didn't exist. All the things. No luck. 

 

I have another PC that is way older and worked from Day 1 with the Background effects options. 

 

Anything else I'm missing? I even uninstalled/reinstalled Teams. 

Does anyone have a similar instructional/step-by-step fix for Macs? I have the same issue as everyone else - other colleagues have the option except for me, uninstalled/installed/restarted to no success, have pretty "recent" iMac (2012 model - though with new HD and extended RAM) desktop with above average specs.

I think I have a similarly related issue in that the 3x3 video has not become available for me, yet identical users on our same tenancy with same spec laptops and same spec Teams client installations have got the feature and have had it since last week.  I get the distinct impression that "something" in the roll out to tenancies then also has a slow-ish roll out through all users.  Perhaps the same issue is there for the backgrounds referenced on this thread.