SOLVED

"This username may be incorrect. Enter a different one or create a new one."

Occasional Visitor

I have a Teams personal (free) classic account.  As the first user with the @MyCompanyName, I was automatically made admin of that org.  I have added others to my org by going through "manage org" and sending email invites.  The recipients are addresses are eternal addresses (my company's, who is NOT related to any MS email accounts).  These users do NOT have any form of Teams accounts.  

 

When we set this up originally a good while ago, the users would get an email invite, with a link to click.  It would then let them log into Teams and setup a password.  This has worked for some time with no problem.

 

I have tried to invite a new user recently (same setup as before, no Teams account of their own and external address).  If I send it to email address removed for privacy reasons, the user can get the email link, then a code and is signed in.  If they log out, they can simply sign in later by using their email address, but this time, they have no option to use a password, but instead, they are only allowed to send a new code to their @yahoo account, but this DOES allow them to get in that way.

 

I have one more new person that I tried to invite.  He has a @MyCompanyName address the same as me.  He gets an email with a link, then is required to get a code via email.  However, once he logs in, it shows that Teams is not available for him and to contact the administrator of my company to enable it. (This makes no sense since there is no administrator, as my Teams is a personal account, not tied in with Azure, O365, or anything like that).  Finally, if he tries to login again, it simply says his account is not found.  There are no options for a password, nor a code sent to his email.

 

It is my hypothesis that this user's account has somehow been tied to someone else's tenant. (He has used his email address to participate in a conference last summer).  I had him contact the person who hosted the event, but they have no technical skills and no IT staff to assist us.  Is it possible that his account is somehow tied as an external to someone else's tenant/Azure and is causing problems?  If so, how can this be resolved?  Any help is greatly appreciated.

1 Reply
best response confirmed by StaceeFrane (Microsoft)
Solution

The Email one-time passcode feature is enabled by default for all tenants now. That explains the code being sent. It's for those not using a Microsoft identity so they don't have to create a new Microsoft account to access another tenant, but still have a guest account created in the resource (inviting) org.

You cannot manage anything through the admin centers as you mention using Teams free (classic), but you can access https://portal.azure.com/ and manage your tenant. Just sign in with your account associated with the Teams free admin account.

Bear in mind Microsoft has moved away from the "classic" orgs. and they cannot be created anymore. So, Teams free today is something different as you might have noticed.

 

As for the issue, it’s most likely cached credentials. Have him use InPrivate mode or Incognito. Or clear the Teams cache by signing out manually/quit the app.

Hope it helps!