MTR device gets thrown back to the login page after clicking on the "Sign-in" button.

Occasional Contributor

My CTP18 Yealink device gets stuck at the Company Portal page or the system gets thrown back to the login page after clicking on the "Sign-in" button. I see the progress bar with white background that registers device, after which nothing happens and I get to sign in again.

Things tried:

Firmware & Factory Reset
MFA Inactivated 
Licenced Teams Room Standard

Excluded all Conditional Access

Excluded all Intune Compliance (though A20 Meetingbar signs in fine w/ same account as AAD registered)
On same LAN, connected to internet
Allow acc to Azure AD Join devices with limit of 50 devices
Sign In with token


3 Replies
Have you tried signing into a test tenant where are no CA policies or device compliance rules in place?

@Graham Walsh 

As the A20 is an Android device, the solution was to allow the Android Device Manager via the Endpoint manager for both company owned and BYOD devices:

There's also an arbitrary limit on the number of devices an account can enroll (15) these records are apparently only deleted once every 30 days or so.

There's another menu blade somewhere in the endpoint manager which shows device

enrollment failures, where you can search for the account get a clue what the error might be, though I do not know how to navigate to it (before you could access it from the home page)

Hope this helps anyone with the same issue.

My recommendation is to pull out the device logs from the Teams admin center and and vendor specific logs, and contact the manufacturer of the device, as the error codes are not user friendly, and , evidently, Microsoft provides no end user error codes to distinguish between the dozens of errors which can happen during enrollment 
(Such as conditional access, enrollment restrictions, Azure resgistration restriction, Intune Registration restrictions, device enrollment limits) 
as in my case the MTR device just looped back to the login screen. 


Thanks for that info, will certainly help others. As for looking at issues, I find it best to look for the user/room account in Endpoint Manager you are trying to troubleshoot, you can then see the failures in that blade.