MS Teams forcing to use old account

New Contributor

I have MS Teams installed on my laptop (MacBook pro) .  I have an account on it I want to remove and use a different one.  It keeps forcing me to login to the old account and won't let me add the new one.  I have done this successfully on my iphone installation but can't make the change on the laptop. 

5 Replies

@DNM001 : Hi, have you tried to delete old account from your MacBook ?

 

  1. Select Finder > Applications > Utilities > Keychain Access.

  2. Right-click the account that you want to remove.

  3. Select Delete [account name].

If you find this response useful, mark it best response

@Surya_Pammi 

 

Thanks for trying but it had no effect.  When I log in here I see all the accounts i have had, but when I load MS Teams it pushes up a notification saying it will send an access code to my last account, but won't let me do anything else at all.  Its very weird.  If I load Teams via the web rather than the app it works, as it does on my cell phone where I can select the account I want.  I think the issues lies within MS Office online somehow.  I may well just try and delete and reinstall, but i suspect that wot make any difference as it will pick up the old information,

 

cheers

david

@DNM001 

 

Could you try to clear the Microsoft Teams cache. 

Clear Teams cache in macOS

  1. If Teams is still running, right-click the Teams icon in the dock, and then select Quit, or press Command (⌘)-Q.

  2. In the Finder, open the /Applications/Utilities folder, and then double-click Terminal.

  3. Enter the following command, and then press Return:

    rm -r ~/Library/Application\ Support/Microsoft/Teams
  4. Restart Teams.

 

reference: https://docs.microsoft.com/en-us/microsoftteams/troubleshoot/teams-administration/clear-teams-cache#...

 

 

let me know if this fixed it :grinning_face: 

 

regards,

Mitchell

As it happens I managed to get it working, but I am not sure how I managed it. Thanks for responding and I will keep this for dealing with future problems, Cheers. :)
Could you please select one of the above comments and mark it as answered?

Thanks :grinning_face: